Solved

How do I join a NAS Buffalo LinkStation to the domain?

Posted on 2008-10-15
8
11,081 Views
1 Endorsement
Last Modified: 2013-11-14
I recently purchased a Buffalo LinkStation Pro LS-1000GL NAS to be used as additional storage on my network.  In the Workgroup/Domain Properties, I have correctly entered the Active Directory NetBIOS name, AD domain name, AD domain controller name, administrator username & password, and the correct WINS server IP address.  I have also followed the steps outlined on Buffalo's website about how to configure the NAS for Active Directory.  Initially, authentication seems to be working, but I keep getting an error message that says: "Failed to join Active Directory Domain.
Please confirm the Active Directory Domain setting information, Administrator user name and password." I

Also, on the home page of the management software, I get a warning message that says: "Access permission for the domain controller is invalid."  Do you have any idea of what might be causing these problems?
Buffalo-NAS.doc
1
Comment
Question by:CityOfRome
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 8

Expert Comment

by:sstone55423
ID: 22720619
This does look like an authentication issue.  It seems like if you had an XP wqorkstation, and you tried to join the domain, but it would not let you.
Can you check in AD to see if there is a computer object created for the LS-1000?  Or, if there is another computer already with that name?  If you know there is not, try deleting the computer object in ad (if one exists) and try again.  Also, go back and reenter the authentication information.  Also, you may need to use the format "DOMAIN\Administrator" rather than just the administratove user name.  
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 22727943
I would also run DCDIAG and Netdiag in verbose mode to see if anything is amiss.


I hope this helps !
0
 

Author Comment

by:CityOfRome
ID: 22733015
I tried both solutions, but I'm still getting the same error message.  "Failed to join Active Directory Domain".  Is there anything else I can try?  
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 8

Expert Comment

by:sstone55423
ID: 22736195
Okay, if it is not an authentication issue, can you make sure that you are up to date with the latest firmware?  (1.11 dated 2007-09-04)   http://www.buffalotech.com/support/downloads/
There is also a NAS navigator utility that may help with the diagnosis.
Please check the domain name and password yet again.  SOmetime the domian name is seperate and other times it is part of the authentication "domain\logname"  and get the correct slash (backslash).  Also, when you put the domain controller name in the Linkstation, try the IP address instead of the name.  
Can you send a snapshot of the Network page after you put that stuff in?
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22736204
Also, are you selecting the Windows NT, or Active Directory check box?
0
 

Accepted Solution

by:
CityOfRome earned 0 total points
ID: 23071616
I still cannot join the Buffalo NAS to my domain.  It seems that the AD function within the NAS software doesn't work, so I tried the following option to use Domain Users.

This option does not integrate the Buffalo to Active Directory, but uses the Delegate Authority to an external SMB Server option. To do this, login to the Link Station's web navigator, click on the network link, select Workgroup and put a checkmark in the "Delegate Authority to External SMB Server", "Use Windows Domain Controller as Authentication Server", "Automatic User Registration", and "Authentication Shared Folder" and enter the required information. The "Authentication Shared Folder" option will create an open share. Have the domain users that are to access the unit login to that share. This will register those users on the Buffalo. Afterwards, you can set Access Restrictions on the shares using those users and remove the "Authentication Shared Folder".
0
 

Expert Comment

by:Omer Maor
ID: 37989034
I found an answer!!!!

After spending literally hours and hours on this, trying dozens of different suggestions from a variety of online suggestions and resources, it came down to this:

SPECIAL CHARACTERS in the NT Password account!!!  We were using the dollar sign instead of the letter "S" and that messed it up!

If you have any characters outside of the alpha-numeric set, it will NOT work!

I tried everything else:
- Confirming NTP and time settings
- Adding the NAS as a pre-Windows 2000 machine
- Verifying forward and reverse DNS lookup entries
- Setting up WINS on the DC
- Verifying and triple-checking every IP and domain setting
- Verifying the DNS/Realm name
- Changing the Default Domain Policy setting in Group Policy Management (ie "Default Domain Policy/Computer Configuration/Windows Settings/Security Settings/Security Options/Network Security: LAN manager Authentication Level/Send LM & NTLM - use NTLMv2 session security if negotiated")
- Sacrificing small animals under a full moon  (kidding on that last one)

And it all came down to that the password for the administrator account used for this NAS used dollar signs ("$") in place of the letter "s" for complexity.

So evidently, even though all of the documentation from Buffalo saids they support special character, they DON'T!!!!

So for anyone who finds this in the future, you may have to do all of those other things I listed, but for goodness sakes, start with an alpha-num password first!!!
0
 

Expert Comment

by:jmillsapps
ID: 38902631
SamGliksman: Just tried your suggestion and the special characters were the issue on mine as well.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Group policies can be applied selectively to specific devices with the help of groups. Utilising this, it is possible to phase-in group policies, over a period of time, by randomly adding non-members user or computers at a set interval, to a group f…
Here's a look at newsworthy articles and community happenings during the last month.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question