Solved

Distribution / Mailing list always gets stuck in message queue followed by ndr / timeout

Posted on 2008-10-15
11
339 Views
Last Modified: 2013-11-30
Our system configuration is as follows:

Windows 2003 Server Standard SP2
Exchange 2003 Standard SP2
adsl internet
Outlook 2003 Clients

The Outlook clients are equipped with an exchange account and a separate pop/smtp account.
Within exchange i configured the smtp server from our mailprovider as smtp connector.

If i send an email directly with installed pop/smtp account it works. Also with the exchange respectively the installed smarthost account.
But if i address via mailing list the mails always get stuck in the queue of exchange. After the defined timeout i get ndr with timeout error or without special reason.
If i use the local installed pop/smtp account the mailing list mail works fine.
What could be the problem?

Thanks for your assistance

regards
0
Comment
Question by:_Mack_
  • 7
  • 4
11 Comments
 
LVL 32

Expert Comment

by:gupnit
ID: 22720712
Hi,
Can you explain what error you get when you try to send via mailing list and what is this mailing list that you have mentioned
Thanks
Nitin
 
0
 

Author Comment

by:_Mack_
ID: 22720926
Hi,

i get either timeout error #4.4.7,
or mails are dropped with error #4.0.0 smtp;421
smtp.mailproviderserver.de connection timed out

The mailing list consists only of external mail domain accounts.
The destination domain seems in no way relevant to the problem because the recipients are totally different.

regards
0
 

Author Comment

by:_Mack_
ID: 22720982
btw : the messages are stuck in the smtp connector queue.

regards
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 32

Expert Comment

by:gupnit
ID: 22721292
Hi,
Since the mail has been sent to for example 50 external users (in many 15 diff domains). ee an NDR does not mean the  mail didnt goto all users, it could be 1-2 domains that could be an issue. Please give me entire NDR to clarify the same. You NDR is about TimeOut, so it could be possible that issue at receiving end.
Why not create a new Distribution Group and add 2-3 of your personal IDs (Yahoo/Hotmail/Gmail etc) and try to send to that Mailing list. If you get all it will confirm that issue.
Cheers
Nitin
0
 

Author Comment

by:_Mack_
ID: 22721444
I should have explained it more exactly. Sorry for that.

It is no question if only some mails produce the NDR.
No user get an email i address.
I have also tried a test email to two yahoo addresses and they stuck again at our smtp connector queue.

The result NDR (but german)

Folgende Empfänger konnten nicht erreicht werden:

      'emailname 1' am 10.10.2008 12:15
            Die Nachricht konnte nicht übermittelt werden, da die maximale Zeit zur Übermittlung der Nachricht abgelaufen ist. Versuchen Sie es erneut, oder wenden Sie sich an den Systemadministrator.
            <our exchange server #4.4.7>

      'emailname 2' am 10.10.2008 12:15
            Das E-Mail-System konnte diese Nachricht nicht übermitteln, ohne einen besonderen Grund dafür anzugeben. Überprüfen Sie die Adresse, und versuchen Sie es dann erneut. Wenn die Übermittlung nochmals fehlschlägt, wenden Sie sich an den Systemadministrator.
 <our exchange server #4.0.0 smtp;421 smtp.ourmailprovider.de connection timed out>

Always timeouts. I also configured alternative smtp connectors with different smtp mailproviders with the same result.

regards
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22721544
Hi,
This only happens for Distribution Groups...right...please verify once again !
Also
  • Do you use a Smart Host or Exchange sends out Directly
  • Goto www.mxtoolbox.com and checkk various tests for your site, I doubt RDNS
  • Also in ESM --> SMTP Virtual Server --> Delivery --> Set the SMTP banner to server's external FQDN
Let me know
THanks
Nitin
0
 

Author Comment

by:_Mack_
ID: 22725668
Hi,
yes, it only happens while using Distribution Groups.

I have configured a smtp connector inside exchange routing groups.
I can see the emails being stuck in the smtp connector queue until the NDR.

I checked the message tracking at message status (dont know the right translation).
And I can see that exchange wants to deliver the mail via smtp to my configured smtp connector (smart host). But nothing happens.

Hm, sorry for maybe dumb questions, but what site should I check at mxtoolbox? I have no external site with a public exchange. The exchange isnt reachable from outside.
We use the exchange just internaly.
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22726075
Wow...there goes the answer...You do not have a Domain Registered...is it ?
Ok no question is dumb, a question is always a question, so chill.
Answer my dumb questions ;-)
  • DO you receive external mails (liek from Yahoo etc) to your Exchange users properly
  • If yes how do mails come in, can you explain the flow
  • Do mails from Internal users to single ID (like of Yaho0) go out successfully
  • If yes how
If you can give me these answrs, I will sort it out for you.
Cheers
Nitin
0
 

Author Comment

by:_Mack_
ID: 22726320
First, thanks for your patience. :-)

We do have a domain registerd, but we dont host them by ourselves.
The mx record from our domain is linked to the mail servers from our smtp domain provider.

So you assumes right. We aren't able to get mails by smtp directly.
Therefore we get them with pop3 protocol via accounts at client side (outlook).
Alternatively we have a central pop3 connector which regularly gets the mail and delivers them by smtp to our exchange.

Internal mails to single ID go out successfully. Wether smarthost or direct via local (outlook) configured pop/smtp account.
I hope i explained it comprehensible. Sorry, english isnt my first language as you noticed.

greets
Mack
0
 

Author Comment

by:_Mack_
ID: 22751468
Hm, it seems that my problem is a bit more dífficult as supposed.

Therefore is raise the points to 500.

Maybe we get even more support.

Thanks for your patience.
0
 

Accepted Solution

by:
_Mack_ earned 0 total points
ID: 22784361
I don't know what happend.

I tested it again. And since today it works as expected.
A testmail to a group of external emailadresses goes out successfully without any lag.
The installed smarthost seems to work as usual.

I would assume a problem at our mail provider but I had tested an other mail provider too.
And I got the same problems. Therefore I don't have any clue what happend.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

838 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question