Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

When I close my rdp connection and re-connect it creates a new session not joining the old one.

Posted on 2008-10-15
5
Medium Priority
?
311 Views
Last Modified: 2013-11-21
We have many server 2003 installs where i use RDP to connect and administrator the server. We have an old Server 2000 TS server as well as a 3 server citrix farm in the domain.

Whenever i try and connect to a server 2003 box with rdp and do something, and my connection gets clipped, or i click close in the rdp client and reconnect to the server with rdp it creates a new session. Is there a gp or other setting i need to change to get it to reopen my last rdp session instead of closing that session and starting a new one?

I do use the /console switch when i can, but i can't do that with all of the servers.

Thanks!
0
Comment
Question by:merit_lclark
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 3

Expert Comment

by:Dicanio37
ID: 22722400
Either install the admin pack on your pc and create a remote desktop console. Here you can specify to connect to the console of the rdp or not simply by checking a box.
Or from the run cmd type mstsc -v:serverip /f -console
0
 
LVL 7

Assisted Solution

by:Mikealcl
Mikealcl earned 1000 total points
ID: 22722404
In administrative tools > terminal services configuration > Server Settings

You can enable restrict each user to one session.  This will force you to reconnect to the same session.
0
 
LVL 11

Assisted Solution

by:jkarnes12
jkarnes12 earned 1000 total points
ID: 22722419
Configure the follwoing GPO setting:

Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services -> Keep Alive Connections

Set it to Enable, and specify a time to Keep Alive.
0
 

Accepted Solution

by:
merit_lclark earned 0 total points
ID: 22722554
I just looked at the GP and "Restrict Terminal Services users to the single remote session" is already enabled.
0
 

Author Comment

by:merit_lclark
ID: 22722724
Ok I found it.  It was in Computer Configuration\Windows Components\Terminal Services\Sessions\ Set time limit for disconnected sessions. It was set to 1 minute.

I will split points since you both got me into the right GPO area.
Thanks.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After having deployed hundreds of thousands of Terminal Services seats worldwide, I still see all the time people asking me that same old question: "If TS/RDS is that reliable why are you telling me I should reboot it that often? My DC/SQL/Exchange/…
The question has been asked on multiple occasions as to how best to do printing in a remote desktop or terminal services environment.   It seems that this particular question has plagued several people and most especially as Terminal Services, as…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question