Microsoft, Exchnage Server 2003, SP2, Small Business Edition w/SP2, Unable to connect to the Microsoft(R) Exchange server <SERVER>. To fix this problem, verify that there is network connectivity

Posted on 2008-10-15
Medium Priority
Last Modified: 2012-05-05
I have a SMall BUsiness Server (with SP2) running Exchange. The server works perfectly we use webmail (/exchnage) all the time.
We decided to srtart using the mobile access and active-sync recently and have discovered an issue.
When you go to http://localhost/oma or http://server/oma (same with https) you get the following error:

Unable to connect to your mailbox on server Servername. Please try again later. If the problem persists contact your administrator

I have tried the following Microsoft fix: http://support.microsoft.com/Default.aspx?kbid=817379 which did nothing.

The server has 1 NIC, the default website is using 'all unassigned' as its IP, there are no host headers, the http://localhost/exchange owa site works perfectly (and is configured using SSL).
The only error I get in the Application log is:

Unable to connect to the Microsoft(R) Exchange server SERVER. To fix this problem, verify that there is network connectivity between this server and the Exchange server. Also, verify that the Exchange server that this server is attempting to connect to is functioning properly

I have tried logging in using domain\user user@domain and just user. I can confirm that FBA is turned off, there are no other servers in this network and the Best Practice Analyzer gives me no errors, as of today (15th October) we have all updates.
Also we thought it might be slight corruption, so we deleted the Exchange directories, used the Metabase explorer to remove an entry and restarted the Exchange Servcies and got all new directories, this didnt help, didnt make it any worse either, but....

I am at this point lost for ideas, so please, any help appreciated.

Question by:lyndos
  • 4
LVL 33

Expert Comment

ID: 22724201
"When you go to http://localhost/oma or http://server/oma (same with https) you get the following error:"

How about you trying to connect using http://FQDN of Exchange server/oma ??

If OWA works fine from within - this means that the net connectivity works fine.

Author Comment

ID: 22728809
Sorry, no. I tried the http(s)://server.domain.local and http(s):// http(s)://server/oma and I Get the same errors with all of them.
Internet and network connectivity is fine, we use owa all the time over https from outside.
I have checked that mobile services are enabled and we also checked the enable unsupported devices option.

Thank you.

Author Comment

ID: 22738651
I was looking at the server yesterday and through the event logs and nothing really seems out of place, but I checked all of the updates and ipconfiguration etc and thats all good, but I had more than 1 companyweb site (the others were disabled so onl;y 1 running). I removed the intranet componant and SQL for SHAREPOINT uninstalled the FP extensions and removed the exchange directories again.

Did a re-install of the intranet componants, and the exchange virtual directories, checked all of the permissions. Setup and ran sharepoint and that works perfectly.
The /exchange, /monitoring, /tsweb, /remote, /backup, /connectcomputer, /clienthelp etc all work perfectly.

I really dont understand what could be wrong as everything works fine apart from this. Any ideas welcome.


Author Comment

ID: 22738909
Don't know if this helps or not, but here it is anyway.

Attempting to Resolve the host name mail.server.co.uk in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned:

Testing TCP Port 443 on host mail.server.co.uk to ensure it is listening/open.
 The port was opened successfully.

Testing SSLCertificate for validity.
 The certificate passed all validation requirements.

Testing Http Authentication Methods for URL https://mail.server.co.uk/Microsoft-Server-Activesync/
 Http Authentication Methods are correct
Additional Details
 Found all expected authentication methods and no disallowed methods Methods Found: Basic realm="mail.server.co.uk"

Attempting an Activesync session with server
 Errors were encountered while testing the ActiveSync session
Test Steps
 Attempting to send OPTIONS command to server
 Testing the OPTIONS command failed. See Additional Details for more info
 Tell me more about this step

Additional Details
 Exception occured: Exception Details: Message: The remote server returned an error: (401) Unauthorized. Type: System.Net.WebException Stack Trace: at System.Net.HttpWebRequest.GetResponse() at Microsoft.Exchange.Tools.ExRca.Tests.ActiveSync.ActiveSyncOptionsTest.PerformTestReally()


Accepted Solution

lyndos earned 0 total points
ID: 22739515
Ok, not sure how this works exactly, but re-installing the Administrative tools did the trick, I now have OWA, OMA and EAS, Sharepoint, Faxes and RWW again, perfect.

I had to spend nearly 4 hours trawling through posts on here and google this morning to find it, but its working now.

Thanks all

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
In my humble opinion (IMHO), TouchDown from Symantec is the best in class for this type of application, but Symantec has end-of-lifed it and although one can keep using it, it will no longer be supported or upgraded.  Time to look for alternatives t…
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

616 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question