Solved

Port Forwarding smtp through CISCO PIX506e Due to Slow email delivery

Posted on 2008-10-15
3
537 Views
Last Modified: 2013-11-30
Hi All,

I'm having an issue at a customers site where they are experiencing slow inbound email.  Unfortunatley the ISP provider can not help until I can allow their support guys to telnet on port 25 into the email server.  The Cisco 506e router currently only allows smtp port forwarding on a specific IP range which contains the ISP forwarding email servers and spam filter.

Do You think I should allow ANY IP address to have access/port forward smtp into the email server or should i allow just the Support guys ip range and keep the current range open? Can you provide me we the appropiate config to configure the pix for all IP and just one IP to port forward from the PIX to the Private IP of the Email server

I currently not on site but will be back first thing tommorow and will implement changes then.

The Client setup is basic and consists of the following:

The cisco pix 506e Outside IP address is = 87.xxx.xxx.162
The cisco pix 506e Inside IP address is = 10.0.0.254
The Internet Router which the 506e sits behind  = 87.xxx.xxx.161
The email server IP = 10.0.0.200

#################
IP RANGE of FORWARDING EMAIL SERVERS
195.40.1.0
212.135.6.0
##############
Is an old IP and should be deleted 87.xxx.xxx.34
Is an old IP and should be deleted 87.xxx.xxx.33

##### cisco current config########


PIX Version 6.3(4)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname PIX506E

domain-name ciscopix.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names
 
 

access-list 100 permit icmp any any time-exceeded 

access-list 100 remark Webflow

access-list 100 permit tcp any interface outside eq www 

access-list 100 permit tcp host 213.xxx.xxx.146 host 87.xxx.xxx.162 range ftp ssh 

access-list 100 permit tcp host 213.xxx.xxx.146 host 87.xxx.xxx.33 eq www 

access-list 100 permit icmp any host 87.xxx.xxx.162 echo-reply 

access-list 100 permit tcp host 213.xxx.xxx.146 host 87.xxx.xxx.33 eq 1000 

access-list 100 permit tcp host 213.xxx.xxx.146 host 87.xxx.xxx.34 eq 1000 

access-list 100 permit tcp 195.40.1.0 255.255.255.0 host 87.xxx.xxx.162 eq smtp 

access-list 100 permit tcp 212.135.6.0 255.255.255.0 host 87.xxx.xxx.162 eq smtp 

access-list 100 permit tcp 195.40.1.0 255.255.255.0 host 87.xxx.xxx.161 eq smtp 

access-list 100 permit tcp 212.135.6.0 255.255.255.0 host 87.xxx.xxx.161 eq smtp 

access-list 100 permit tcp host 65.xxx.xxx.80 host 87.xxx.xxx.162 eq 1863 

access-list 100 permit tcp host 216.xxx.xxx.169 host 87.xxx.xxx.34 eq 5050 

access-list 100 permit tcp any eq smtp interface outside eq smtp 
 
 

access-list 101 permit ip 10.0.0.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list split1 permit ip 10.0.0.0 255.255.255.0 10.0.1.0 255.255.255.0 
 
 

pager lines 24

logging on

logging timestamp

logging trap debugging

logging host inside 89.0.0.91

mtu outside 1500

mtu inside 1500

ip address outside 87.xxx.xxx.162 255.255.255.240

ip address inside 10.0.0.254 255.255.255.0
 

ip audit info action alarm

ip audit attack action alarm

ip local pool COMPANYvpnpool 10.0.1.1-10.0.1.25

pdm location 10.0.0.200 255.255.255.255 inside

pdm location 10.0.0.220 255.255.255.255 inside

pdm location 195.40.1.0 255.255.255.0 outside

pdm location 212.135.6.0 255.255.255.0 outside

pdm location 213.253.45.146 255.255.255.255 outside

pdm location 65.54.239.80 255.255.255.255 outside

pdm location 1o.0.1.0 255.255.255.0 outside

pdm location 216.155.193.169 255.255.255.255 outside

pdm location 10.0.91 255.255.255.255 inside

pdm location 87.xxx.xxx.161 255.255.255.255 inside

pdm location 87.xxx.xxx.162 255.255.255.255 inside
 
 
 
 

pdm logging debugging 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface ftp 10.0.0.220 ftp netmask 255.255.255.255 0 0 

static (inside,outside) tcp interface ssh 10.0.0.220 ssh netmask 255.255.255.255 0 0 

static (inside,outside) tcp interface www 10.0.0.220 www netmask 255.255.255.255 0 0 

static (inside,outside) tcp interface 1000 10.0.0.220 1000 netmask 255.255.255.255 0 0 

static (inside,outside) tcp interface smtp 10.0.0.200 smtp netmask 255.255.255.255 500 500 

static (inside,outside) 10.0.0.254 10.0.0.254 netmask 255.255.255.255 0 0 

static (inside,outside) 87.xxx.xxx.161 87.xxx.xxx.161 netmask 255.255.255.255 0 0 

access-group 100 in interface outside

route outside 0.0.0.0 0.0.0.0 87.xxx.xxx.161 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+ 

aaa-server TACACS+ max-failed-attempts 3 

aaa-server TACACS+ deadtime 10 

aaa-server RADIUS protocol radius 

aaa-server RADIUS max-failed-attempts 3 

aaa-server RADIUS deadtime 10 

aaa-server LOCAL protocol local 

http server enable

http 10.0.0.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set mediaset esp-3des esp-md5-hmac 

crypto dynamic-map dynmap 90 set transform-set mediaset

crypto map newmap 20 ipsec-isakmp dynamic dynmap

crypto map newmap client configuration address respond

crypto map newmap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 15

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup COMPANYvpngroup address-pool COMPANYvpnpool

vpngroup COMPANYvpngroup dns-server 10.0.0.200

vpngroup COMPANYvpngroup default-domain COMPANYltd.local

vpngroup COMPANYvpngroup split-tunnel split1

vpngroup COMPANYvpngroup idle-time 28800

vpngroup COMPANYvpngroup max-time 28800

vpngroup COMPANYvpngroup password ********

telnet 10.0.0.0 255.255.255.0 inside

telnet 10.0.0.200 255.255.255.255 inside
 

telnet timeout 60

ssh timeout 5

console timeout 0

terminal width 80

Cryptochecksum:526a32bfd8619baac9867cb63ef7e565

: end

[OK]

Open in new window

0
Comment
Question by:Firewall_Help
  • 2
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 22725793
For testing, you can change this:

>access-list 100 permit tcp any eq smtp interface outside eq smtp

to this:
access-list 100 permit tcp any interface outside eq smtp

For email to come in, the source port will not be 25, only the destination is 25

0
 

Author Comment

by:Firewall_Help
ID: 22726140
will the below port forward smtp from any inbound IP? Whats the actual meaning of the below? So email from any host emailed to my cisco pix outside ip will  be forwarded to my email server 10.0.0.200 using the below?

access-list 100 permit tcp any interface outside eq smtp
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22726222
The actual port forwarding is done with the static:
 >static (inside,outside) tcp interface smtp 10.0.0.200 smtp netmask 255.255.255.255

The access-list entry will allow inbound smtp from "anywhere"

once you complete troubleshooting with the ISP, you can remove that single line and be back to allowing inbound SMTP only from recognized/authorized hosts.

0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

These are on the increase and getting more common these days. Users who use the Google search engine may complain of having their search redirected to unwanted sites, regardless of what browser is used. This happens when the system is infected with…
From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now