Solved

Citrix, Citrix Presentation Server, 4.5, TERMINAL SERVER, logon issue

Posted on 2008-10-15
12
1,204 Views
Last Modified: 2013-11-21
When a user tries to run a published application via citirx, they are first prompted for an RDP username and password after they are already authenticated via the web interface.
citrix-rdp-prompt.bmp
0
Comment
Question by:mjm21
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +1
12 Comments
 
LVL 2

Expert Comment

by:Ron9909
ID: 22725226
From the screenshot, your user's credentials are trying to use the local computer domain, rather than your AD.

Are your users using pass-through authentication?  If so, have you made the required mods to the user's Appsrv.ini file (on the client, located within the user's profile.  Add EnableSSOnThruICAFile=On
SSOnUserSetting=On to the WFCLIENT section)

Have you tried configuring domains within the configured authentication methods for WI within the Access Suite Console?

Its also possible to configure a default logon domain by modifying the Winlogon entry for your servers - provided that your users all belong to the same domain.

If none of this helps, can you give me a complete description of the setup - how users access WI, how its configured, where users and servers are located etc.  Thanks.
0
 

Author Comment

by:mjm21
ID: 22725402
Hi, Thanks.

1. No passthrough.
2. do not think so, will have to check.  Remember this is after they logon through web interface and click the published app.
3. There is only one domain.

Let me take a look.  Can I get back to you.....

Scenario:  users access citrix apps via web interface/ secure gateway. 3 PS servers, 1 farm, separate license server, one of the three server in the far is running terminal server licensing, several published apps.
0
 
LVL 18

Expert Comment

by:sk_raja_raja
ID: 22725413
open the Program Neighborhood, go to Tools>ICA Settings
Check 'Allow pass through'
Check Use local credentials.
Close Program Neighborhood.
Log off windows (don't reboot), then logon again.
Open program neighborhood
Right click and go to properties on published application/application set, go to 'Logon Information'  
input the username and password and domain


0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 18

Assisted Solution

by:sk_raja_raja
sk_raja_raja earned 50 total points
ID: 22725421
0
 

Author Comment

by:mjm21
ID: 22725794
I am taking a look now to what is going on.   I will get back to you.
0
 

Author Comment

by:mjm21
ID: 22726003
I will have more info tomorrow when the group of users are in.....they are from Germany
0
 
LVL 11

Expert Comment

by:Eric
ID: 22726030
See attached.  You may not be able to use passthrough.
I dont allow it on my network.

citrix-policy.jpg
0
 

Accepted Solution

by:
mjm21 earned 0 total points
ID: 22733063
I figured it out.  I physically went to the server that was causing the issue.  Took a keyboard, mouse and monitor and hooked them up.

What I saw was the log in prompt was set as the following:

username: domainname\username
Password:
local server: local server hostname

Someone logged on locally to this server..and that was the issue.

Solution:  Logged in as domain administrator with the the domain name, not the local server.

Logged off.  Issue resolved!!  Had a user test and worked fine.

Wierd, but it worked....  Great!

I will see tomorrow if the other users from Germany have no problem as well.
0
 
LVL 11

Expert Comment

by:Eric
ID: 22733102
That was Ron's First suggestion for the record.
0
 

Author Comment

by:mjm21
ID: 22733975
this:  From the screenshot, your user's credentials are trying to use the local computer domain, rather than your AD.

I agree, but who knew you had to go to the local machine and check this.  It is as if the server forced local log in via citrix session.
0
 
LVL 2

Expert Comment

by:Ron9909
ID: 22734050
Yes - in this case, if you haven't specified a logon domain, either through WI authentication, or through the DefaultDomainName registry entry, then it uses the domain/realm of the locally logged on user.  To prevent this happening again, you should specifiy the domain to be used.  Easiest way is through the Access Suite console - authentication methods for the WI site.
0
 

Author Comment

by:mjm21
ID: 22737060
I am specifying the domaon name being used through web interface man.....I will provide for you screen shots...
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It Is not possible to enable LLDP in vSwitch(at least is not supported by VMware), so in this article we will enable this, and also go trough how to enabled CDP and how to get this information in vSwitches and also in vDS.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question