Solved

Blocking MSN / Yahoo Messenger using CLI

Posted on 2008-10-15
5
773 Views
Last Modified: 2012-05-05
All,

I'm trying to block both yahoo and MSN using the CLI, having tried the commands in the following link:-

http://www.experts-exchange.com/Hardware/Networking_Hardware/Firewalls/Q_23795263.html

Results in errors in the IOS, can anyone point me in the right direction as to the correct CLI commands to block boh MSN abd Yahoo Messenger.  Below is my current running config:-

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password SX/Y7cXtfgcNOcz9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfw
domain-name workgroup
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.13 Exchange
access-list outside permit tcp any interface outside eq smtp
access-list outside permit tcp any interface outside eq https
access-list inside permit tcp any any eq ftp
access-list inside permit tcp any any eq www
access-list inside permit udp any any eq domain
access-list inside permit tcp any any eq domain
access-list inside deny ip any any
pager lines 24
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute retry 4
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.16.58 255.255.255.255 outside
pdm location Exchange 255.255.255.255 inside
pdm location 192.168.0.1 255.255.255.255 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface https Exchange https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp Exchange smtp netmask 255.255.255.255 0 0
access-group outside in interface outside
access-group inside in interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 15
ssh 192.168.0.1 255.255.255.255 outside
ssh timeout 15
console timeout 0
dhcpd address 192.168.0.2-192.168.0.10 inside
dhcpd dns 81.26.107.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
banner login Disconnect immediately if not authorised
banner motd Home cable firewall
Cryptochecksum:eb2f60263be6afc8c48ae99bdb852e4d
: end
pixfw(config)#
0
Comment
Question by:dt3itsteam
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 1

Author Comment

by:dt3itsteam
ID: 22725930
Note I've added the following "object-group network" & object-group services" statements as well as

Adding the following access-list "access-list acl-inside deny tcp any object-group MSN_Messenger_hosts object-group"

Howvere I'm still able to sign in to MSN!  I guess the hosts in the "object-group network" section are way out of date?

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password SX/Y7cXtfgcNOcz9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfw
domain-name workgroup
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.13 Exchange
object-group service MSN_Messenger_tcp tcp
  port-object eq www
  port-object eq 1863
  port-object eq 7001
object-group network MSN_Messenger_hosts
  network-object 65.54.195.0 255.255.255.0
  network-object 65.54.225.0 255.255.255.0
  network-object 65.54.226.0 255.255.254.0
  network-object 65.54.228.0 255.255.254.0
  network-object host 65.54.240.61
  network-object host 65.54.240.62
  network-object 207.46.104.0 255.255.252.0
  network-object 207.46.108.0 255.255.255.0
  network-object 207.68.171.0 255.255.255.0
access-list outside permit tcp any interface outside eq smtp
access-list outside permit tcp any interface outside eq https
access-list outside permit tcp any any eq ssh
access-list outside permit tcp any interface outside eq pptp
access-list inside permit tcp any any eq ftp
access-list inside permit tcp any any eq www
access-list inside permit udp any any eq domain
access-list inside permit tcp any any eq domain
access-list inside permit tcp any any eq https
access-list inside deny ip any any
access-list acl-inside deny tcp any object-group MSN_Messenger_hosts object-group MSN_Messenger_tcp
pager lines 24
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute retry 4
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.16.58 255.255.255.255 outside
pdm location Exchange 255.255.255.255 inside
pdm location 192.168.0.1 255.255.255.255 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface https Exchange https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp Exchange smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh 192.168.0.1 ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pptp Exchange pptp netmask 255.255.255.255 0 0
access-group outside in interface outside
access-group inside in interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 15
ssh 192.168.0.1 255.255.255.255 outside
ssh timeout 15
console timeout 0
dhcpd address 192.168.0.2-192.168.0.10 inside
dhcpd dns 81.26.107.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
banner login Disconnect immediately if not authorised
banner motd Home cable firewall
Cryptochecksum:f0ec7af1a913ec484cc6bfc66c25ae8a
: end
pixfw(config)#
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 22730501
You did not apply the acl to the interface

no access-group inside in interface inside
access-list acl_inside deny tcp any object-group MSN_Messenger_hosts object-group MSN_Messenger_tcp
access-list acl_inside permit ip any any
access-group acl_inside in interface inside


0
 
LVL 1

Author Comment

by:dt3itsteam
ID: 22732553
this is my current running config, MSN still works I'm afraid:-

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password SX/Y7cXtfgcNOcz9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfw
domain-name workgroup
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.13 Exchange
object-group service MSN_Messenger_tcp tcp
  port-object eq www
  port-object eq 1863
  port-object eq 7001
object-group network MSN_Messenger_hosts
  network-object 65.54.195.0 255.255.255.0
  network-object 65.54.225.0 255.255.255.0
  network-object 65.54.226.0 255.255.254.0
  network-object 65.54.228.0 255.255.254.0
  network-object host 65.54.240.61
  network-object host 65.54.240.62
  network-object 207.46.104.0 255.255.252.0
  network-object 207.46.108.0 255.255.255.0
  network-object 207.68.171.0 255.255.255.0
access-list outside permit tcp any interface outside eq smtp
access-list outside permit tcp any interface outside eq https
access-list outside permit tcp any any eq ssh
access-list outside permit tcp any interface outside eq pptp
access-list inside permit tcp any any eq ftp
access-list inside permit tcp any any eq www
access-list inside permit udp any any eq domain
access-list inside permit tcp any any eq domain
access-list inside permit tcp any any eq https
access-list inside deny tcp any object-group MSN_Messenger_hosts object-group MSN_Messenger_tcp
access-list inside deny ip any any
pager lines 24
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute retry 4
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.16.58 255.255.255.255 outside
pdm location Exchange 255.255.255.255 inside
pdm location 192.168.0.1 255.255.255.255 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface https Exchange https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp Exchange smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh 192.168.0.1 ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pptp Exchange pptp netmask 255.255.255.255 0 0
access-group outside in interface outside
access-group inside in interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 15
ssh 192.168.0.1 255.255.255.255 outside
ssh timeout 15
console timeout 0
dhcpd address 192.168.0.2-192.168.0.10 inside
dhcpd dns 81.26.107.2 81.107.26.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:4abff94d8daead25cf7b6626c3397341
: end
pixfw(config)#
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22733596
Try moving the deny acl entry to the top
You're allowing www "any any" before you try to stop those


0
 
LVL 1

Author Comment

by:dt3itsteam
ID: 22758452
Thanks will try tonight and let you know how I get on!
0

Featured Post

Are You Ransomware's Next Victim?

Worried about ransomware attacks hitting your organization?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with WatchGuard Total Security!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VPN tunnel up, but no pings or remote resource access 13 154
Business Broadband for Small Office in Dubai 2 104
Cisco ASA 3 51
List IP by send / recieved size in Fortigate 5 33
In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
I recently had the displeasure of buying a new firewall at one of the buildings I play Sys Admin at. I had to get a better firewall than the cheap one that I had there since I was reconnecting the main office to the satellite office via point-to-poi…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question