Unable to view video file in IE or Firefox that is created in Swish Max 2

I am trying to create a video file (swf) to be viewable on the internet.  I have a FLV file that I am importing into Swish Max 2 and using the Ultra Minimalist FLV Component.  So far, I have had no luck in getting it to play.  It would show up in firefox but the player controls would not show up in IE.  Now I have no player controls on either one of them.  code is attached.  


<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','560','height','410','src','flash/bgtworking2','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','flash/bgtworking2' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="560" height="410">
              <param name="movie" value="flash/bgtworking2.swf">
              <param name="quality" value="high">
              <embed src="flash/bgtworking2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="560" height="410"></embed>
            </object></noscript>

Open in new window

thirdrockitAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
alikaz3Connect With a Mentor Commented:
jason has a good point there, also, I see alot of articles talking about the path. Look at this:
<embed src="flash/bgtworking2.swf"

Have you confirmed your bgtworking2.swf file is located in a folder called flash, and "flash" is inside the same folder as your htm file?
0
 
alikaz3Commented:
Have you installed the latest flash plugin for those browsers?
0
 
thirdrockitAuthor Commented:
yes
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
alikaz3Commented:
have you seen this:
The problem is typically in the "url" parameter for the Ultra Minimalist video player.

By default, the url parameter is populated automatically when you import a video ... the problem is that it uses an absolute path to the FLV file on your computer (this makes sure it works when testing locally). IMO, I do not think the program should do that and will once again suggest that it doesn't.

Select the "videoPlayer" MovieClip from the Outline - then open the Paramters panel. If it is showing an absolute path to a location on your computer, change it to a relative path (see attached reference image)

As an example, if the 'url' parameter is showing "C:\Folder\Folder\video.flv" ... change it to "video.flv" ... then just make sure to upload the .FLV file to the same folder as your .SWF file on your website.

from:
http://forums.swishzone.com/index.php?showtopic=60538
0
 
alikaz3Commented:
and here's the manual if you haven't already gotten it:
http://www.swishzone.com/manuals/max2components/index.html?p=ultra_minimalist.htm
0
 
Jason C. LevineNo oneCommented:
Always check to see if you uploaded the Scripts folder from the local to remote site.  Whenever you embed Flash from Dreamweaver, a new folder will be created in  the Local site root called "Scripts" and this folder and all contents needs to be uploaded to the Remote site otherwise the movies may not play.  Firefox may still allow things to happen because of the embed tags but IE will not.
0
 
thirdrockitAuthor Commented:
It seems to be a problem with the ASP code.  The website I am trying to place the video is done in ASP.  If I export the swf and html file from Swish and upload it to the website, the video works and loads.  But if I put it in the the asp page, the video doesn't even show up.  Here are the example links

working......
http://www.bluegrasstomorrow.org/flash/bgtworking2.html

not working............
http://www.bluegrasstomorrow.org/newsmakers.asp

0
 
Jason C. LevineConnect With a Mentor No oneCommented:
The source parameter is wrong.

src="flash\bgtworking2.swf"

try

src="flash/bgtworking2.swf"
0
 
thirdrockitAuthor Commented:
OK....I fixed that but it still will not work in IE7
0
 
Jason C. LevineNo oneCommented:
Right, because you are using straight out object and embed tags and IE7 blocks those.  That's where the javascript file from DW comes into play.  It works around the IE active content blocks.
0
 
Jason C. LevineNo oneCommented:
Also, the param tag in the object is wrong:

<param name="movie" value="bgtworking2.swf">

should be

<param name="movie" value="flash/bgtworking2.swf">
0
All Courses

From novice to tech pro — start learning today.