Solved

IIS permissions issues for IUSR guest account

Posted on 2008-10-15
5
3,547 Views
Last Modified: 2008-10-23
I have a website that I moved from the current web host to our in house server.  It utilizes asp pages and Access databases.  When testing, it will not allow the IUSR_Servername internet guest account to access the index.asp page unless I give it WRITE permissions on the wwwroot folder.  Since I wouldn't think that the WRITE permission is generally recommended to give to anonymous users, how do I resolve this issue?  What are the recommended security settings in general for asp pages?
0
Comment
Question by:bleujaegel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 1

Accepted Solution

by:
Abh4IT earned 250 total points
ID: 22729378
Hi,

Yes you should not provide write access to anonymous users. What you should do is in your asp page you should authenticate/imporsonate as another user who has enough permissions. When working on ASP.NEt this is better since you can provide required rights to ASPNET user.

Hope this helps
0
 
LVL 2

Author Comment

by:bleujaegel
ID: 22731562
So I should give read to IUSR and write to the ASPNET user and it should work?
0
 
LVL 15

Assisted Solution

by:pcsmitpra
pcsmitpra earned 250 total points
ID: 22731656
Read only for IUSR, If you are running IIS 6 then add NETwork Service and give it Execute access. Add ASPNET in case of IIS5.
0
 
LVL 2

Author Comment

by:bleujaegel
ID: 22779698
I tried the network service with execute (even tried FULL), but page would not display.  I stripped down the permissions to start over, and now I have:

administrators: FULL
IIS_WPG: Read & Execute, List folder contents, and read
Internet Guest Account IUSR_Servername: Read & Execute, List folder contents, read, and write
SYSTEM: FULL
Users: Read & Execute, List folder contents, and read

Still as soon as I take the WRITE permission away from the Internet Guest Account IUSR_Servername, then the .asp page won't display and gives an error.

I like the idea of impersonating a user, so I'll try that next, but don't know the syntax of how to set that up.  I'll give it a google.
0
 
LVL 3

Expert Comment

by:jandelbasanal
ID: 23343925
Kindly check the IIS settings first if you allow or specify execute permissions.You can check also configuration if asp extension has been added.I guess this a security related settings you encountered.

Can you create just a simple asp scripts on other folder?this is just to verify your IIS running fine with asp.Pls do check also folder security permissions on local drive or home folder.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here are the symptoms: You start receiving calls from users that one of your legacy web apps isn't coming up, so you log into your IIS 5 server to check it out.  When you pull up the services, you notice that the WWW Publishing service isn't runn…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question