Solved

BlackBerry Encryption Key Failure Issue

Posted on 2008-10-15
2
2,276 Views
Last Modified: 2013-11-17
Ok, here is the problem.

We are running BES version 4.1 something.
The BES is connected to our Domino server version 7.03 something.
We have 25 users and all users except 1 is using a 8830 World Edition and the one is using an 8330.

The phone was brought to me because the user could no longer Reply to all emails they recieved only specific ones.  The only option they had was to Save as a Draft with the send option missing.

The first thing in trouble shooting that I tried was to delete the Desktop CMIME Service Book and resend it from the BES.  This did appear to work properly but I could still not reply to the specific emails.

The next thing I tried to do was to Regenerate the Encryption key, which I did manually from the device and it failed with a general error saying to contact the Admin.

Then I decided to completely wipe the device and delete the user from the BES.  After wiping the device, re-adding the user to the BES, and running the Enterprise Activation again I was able to send and recieve email to everyone, or so I thought.

I got the BB back again this morning with the same problem, only certain emails can be replied to.

So this time I called over to the BlackBerry support team.  The technician had me use JavaLoader to wipe the device (forced 507 error) and reload the OS.  He also had be manually delete the "state" database's from our Domino server that didn't properly delete when I had removed the user from the BES previously.  We then re-created the profile on the BES, and did an Enterprise Activation.  

At this time again it appeared as though everything was working, so I let the phone sit for about 2 hours and kept a watch on it.  After a while the phone stopped receiving messages which I thought was odd because this is a rather heavy traffic user.  I first looked on the BES and to my surpise the phone number was missing and the account was sitting at the "Initializing" screen again like I had never activated it!

So I ran Enterprise Activation again and the first thing I did was try to manually Regenerate Encryption Keys and when I did this it failed again.  I then looked on the BES and the phone number was gone and in Initializing status again.

I then thought perhaps the account was to blame so I set up a test acount on the BES and activated it  but I was unable to generate encyption keys with that account also.

Next I set up one of our 8830's with the user in questions account and tried to generate keys but yet again I was unable to do so.

I am not sure what I am missing here and anything that could lead me down the right path would be greatly appreciated.
0
Comment
Question by:Adam82
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 63

Assisted Solution

by:SysExpert
SysExpert earned 100 total points
ID: 22727869
weird.

At this point I would call RIM for support, since you have already eliminated the hardware, and the account, so it is something sublime.

I would remove the user, and add him back, and try on a different BB device that has been wiped, just to be sure.

Also check for firmware updates, and try an activation via BB desktop manager with logging on ( advanced logging if possible ).
Anything in the event logs or BB logs ?

I hope this helps !
 
0
 
LVL 1

Accepted Solution

by:
Adam82 earned 0 total points
ID: 22737312
Well, here is what happened.

The reason that this user was unable to reply to some emails is because they were not emails that were sent from her BES account!

I found out today that not only is this user setup on a BES but also on a BIS.  And what was happening is that emails that were sent using the BIS account were still be directed to the phone when I would reactivate it on the BES, and when trying to reply to these because the BIS account had not yet been setup it on the device it would not go through.

Once I setup her BIS account she was able to reply to all messages.

The reason for the encryption keys failing is because BIS wins over BES meaning that the BES was seeing the pin as already being activated elsewhere hence dropping it off the BES.

This was very tricky... ;)
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've already touched on keyboard shortcuts that can be used in a BlackBerry to make navigation much more easy but there are also another set of commands which are hidden for different reasons. Standard users won't need these unless under exceptional…
There are various sources that I've used for this process and I've used it many times and adapted it with my own findings. This process is not meant to be a definitive troubleshooting guide for BlackBerry installation. That needs to be handled elsew…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question