Solved

Urgent

Posted on 2008-10-15
28
757 Views
Last Modified: 2012-06-22
I need to enable computers from outside my router's internal network  to be able to browse to my asp webpage witch is hosted on my IIS.

maybe with port forwarding or virtual server.
0
Comment
Question by:RahnLev
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 8
  • 3
28 Comments
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22729447
you should make port forwarding;
create a rule on your server or router for example on port 3000
for example,I'd done this on my linux server for forwarding:

iptables -t nat -A PREROUTING -j DNAT -i eth1 -p tcp --dport 3000 --to-destination 192.168.10.101:3000


0
 

Author Comment

by:RahnLev
ID: 22729501
I dont know wre to add this line...
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22729538
what server do you have or router?
0
The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

 

Author Comment

by:RahnLev
ID: 22729607
router edimax
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22729625
is there an  option to create port forwarding
does that router have a real ip on it>
0
 

Author Comment

by:RahnLev
ID: 22729739
yes there is an option for port forwading.
yes it has.... reall as a regular IP from the provider.
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22729790
to create a port forwarding rule, on port 4444 for example
and redirect the ip to the ip where the application is installed.
0
 

Author Comment

by:RahnLev
ID: 22729936
this is a screenshot of the edimax port forward page....

1 thing I dont anderstand is that even if I close the Development srv (stop the Debug) I still can browse the page from within the machine.
Port-forwarding.jpg
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22729961
in the private IP type the ip of the pc that had the application hosted.
chose the port that you want.

the same method as your current port forwarding table
0
 

Author Comment

by:RahnLev
ID: 22730090
what address should I type in the IE URL?

this 1?

http://87.58.273.28:1164/eCommerce(3)/Default.aspx

or this 1?

http://87.58.273.28/eCommerce(3)/Default.aspx

by the way they both dont work....

0
 

Author Comment

by:RahnLev
ID: 22730099
what about port 80, I think this port is for browsing...
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22730110
what is the ip of your router?
0
 

Author Comment

by:RahnLev
ID: 22730377
87.68.165.76
0
 

Author Comment

by:RahnLev
ID: 22730388
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22730499
had you put the private IP, the IP of the machine that is having the application
0
 

Author Comment

by:RahnLev
ID: 22730690
like in the jpg Y 192.168.2.103.....
TCP +UDP  (in the picture "BOTH")
I put Port 1164 and range 50-80 caus I didnt know the bussiness with the internal 50 and the external 80 or the oppozite.
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 22730734
inside the LAN, if you type 192.168.2.103 in any computer's browser,
will it work?
0
 

Author Comment

by:RahnLev
ID: 22730995
its not working in the internal network as well

I gave http://192.168.2.103/
and http://192.168.2.103:1164/
0
 

Author Comment

by:RahnLev
ID: 22735216
the model of my router is:

edimax....

br-6204wg
0
 
LVL 37

Accepted Solution

by:
bbao earned 500 total points
ID: 22737161
for publishing a common web server, you may just use Virtual Server option by giving the server type and internal server IP address.

for other particular applications, use Port Forwarding instead.

as per your screenshot, you may now use http://87.68.165.76 to access the web server, if the web site is running on the default port number TCP 80.

hope it helps,
bbao
0
 
LVL 37

Expert Comment

by:bbao
ID: 22737169
0
 

Author Comment

by:RahnLev
ID: 22740055
0
 

Author Comment

by:RahnLev
ID: 22740537
Do I do It right?
0
 

Author Comment

by:RahnLev
ID: 22740562
0
 

Author Closing Comment

by:RahnLev
ID: 31506557
one thing was missing....
TURN of the FIREWALL
0
 
LVL 37

Expert Comment

by:bbao
ID: 22747434
yes, it is right, if you mean you are sharing an internal web server at 192.168.2.206 on the internet.

be aware that you have another shared service on TCP 1164.

hope it helps,
bbao
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question