Solved

stp error/fix?

Posted on 2008-10-15
9
962 Views
Last Modified: 2012-05-05
Howdy,
  I recently installed a new 4503 switch. When I hooked my server up to it I received this error on the switch:

 %C4K_EBM-4-HOSTFLAPPING: Host cc.cc.cc.cc.cc.cc in vlan 50 is flapping between port Gi3/15 and port Gi3/6

now the server has a bridged NIC. Is there a workaround besides NIC teaming to fix this problem? and yes this is about the second time I asked this question :) Sorry for the repeat but I need this one fixed hopefully fast :p
0
Comment
Question by:Paktusjet
  • 5
  • 4
9 Comments
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22729573
turn of the error detection on these ports?

but to be honest you are asking a switch to do something impossible. If you dont team the ports. how dose the switch know what one to use if the Mac address on each is the same??

you are telling it not to load balanace, but it has to.

A switch learns mac address and forms a mac address table telling it where to forward data to. if it has the same  mac address on two ports it cant do this. It will try to use one at a time. and each time it runs an arp it will reupdate its mac address table to use one or the other.

not a good configuration....
0
 
LVL 2

Author Comment

by:Paktusjet
ID: 22734038
well I was using a c3750g and it worked fine no errors... and the network was stable... But when I put this bad boy 4503 in... He did not like that... So now I'm at this spot:

I have to get this switch to stop flapping with that error.
I have no free IP addresses to assign to this NIC.
I'm on a count down timer to get this fixed.
And my server does not support NIC teaming.

So if it worked on a 3750g It should work on a 4503. I know you think this is impossible, but I've seen this work for a long time.. only thing is I dont know how they set it up.
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22738509
you have the same mac address set up on both NIC cards in the server. This is a form of NIC teaming?

Can i jsut ask,

I think you have one ip address for the two nic's?
and have assigened the same mac address to both nics?

can you jsut confirm that is correct?
0
 
LVL 2

Author Comment

by:Paktusjet
ID: 22744239
well when you bridge two nics together, they use the most primary mac address for both which is what nic teaming doesnt do. NIC teaming uses one IP address but each nic holds it's respective mac address. But.. my servers do not support nic teaming.

So yes one IP address for both nics and since there bridged it's one MAC address. Now keeping that in mind I asked this on another post that I put up and asked if there was a way to set STP to block one port until the other goes down.. which in case this one will change to forwarding. But all I got was that cannot be done. So thinking with a cisco mind they must of set something up so this is possible.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 16

Accepted Solution

by:
Aaron Street earned 500 total points
ID: 22751533
try setting the ports on the switch in to portfast,

this will stop them being included in spanning tree so you should stop getting errors
I am at home so can't rember the exact command
but its some thing like
conf t
int gx/x/x
switch port mode portfast..
or is it spanning tree mode portfast??

IF you can't find it I will log on to a switch tomorow to remind my self (i have a thing that i need to be sitting in frout of the switch to rember where things are !)

it is best to have acces ports in port fast mode anyway as PC/servers should never need to be involved in spanning tree caculations, and it will mean PC's/servers will concect the instance you patch them in, rather than casuing a network wide spanning tree, reconvergence caculation.


also for info NIC teaming is a generic term to use two or more nic's for the same sever conection.

there are many differnet types. of teaming below are the various types that HP suppoerts.

"Types of teaming configurations  
 
 
 The following teaming configurations are available for HP ProLiant Ethernet network adapters:
Automatic - allows a ProLiant server to use the best network team type possible, given current network and server configurations. It enables the server to automatically select the best type of failover team based on team member connections.

For example, when the teamed NICs are attached to a switch, the software creates a Transmit Load Balancing team. If those same NICs are instead connected to a switch that supports dynamic link aggregation (802.3ad), the team forms an aggregated link that supports both transmit and receive load balancing.

Additionally, the Automatic Teaming feature helps the ProLiant network remain adaptive to network and server conditions. As network and server configurations change, the Automatic Teaming type ensures that the customers' servers connect to the network in the most efficient manner possible. Automatic Teaming is a standard feature of HP ProLiant Teaming.


802.3ad Dynamic - provides receive and transmit load balancing on a single switch. In this team type, the team members negotiate with the switch to automatically form a port group, so no additional configuration is required on the switch. The switch must support the IEEE 802.3ad Link Aggregation Control Protocol (LACP). 802.3ad Dynamic Teaming is a standard feature of ProLiant teaming.


Switch-assisted Load Balancing (SLB) - provides receive and transmit load balancing on a single switch and is functionally identical to 802.3ad Dynamic Teaming. SLB requires the switch itself to be configured to form a port group. The switch must support port aggregation, but it does not need to support the IEEE 802.3ad Link Aggregation Control Protocol. SLB is a standard feature of ProLiant Teaming.


Transmit Load Balancing (TLB) - balances the transmit traffic among the team members, but does not require any special switch intelligence or switch configuration. In addition, TLB teams can be split across switches as long as all members are in the same layer 2 network. In TLB teams, receive traffic is not load balanced, but is received on a single team member. TLB is a standard feature of ProLiant Teaming.


Network fault tolerance (NFT) - prevents network downtime by transferring the workload from a failed port to a working port. Clients on the network see no disruption of service, and the network can remain in use while the failed component is repaired. NFT teaming functions at any speed, on any media. It is switch-independent and can be split across Layer 2 switches but must be in the same Layer 2 domain. NFT is a standard feature of ProLiant Teaming, and is available in all team configurations.
 "
0
 
LVL 2

Author Comment

by:Paktusjet
ID: 22772152
well the errors stopped but... Now I cant get one of my servers to talk to the one thats port channeled.

configs:

Switch(config-if)#spanning-tree portfast
Switch(config-if)#channel-group 1 mode active
Switch(config-if)#port-channel load=ballance src-mrc

interface GigabitEthernet1/1
switchport access vlan 40
channel-group mode active
spanning-tree portfast
!
!
interface GigabitEthernet1/5
switchport access vlan 40
channel-group mode active
spanning-tree portfast

The other server is on vlan 40 but it cant ping the portchanneled server... Everything can ping this server but this one cannot ping the portchanneled server. But when we take it off it works :/

any suggestion?
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22774132
hold on if every thing else can ping this server. then i would suggest it is not a problem with the port channeled server. but with the one that can't ping it?

double check vlans and trunking info..
0
 
LVL 2

Author Closing Comment

by:Paktusjet
ID: 31506600
I read in on the 802.3ad and basically pointed me to ether channeling and we found a HP software to "Team" our NICs :) thanks for the help. Now I know I stated we can't NIC Team but we were able to find software for it.
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22784071
glad you got it sorted :)
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
This video discusses moving either the default database or any database to a new volume.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now