Solved

Exchange unable to send external mail.

Posted on 2008-10-15
12
211 Views
Last Modified: 2010-03-06
Up until yesterday the exchange server was running without any problems. Then we had a call from a customer saying that they had not received an email when we had sent it. I have since found that any email we send to an external address does not get receive. We can receive emails fine. We can even send emails internally. I have checked our firewall. I have looked through exchange and can't find anything obvious. I have not changed anything on the server that I can think might have caused this. The mail simply goes to the outbox like its being sent then a few seconds later moves to the sent items box. No error message get bounced back they simple disappear to nowhere. I have tested sending emails to multiple email domains so I don't think it's those I am sending to. I am not using smart host although I tried setting that up with no luck. Any suggestion would be grateful. This is rather urgent as we have not been able to send emails for 2 days now.
0
Comment
Question by:milltechtga
  • 7
  • 3
  • 2
12 Comments
 
LVL 9

Expert Comment

by:abdulzis
ID: 22728017
Does that email show up in the Queue?
Have you enabled message tracking and checked where the message goes?
Are you running Symantec file level scanner?
0
 

Author Comment

by:milltechtga
ID: 22728106
I am not running symantec file lvl scanner, my AV is NOD32. Yes i have enable message tracking. This is a example of one of the lines: (Hope it does make to much of a mess.

10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1027      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      c=NZ;a= ;p=MTD;l=MTSERVER-081016043018Z-8      Test      EX:/O=MTD/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=DAVE      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1019      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      -      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1025      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      -      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1024      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      -      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1033      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      Dave@milltechtga.co.nz      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1034      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      Dave@milltechtga.co.nz      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      -      MTSERVER      -      david.buchanan@clear.net.nz      1020      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      Dave@milltechtga.co.nz      -
                                                                                                                        
10/16/08      4:30:18 GMT      -      -      firewall.mtd.local      MTSERVER      -      david.buchanan@clear.net.nz      1031      D702B92DCDDD584D93570B094C2CB82F9987@mtserver.mtd.local      0      0      4855      1      2008-10-16 4:30:18 GMT      0      -      -      Test      Dave@milltechtga.co.nz      -
0
 
LVL 9

Expert Comment

by:abdulzis
ID: 22728149
Can you disable Nod32, restart SMTP and try again?
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 22729326
Do you use default smtp virtual server to relay your smtp messages? Try to install another smtp server (with iis you can do it very quicly) and create a new smtp connector with higher priority to use that new smtp service. check if the mail goes. Also check if you are listed in RBL's has a spammer. Having a open relay smtp by mistake may cause this.
0
 

Author Comment

by:milltechtga
ID: 22734953
abdulzis: No luck with your idea.

GreatVargas: Trying your suggestion now, will post back once I have tested it.
0
 

Author Comment

by:milltechtga
ID: 22735297
GreatVargas: Yes I use the default SMTP virtual server to relay messages. I have checked a couple of RBLs and could not find our domain on there. The server is not setup as an open relay. Or at least thats what mxtoolbox.com told me. I created a new SMTP server through Exchange System Manager as I could not find it in IIS. Not sure if that's correct but it didnt fix the problem.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 15

Expert Comment

by:GreatVargas
ID: 22736535
dont create the server in exchange. go to some other server that you have, go to admin tools, add remove programs, add windows components, go to iis and inside select that you want to install smtp service. install and then trough the iis console choose the smtp service and configure it tjo allow your exchange server to relay. configure the smtp connector in exchange to use as smart host the iis/smtp machine. test and report.

it will help

regards
António Vargas
0
 

Author Comment

by:milltechtga
ID: 22736675
This is a single server network.
0
 
LVL 15

Accepted Solution

by:
GreatVargas earned 500 total points
ID: 22736722
install iis on one xp system... it's possible and the steps are the same
0
 

Author Comment

by:milltechtga
ID: 22736766
Will do.
0
 

Author Comment

by:milltechtga
ID: 22753477
I have not yet tested your idea GreatVargas: however I came into work today and found I had some emails from clients saying that our emails from last week all came thru yesterday at once. (Delay of 1-5 days on some of them) I have since tried to send another test email to 3 different emails with no luck. I am very puzzled by this event.
0
 

Author Comment

by:milltechtga
ID: 23142786
I found the problem. It was due to an incorrectly configured SMTP proxy server. Emails were being delayed by a few days or not being sent at all. Thanks for all the help.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
how to add IIS SMTP to handle application/Scanner relays into office 365.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now