Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Fedora 9 Display Out of Range

Posted on 2008-10-16
6
Medium Priority
?
1,805 Views
Last Modified: 2013-12-06
OK Have searched the fedora section for relative posts but i haven't seen 1. So i'll post hoping that im not covering ground already covered in a previous post.


PROBLEM:
When i try to run the Fedora 9 graphical anaconda setup , the monitor blacks out and says "out of range"

When i run the intaller in text mode, then complete it , when i startx it does the same thing.

I am using an Nvidia 6800 GT and 22" widescreen Veiwsonic monitor.

I have read many post relating to editing manually the conf file. but am new to linux and dont know how to use some of the built in text edotors , so if you want me to edit please include relevant command line tools.

When i try to run system-config-display again it produces the monitor displaying "out of range".

Apparently there are issues with the Nvidia drivers and the new version of x being 11. is there any way around .
Or should I just swap to another graphics card I have a spare ati 3400HD

Help , please linux gurus...

Kman
0
Comment
Question by:Kramer8u
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 3

Accepted Solution

by:
sbickerstaff earned 750 total points
ID: 22729919
Hi,

I've came across this problem on many occasions ever since the release of Fedora 8 as I have a 6800XT card.  I recently changed my monitor to a Samsung from an Acer and no longer get this out of range issue.  Therefore while it IS an issue with the nividia driver, it's not actually the card, its the monitor itself.

Is this a live server?

TO install with graphics option, you cen edit the boot line to use the vesa driver.  This worked prior to F9 but I couldn't get it to work for F9.  If you have the server installed using text mode:

- Log in to the server;
- From command line, type:
 
# vi /etc/X11/xorg.conf

- look for something like Driver=nv (or nvidia)
- Hit ESC key twice and then the i key (puts you into insert mode within the vi editor
- change nv (or nvidia) to vesa
- Hit ESC key again and type :wq!
- then type init 5 (this restarts the x server for the graphics.

let me know how you get on or if anyone else knows an alternative
0
 
LVL 4

Expert Comment

by:larsga
ID: 22735675
"Out of Range" means that the video card is supplying the monitor with a signal it is not able to display (usually too high resolution or too high refresh rate).

There is a standard for how  the monitor can inform the video card of what it is capable of displaying ("EDID"), to make sure that it picks a mode that works. With reasonably modern monitors and video cards, this autoconfiguration usually works fine.

However, in your case it seems like this autoconfiguration fails. You can try two things:

(1) Update the graphics driver. Fedora9 unfortunately included a pre-release version of xorg 1.5, and official drivers from nVidia that supported this version of xorg was not available for a while. They released an updated driver a while ago, and download link/instructions for installing it are available at http://www.nvidia.com/object/linux_display_ia32_173.14.05.html

(2) It might be that the monitor "lies" (has incorrect EDID information), which makes the video card think that it supports video modes that the monitor really doesn't  support. If this is the case, check the manual for your monitor for what modes it really supports and then use nvidia-xconfig to set a working mode manually (instructions for using nvidia-xconfig can also be found at the link above).

Good luck, and happy Linuxing.
0
 

Author Comment

by:Kramer8u
ID: 22737058
sbickerstaff:
I successfully edited the config file but no change still says out of range,
Im assuming then the monitor is the issue , so i pluggged in another monitor 17in standard ,
same thing happended , so im assuming that the driver is either miscalculating the edid and setting a too high resolution or refresh rate..
QUESTION?
Can i defind in the xorg.conf  the resolution and refresh rate manually ,
if so how ..

thankyou
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Kramer8u
ID: 22737125
Ok thankyou to sbickerstaff:

Whilst you solution didn't work , you put me on the right track :

For Future reference:
You need to additional line to the edit of the Xorg.conf
so do the above in sbickerstaff:'s solution :

" - Log in to the server;
- From command line, type:

# vi /etc/X11/xorg.conf

- look for something like Driver=nv (or nvidia)
- Hit ESC key twice and then the i key (puts you into insert mode within the vi editor
- change nv (or nvidia) to vesa
- Hit ESC key again and type :wq!
- then type init 5 (this restarts the x server for the graphics."


ALSO-:ADD-: UNDER THE FOLLOWING SECTION
Section "Screen"
Identifier "Screen1"
Device "Built-in Video"
Monitor "Envison EFT720"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768"
EndSubSection

Add the bold "modes" line to force  the screen resolutions.
 
From here i intent to do  larsga: solution and update drivers
 
Thankyou all for your input
Kman
0
 

Author Closing Comment

by:Kramer8u
ID: 31506639
additional line required, see post
0
 
LVL 3

Expert Comment

by:sbickerstaff
ID: 22738476
ah, usualy waited until i got the gui and then set the mode to 1280x1024 but glad you got it all sorted.  Its an issue which is well know, but most people tell you how to fix it after you've installed fedora.  the xdriver=vesa use to work in F8 but something was changed and didn't work for F9.  Just maybe need to check out your choice of monitor next time you're getting one.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question