Solved

web site properties - Use IIS Web Server

Posted on 2008-10-16
9
666 Views
Last Modified: 2008-10-23
I am working on a new web project (C#), it runs just fine on my PC when I have the project's properties set to Use Visual Studio Development Server.   But when I try to change it to 'Use IIS Web Server' and I specify a project Url...I get 'Unable to start debugging on the web server.  The web server is not configured correctly.'  I have checked to be sure it created the virual directory, etc...
0
Comment
Question by:cenetadmin
  • 4
  • 3
  • 2
9 Comments
 
LVL 6

Expert Comment

by:divyeshhdoshi
ID: 22730532
set debug ="false" in web.config as well as page itself
or
Check Integrated windows authentication in website properties >> security >> directory security.

0
 

Author Comment

by:cenetadmin
ID: 22730559
these are both correct.  still get the error.
0
 
LVL 6

Expert Comment

by:divyeshhdoshi
ID: 22730607
Is Anonymous authentication is also checked? If not then check it.
0
 

Author Comment

by:cenetadmin
ID: 22730644
yes it is checked. looking around on the web for any other ideas...I am sure it is something simple...could it be an issue with me having asp.net 2.0 and 3.5 on this same machine?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 6

Expert Comment

by:divyeshhdoshi
ID: 22730702
goto windows explorer
navigate to your project folder >> properties
give aspnet user to full control permission.
0
 

Author Comment

by:cenetadmin
ID: 22730745
Gave asp.net Machine Account full control in that directory. Same error.
0
 
LVL 20

Expert Comment

by:brwwiggins
ID: 22732171
On the ASP.NET tab of the website properties in IIS is the version correct? Also this document has some more tips

http://msdn.microsoft.com/en-us/library/dwesw3ee(VS.80).aspx
0
 

Author Comment

by:cenetadmin
ID: 22739675
I went to IIS, did properties on my virtual directory...I don't see a ASP.net tab. Only Virtual Directory, Documents, Directory Security, HTTP Headers, and Custom Errors
0
 
LVL 20

Accepted Solution

by:
brwwiggins earned 500 total points
ID: 22740510
hmm, sounds like you may need to try some of these steps

http://forums.asp.net/p/985700/1269754.aspx
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
pdf file 7 72
PHP Curl Setup Option 4 33
Problem to go to Web page 2 52
IIS 7.5 to 8.0 6 72
Using Quotation Marks in PHP This question (http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/PHP/Q_28217211.html) seems to come up a lot for developers who are new to PHP.  And it got me thinking, "How can we explain the rule…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video teaches users how to migrate an existing Wordpress website to a new domain.
Use Wufoo, an online form creation tool, to make powerful forms. Learn how to selectively show certain fields based on user input using rules to gather relevant information and data from your forms. The rules feature provides you with an opportunity…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now