Solved

New Blakcberry bes install - deleting emails

Posted on 2008-10-16
17
498 Views
Last Modified: 2012-05-05
Hi,

I'm in the process of rolling out a new BES install, 4.1.9 on the Vodafone network in the UK.    I'm using Exchange 2003, with Outlook 2003 and 2007 clients running in cache mode.

I've installed BES onto a physical server (RIM refused to let me install on a virtual machine :( ).  The install has gone on ok and complete.  I've had 3 test devices so far.

The first problem i don't seem to be able to fix is a problem deleting emails.

Once the phone has been added onto the bes and has downloaded its emails, if i delete an email from the handset it correctly deletes from MS Outlook.

The problem is if i delete an email form Outlook, it stays on the phone.

Any ideas why this happens?

I thought the whole point was that the mailbox and device keeps in sync!?!?

my devices are a mix of pearls, curves and bold.


I would appreciate any advice you might have?

0
Comment
Question by:falsit
  • 7
  • 5
  • 5
17 Comments
 
LVL 9

Expert Comment

by:mystics7
ID: 22731778
If you look on the blackberr device it self into your messages and click the blackberry butto (to left of the scroll wheel) select options, then select email reconcliation, you will see an option for "Delete ON :" makes sure that is selected to mailbox and handheld.
0
 

Author Comment

by:falsit
ID: 22731805
yep, it's already on 'mailbox and handheld'.

any other ideas?
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22731831
They only thing off the top of my head really quick..... working on 1 hour sleep last night..... is take Outllook out of cached mode and see if that resolves it, I came across this once on my CEO's computer
0
 

Author Comment

by:falsit
ID: 22731989
but i want to use cached mode!... isn't this a major problem for RIM BlackBerry and BES?

cached mode is a great feature of outlook but turning it on breaks BES?!?!?


please say there's a work around?!?!
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22732044
when you delete the email from outlook are you doing a shift+del, or just delete and let them stay in your deleted items?
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22732138
also if you are perminatly deleting emails (shift+del) or emptying the deleted items before the BB syncs you can enable a feature in BES 4.1 to process perminatly deleted items if not already enable

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB14142&sliceId=SAL_Public&dialogID=173668936&stateId=1%200%20173666361
0
 
LVL 5

Expert Comment

by:amorgan2000
ID: 22732306
Cached mode works perfectly fine with BES, it just may take 5 minutes more than the 20 minutes recommended by RIM before the Blackberry should have reconciled your deleted items.  
0
 

Author Comment

by:falsit
ID: 22732399
I've already turned on the linked setting :(

I've tried deleting emails in outlook, by shift deleting and by emptying the deleted items folder.

all of them refuse to remove it off the device.

I'm now going to test a non-cached mode setup and see if that works, but even if its does i think it's a major failing with bes....not allowing cached-mode outlook clients.
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 5

Accepted Solution

by:
amorgan2000 earned 500 total points
ID: 22732425
If you delete a message in outlook it must stay in the deleted items folder until it has reconciled on the device.  If the you shift+delete or empty the deleted items folder before reconciliation has occurred (typically 20 minutes or less) then the message is "lost" and will stay on the device "forever".  
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22732457
you don't want to use the shift del or empty the deleted items. BES needs to see the email has been moved to another folder or deleted items to remove it form the messages on the blackberry device. The link to RIMS website was to show how to combat that. I would turn off cached mode and test by sending and email and then make sure it is in the deleted items and wait to see if it deletes of the BB. If it does then renable cached mode, (like amorgan2000 said it does work with it) and see if the problem comes back or goes away. trying to rule out what the cause is, to come to a resolution for the problem.
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22732481
if you shift+del the email from outlook it will not say on the device for ever i do this everyday out of old habits and then just delete them off the device. I have had BB curve, pearl, 8703 and now a 8830 WE and have never had this problem on BES 4.0 and 4.1 with sprint or verizon. So you can delete them if you shift+delete or empty deleted items before the BB syncs
0
 
LVL 5

Expert Comment

by:amorgan2000
ID: 22732568
Correct.  They stay on the device until you delete them manually.  But why delete them twice?!

There is a Hard Delete features with 4.1 that allows this to work.  But in my experience, it doesn't always work.
0
 
LVL 9

Expert Comment

by:mystics7
ID: 22732610
you can use outlook cached mode with BES & BB's. delete an email WITH OUT using shift+del, letting it go into your delete items folder and see if that deletes the email on the BB, try this in cached mode and with cached mode of. remember it can take a few minutes to delete of the device. you can always on the device when you are in your messages click the blackberry button and select Reconsile now.
0
 

Author Comment

by:falsit
ID: 22735285
ok, how about this for a problem.

my outlook has many rules to auto file emails as the are delivered to me.   within outlook inbox they are automatiically moved to a sub folder, however on my BB Curve the rules are not in effect.

how do i turn my outlook client rules to work as server side rules?
0
 
LVL 5

Expert Comment

by:amorgan2000
ID: 22735464
Are you saying that messages that are filed in folders still show up on the Blackberry?  Thats because the Blackberry "Messages" is not your Inbox.  Its all the messages on your BlackBerry, similar, but vastly different.  If you want to to look even more like your Inbox you can hide filed messages.  Go into Message | Click in and go to Options | Go into General Options | Change "Hide Filed Messages" to YES.
0
 

Author Comment

by:falsit
ID: 22735793
that made no difference :(

i thought, it was cause rules are run on the outlook client and not on the server mailbox?
0
 
LVL 5

Expert Comment

by:amorgan2000
ID: 22743212
Some rules are client-side and some are server-side.  Even with Exchange 2000 and Office 2002 you can have server-side rules.  I know Outlook 2003 will actually list next to the rule if its client-side rules.  If they are server-side then it doesn't say anything about client or server.  

If its that they are client-side rules, and you can't make them server-side then your best bet is to use filters to not forward those messages to your BlackBerry.  But then you would never see them on your BlackBerry.  
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now