Error while trying to remove user. Red Hat - userdel

I transferred users from the old to new Red Hat server.   Users with their own directories can't log in.  
If I created user with useradd , there are no problems.  

If I try to remove existing user using eserdel I get error Segmentation fault.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

how did you do the transfer?
What was the version of you old and new RHs?
what is the error message when you try to login with an old user account?
Do you know what type of password file encoding you had and you have now?
Please post the output of


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MontyDogAuthor Commented:
Attached is output from pwck (pwck.txt) .    Grpck allowed me to correct single error, so there is no output now.

To move users I followed instructions from:

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MontyDogAuthor Commented:
Red Hat versions are both the same (4).
Login is SSH and there is no error displaying when you try to log in (just that Authentication failed).
MontyDogAuthor Commented:
Looks like pwck and grpck solved the main problem.  Thanks Tintin.
MontyDogAuthor Commented:
Thank Tintin.  I will look at the rest of the errors later.  Main problem is solved (I had duplicate entries that are deleted now).
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.