Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SQL 2005 Import / Export wizard

Posted on 2008-10-16
9
Medium Priority
?
3,188 Views
Last Modified: 2013-11-30
Hi,

Our company has just switched from SQL 2000 Enterprise Manager to SQL 2005 Server Management Studio.  My problem is when I try to import or export certain tables I get the error message below.  But when using SQL 2000 EM there is no problems or issues.  

I am exporting tables from SQL 2005 to a blank Access 2000 db.  If I use SQL 2000 EM, exporting the same tables it works just fine.  The error indicates that there is a length limitation of 4000.  I know it's not the blank Access db because I've confirmed that Access 2000 can go up to 63,000 or so.  

Is there a setting within SQL 2005 that needs to be adjusted to allow tables over 4000 in length.  The tables I am having trouble with shows 8,000 length.  I also have the same problem with Importing.

I've tried Importing / Exporting from both the server itself and remotely with the same failed result.

This has had to of happen to others right?  I hope someone can help!  Below is the error message.....

Could not connect destination component.

Error 0xc0204016: DTS.Pipeline: The "output column "Facts_of_Case" (1657)" has a length that is not valid. The length must be between 0 and 4000.
0
Comment
Question by:colemac72
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 16

Accepted Solution

by:
brad2575 earned 672 total points
ID: 22733925
The error is not saying the table length is over 4000 but the field "Facts_of_Case" is over 4000.  

What is the data type for this field in SQL 2000?  What is it in 2005?  I am thinking in 2000 is is varchar and 2005 may be nvarchar?

What is the data type in Access you are trying to put it in?
0
 

Author Comment

by:colemac72
ID: 22734664
The data type in SQL2000   Fact_of_Case is varchar and the size is 8000 and allow nulls is checked

This is same in sql2005     Fact_of_Case is varchar and the size is 8000 and allow nulls is checked

Access is - Memo

Thank you!
0
 
LVL 35

Expert Comment

by:David Todd
ID: 22735842
Hi,

The Access Memo will correspond to the Text data type in SQL 2000 and SQL 2005.

Why not transfer data between the two servers directly? Why go through Access?

Cheers
  David
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:colemac72
ID: 22736001
Hi Dtodd,

We actually moved to a new web host and that's why I currently have both SQL 2000 and 2005.  As of tomorrow we will no longer have the SQL 2000 server.  The reason I mentioned SQL 2000 is I was able to export to Access for years with out a problem on SQL 2000.  Now that we are using 2005 A lot of are tables are getting that error message.  

Is there a setting in sql 2005 that can be changed so it can handle the length over 4000?  I just don't understand why SQL 2000 can do it but 2005 can't?  

Any suggestions would really be appreciated !!
0
 
LVL 35

Assisted Solution

by:David Todd
David Todd earned 664 total points
ID: 22736652
Hi,

Just a thought, have you upgraded Access? Might be worth a crack. (That is, get a version of Access that knows about SQL 2005) Only try this if easily done.

Maybe customise the export as a DTS package, and use a query to put limits on the field sizes by doing left( field, 2000 )

HTH
  David
0
 
LVL 51

Assisted Solution

by:Mark Wills
Mark Wills earned 664 total points
ID: 22793080
Would be inclined to map memo to text. Think you will find that memo is regarded a unicode data type so it is restricted to 2 bytes per character - hence the > 4000 message. Also think you will find it is to do with the drivers. Can try changing the column to varchar(max), or, nvarchar(max).
0
 

Expert Comment

by:jermaing
ID: 25831694
I have moved past this my changing the the nvarchar and using max for the limit.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
This article describes a method of delivering Word templates for use in merging Access data to Word documents, that requires no computer knowledge on the part of the recipient -- the templates are saved in table fields, and are extracted and install…
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
Viewers will learn how to use the UPDATE and DELETE statements to change or remove existing data from their tables. Make a table: Update a specific column given a specific row using the UPDATE statement: Remove a set of values using the DELETE s…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question