• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 879
  • Last Modified:

HTTP 500 error with Exchange 2003 Direct Push to WM6.1

Hi all,

Important info first :

Windows Server 2003 SBS
Exchange 2003 SP2
HTC TYTNII w/ Windows Mobile 6.1

I have a problem getting my exchange box to direct push mail to my WM6.1 device.  The basic problem seems to be that when my device asks for a synchronisation, the server reports a HTTP 500 error.  So far I have done the following :

Forwarded port 80 to my server

Run through the setup of a second virtual server for exchange, as listed here > http://support.microsoft.com/default.aspx?scid=kb;en-us;817379

Turned off SSL for the new virtual server

Tried to access the /exchange-oma externally from a web browser, which comes up with a 403 Forbidden msg.

Tried to access the /exchange-oma internally from a web browser, which also comes up with a 403, but also tells me that the website requires me to log in.

Accessed /OWA internally and externally no problems.

Accessed /Exchange internally and externally no problems.

Installed and run 'wireshark', a packet sniffing program.  Below I have included the request from my WM6.1 device and the reply from exchange (as seen by wireshark).  

*****REQUEST*****

No.     Time        Source                Destination           Protocol Info
     82 18.454570   x.x.x.x           192.168.1.5           HTTP     POST /Microsoft-Server-ActiveSync?User=bob&DeviceId=93D82A950318566FF3053ED9A8C6257D&DeviceType=PocketPC&Cmd=FolderSync HTTP/1.1  (application/vnd.ms-sync.wbxml)Continuation or non-HTTP traffic

Frame 82 (505 bytes on wire, 505 bytes captured)
Ethernet II, Src: Cisco-Li_99:31:6a (00:1e:e5:99:31:6a), Dst: Giga-Byt_1a:8e:9f (00:14:85:1a:8e:9f)
Internet Protocol, Src: x.x.x.x (x.x.x.x), Dst: 192.168.1.5 (192.168.1.5)
Transmission Control Protocol, Src Port: ifor-protocol (1515), Dst Port: http (80), Seq: 377, Ack: 342, Len: 451
Hypertext Transfer Protocol
    POST /Microsoft-Server-ActiveSync?User=bob&DeviceId=93D82A950318566FF3053ED9A8C6257D&DeviceType=PocketPC&Cmd=FolderSync HTTP/1.1\r\n
        Request Method: POST
        Request URI: /Microsoft-Server-ActiveSync?User=bob&DeviceId=93D82A950318566FF3053ED9A8C6257D&DeviceType=PocketPC&Cmd=FolderSync
        Request Version: HTTP/1.1
    Accept-Language: en-au\r\n
    X-MS-PolicyKey: 0\r\n
    MS-ASProtocolVersion: 2.5\r\n
    Content-Type: application/vnd.ms-sync.wbxml\r\n
    User-Agent: MSFT-PPC/5.2.1003\r\n
    Host: moby.australianhotels.asn.au\r\n
    Connection: Keep-Alive\r\n
    Cache-Control: no-cache\r\n
    Authorization: Basic YWhhLmxvY2FsXHN0ZXZlOnN0ZXZl\r\n
        Credentials: aha.local\steve:steve
    Content-Length: 13
    \r\n
Media Type
    Media Type: application/vnd.ms-sync.wbxml (13 bytes)
Hypertext Transfer Protocol
    \r\n

*****REPLY*****

No.     Time        Source                Destination           Protocol Info
     83 18.593546   192.168.1.5           x.x.x.x           HTTP     HTTP/1.1 500 Internal Server Error

Frame 83 (311 bytes on wire, 311 bytes captured)
Ethernet II, Src: Giga-Byt_1a:8e:9f (00:14:85:1a:8e:9f), Dst: Cisco-Li_99:31:6a (00:1e:e5:99:31:6a)
Internet Protocol, Src: 192.168.1.5 (192.168.1.5), Dst: x.x.x.x (x.x.x.x)
Transmission Control Protocol, Src Port: http (80), Dst Port: ifor-protocol (1515), Seq: 342, Ack: 828, Len: 257
Hypertext Transfer Protocol
    HTTP/1.1 500 Internal Server Error\r\n
        Request Version: HTTP/1.1
        Response Code: 500
    Date: Fri, 17 Oct 2008 05:32:40 GMT\r\n
    Server: Microsoft-IIS/6.0\r\n
    MicrosoftOfficeWebServer: 5.0_Pub\r\n
    X-Powered-By: ASP.NET\r\n
    Pragma: no-cache\r\n
    Content-Type: text/html\r\n
    Content-Length: 56
    MS-Server-ActiveSync: 6.5.7638.1\r\n
    \r\n

You can see the response code above, HTTP 500.  Has anyone seen this problem before, or have any ideas on what I can do to fix it?
0
marc_of_death
Asked:
marc_of_death
1 Solution
 
scraaneCommented:
Don't use the microsoft document! In SBS ALWAYS use the wizards. To enable OMA just run the Connect to the Internet wizard. Where it asks for what services should be enabled externaly select the Outlook Mobile. When asked to keep or create a new webcertificate, maybe it is best to create a new one. IF you have a external DNS name, use that to create the certificate, otherwise use your external IP address. THIS IS IMPORTANT. Otherwise your phone will say the certificate does not match the address. Then forward port 443 to your server.

On a computer in your domain, start IE and browse go to the exchange page of your server (like https://sbs01/exchange). View the security certificate and export this to file. Copy it to your mobile device and click on it on your phone. This will install the certificate on your phone. Configure your phone to sync with your exchange using your external dns name or ip address (the one used to create your web certificate). Keep the checkmark at SSL connection. You want this secure.

This should get you going.
0
 
marc_of_deathAuthor Commented:
Eventually fixed the problem by tweaking various IIS permission settings.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now