Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Web site Administration Tool not detecting Sql DataSource

Posted on 2008-10-17
4
Medium Priority
?
565 Views
Last Modified: 2012-06-22
I am using Visual Web Developer 2008 Express SP1.

I added a Login Control on my Web Form. While trying to configure the membership, I selected "ASP.NET
configuration" from the Website menu on my IDE to open Web Site administration tool. When I click the
"Security" tab, I get an error "could not connect to SQL Data Provider".

Actually it is not able to detect my SQL Server 2005 Express Edition instance name. This might be due to that while installing SQL Server 2005 Express Edition, I changed the instance name. I am using instance name "SQLXpress" and not "SqlExpress".

I tried to set the configuration from the command line by using 'aspnet_regsql'. Even after successfully
configuring from the command line, it is simply not detecting the Data Store when returned to Web site
Administration Tool.
0
Comment
Question by:rpkhare
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 9

Accepted Solution

by:
HeoQue earned 1500 total points
ID: 22739652
override LocalSqlServer connectionString in web.config
like
<connectionString>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionstring="your connection string" />
</connectionString>
0
 
LVL 8

Author Comment

by:rpkhare
ID: 22740729
Now it is following error:
====================================
There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: The connection name 'LocalSqlServer' was not found in the applications configuration or the connection string is empty. (C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 145)
====================================
0
 
LVL 9

Expert Comment

by:HeoQue
ID: 22740871
please post your connectionstring
0
 
LVL 8

Author Comment

by:rpkhare
ID: 22740877
Ok, I traced the problem. I modified the machine.config file also according to the way you suggested and it worked. Thanks.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question