Error Message when trying to install Horde

Hello,
I am getting this error message when trying to install Horde. PHP 5.2 WINDOWS IIS (XP).
Horde will not run without gettext support. Compile PHP with --with-gettext before continuing.
I have uncommented the line extension=php_gettext.dll in the php.ini and restarted server. I am still getting this error.
How do I repair this?

Thanks
robinrl2008Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
XeroX1988Connect With a Mentor Commented:
I think it's something related to your PHP installation then, are you sure you've set the path to the extension directory correctly in the ini file?

Also, is there a gettext.dll in that extension directory?

If everything is configured correctly and the problem remains could you make a simple php file with the following code?:

<?php
phpinfo();
?>

And upload it to the webserver, if you browse to it it should give you an detailed information page regarding your php installation.

What you should check is the path to the php.ini, see if it uses the right php.ini file. Also, see if there is a header with "Gettext". If the php.ini path is okay and the Gettext header is in the information page it should be working.
0
 
brad2575Commented:
looks like you dont have gettext installed.

Try this link:
http://us.php.net/manual/en/gettext.setup.php
0
 
XeroX1988Commented:
Try copying "iconv.dll" to your C:\Windows\System32 directory and restart IIS after doing so. It should solve your problem.

Hope it works for you, if not, i'm sure you'll leave a reply :-)
0
 
robinrl2008Author Commented:
Sorry,
I couldn't find it so I did a search and it was in my Mysql directory, I copied it and placed it in the directory no change.
0
 
robinrl2008Author Commented:
I was not setting the correct php.ini I found it with a phpinfo();
0
All Courses

From novice to tech pro — start learning today.