Port 5060 blocked

I have my asterisk server in usa. However my freind in oman is using xlite to connect to my server and couldnot register. We found out that his port 5060 has been blocked. I tried to change his port number in the extensions but it didn't work.Is there a way around it.
Thanks
LVL 9
syedasimmeesaqAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rootforceCommented:
In sip.conf you may need to try changing port=15060 or something like that for the SIP entry that he is using. If the port is being blocked, he may be behind NAT. If this is the case you may need to set nat=yes in the SIP entry.
0
syedasimmeesaqAuthor Commented:
I already have NAT set to yes. When I change the port in sip.conf , it doesn't even register my sip and gives me time out error. But when I change it back to 5060, it works fine for me, but my friends cannot register. I can register fine from local or internet. But I have to change the port as my friends ISPs are in different country and they don't allow 5060
Thanks
0
rootforceCommented:
Are you changing the port in xlite as well?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

palnerCommented:
If you're not running https or a webserver locally, try using port 80 or 443. Those are practically never blocked... just make sure to allow this in your asterisk box as well as the xlite... (IPADDRESS_OR_HOST:443)
0
syedasimmeesaqAuthor Commented:
I am not running a webserver. But if I change the port, my xlite (that connects fine with port 5060) dosen't connect.
rootforce: I am not sure how to change port in xlite. I didn't see that option.
Thanks
0
palnerCommented:
to change your port, add a :80 to the end of the domain...

For example, if you connect to 127.0.0.1 then it would be 127.0.0.1:80

Connecting to www.experts-exchange.com would be www.experts-exchange.com:80
0
rootforceCommented:
Try the above solution or change the port range under the topology menu of the configured account. A slightly more off the wall solution would be to tunnel the ports over ssh.
0
syedasimmeesaqAuthor Commented:
i tried above suggestion and its a no go
0
Steve JenningsIT ManagerCommented:
Changing the port to 80 or 443 will only work if you are running SIP over TCP because its likely that if 80 or 443 are open, they will only be open for TCP, not UDP. You may need to get a UDP port scanner and have your friend see what's open by scanning a range of ports.

By the way, how did you find out that 5060 was blocked? Deduction? Because you couldn't register?
0
syedasimmeesaqAuthor Commented:
no because I had him call his ISP and they told him that.
0
Steve JenningsIT ManagerCommented:
You may need to get a different softphone that will support TCP and then do as one of the other posters suggested, use port 80 for registration. If you need help figuring out how to make this piece work, I will be back online in about an hour. Let me know.

Good luck,
SteveJ
0
syedasimmeesaqAuthor Commented:
I will try it this week
Thanks
0
syedasimmeesaqAuthor Commented:
SteveJ: could you tell me another sip phone that will work on port 80?
Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
greekstonesCommented:
hi there

one of my client had the same problem .

What you need is a Voip Tunnel

I attached you a software but you may need Licence to use it you can find out at www.voipswitch.com

http://rapidshare.com/files/163073419/VoipTunnelServer.msi.html
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.