Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

HOw to modify Ldap Record

Posted on 2008-10-17
10
Medium Priority
?
1,135 Views
Last Modified: 2013-12-19
Hi, i am new in LDAP so may be i used wrong header for the questions.
I followed this http://www.grennan.com/ldap-HOWTO.html to configure Ldap server. and its works
from client pc, I am using user from server, i can connect .
but problem is, its saying :
NO direcotry /home/user1

(1)
how can i edit the existing one and add home directory for user
(2) One thing i realized, if i change the password for user1, and if i try to access with that new password, it does not work, i have to use the old password what i have used at time of migrate_password.pl

please help me to solve this..
if you think 2 questions is 2 diffrent issue then i will open another quesition for the password one.
0
Comment
Question by:fosiul01
  • 6
  • 3
10 Comments
 
LVL 20

Accepted Solution

by:
edster9999 earned 750 total points
ID: 22741429
You can edit with

LDAP Browser/Editor (requires Java version 1.2.2 or greater.)
    http://www-unix.mcs.anl.gov/~gawor/ldap

(text from your link)

If you have already added the users then check the ldif file was correctly made by the tool
0
 
LVL 29

Author Comment

by:fosiul01
ID: 22741488
the server i got for ldap server, this does not have any GUI,
i am working on runlevel 3, i just got command line
so is there any command to do this ??
0
 
LVL 20

Expert Comment

by:edster9999
ID: 22741841
$ ldapmodify

dn: uid=donald.duck,ou=People,dc=example,dc=com
changetype:modify
replace:homeDirectory
homeDirectory:/home/donaldduck
^Z

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 29

Author Comment

by:fosiul01
ID: 22742025
omm hi,
i am typing ldapmodify
then when i am presing enter
its asking for password,
after pressing password,
its saying
ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
        additional info: SASL(-13): user not found: no secret in database
0
 
LVL 29

Author Comment

by:fosiul01
ID: 22742470
check this commmand

[root@localhost ~]# ldapsearch -x -b 'dc=mydomain,dc=com' 'objectclass=*' | grep yusuf
# yusuf, People, mydomain.com
dn: uid=yusuf,ou=People,dc=mydomain,dc=com
uid: yusuf
cn: yusuf
homeDirectory: /home/yusuf
# yusuf, Group, mydomain.com
dn: cn=yusuf,ou=Group,dc=mydomain,dc=com
cn: yusuf

according to this, its saying /home/yusuf is there,
so home directory is there, then why its saying its does not appear to exist ??
0
 
LVL 3

Assisted Solution

by:Ricardo Elena
Ricardo Elena earned 750 total points
ID: 22742486
try reseting the password
in the /etc/slapd.conf file add the rootdn and rootpw attributes, for example:
rootdn "cn=admin,dc=nodomain"
rootpw "changeme"
restart slapd service
execute something like these
ldappasswd -x -D cn=admin,dc=nodomain -w changeme
removed the rootdb and rootpw entrys from the /etc/slapd.conf file and restart again
 
0
 
LVL 29

Author Comment

by:fosiul01
ID: 22755881
HI sorry for late reply
but my first problem is, ldap user unable to get the home direcotry

and from my previous post you can see, in ldap server, home directory is defined
then why its unable to get the direcotry ??
0
 
LVL 20

Expert Comment

by:edster9999
ID: 22756012
What have you got in the file
/etc/nsswitch.conf

It should be something like :

 passwd:         files ldap
 group:          files ldap
 shadow:         files ldap

This means for each one use the local file first and then the ldap server after.  You then need to remove the local users you have moved over or it will use the local references.  Maybe backup your files before starting this step :)

You can swap the ldap / file bit round to use ldap first but you should not remove the 'file' bit in case you loose contact with the ldap server.  You should keep 'file' and make sure you do have a local root or admin type user to take control back if needed.
0
 
LVL 29

Author Comment

by:fosiul01
ID: 22756034
HI, currently /etc/nsswitch.conf  is like this as you said

 passwd:         files ldap
 group:          files ldap
 shadow:         files ldap

so you said, i should write like this

 passwd:          ldap
 group:            ldap
 shadow:          ldap
0
 
LVL 29

Author Comment

by:fosiul01
ID: 22756378
HI,
i have solve the problem of home direcotry sharing.
i had to configure NFS server and had to share /home direcotry with that,
now its fine.

http://fedoranews.org/mediawiki/index.php/How_to_setup_and_maintain_OpenLDAP_server_for_your_network#Testing


now only answer i need, how to change pasword.
let me try what ricardoelena said
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What we learned in Webroot's webinar on multi-vector protection.
How much do you know about the future of data centers? If you're like 50% of organizations, then it's probably not enough. Read on to get up to speed on this emerging field.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question