Solved

Smart Host problem - 3x Back end servers, no FE server

Posted on 2008-10-17
3
473 Views
Last Modified: 2013-11-15
We have three back-end Exchange 2003 servers, all SP2. There is no front-end server.

Two are in one site - we'll call those London1 and London2. The other is at a remote site, we'll call that Remote1.

Up until today, London2 and Remote1 have London1 configured as a Smarthost. This then send's e-mail using DNS lookup. Today we setup with a 3rd party mail filter, Messagelabs. I configured London1 to relay all e-mail via Messagelabs (I.e. I configured messagelabs as a smarthost under the smtp virtual server on London1).

Since adding the smarthost, some of the e-mails sent from mailboxes on London1 to mailboxes on the other servers end up in a queue called remote1.ourdomain.com and london2.ourdomain.com and then move quite quickly (couple of minutes) to the 'Messages queued for deferred delivery' queue.

If I take the smarthost out of London1, mail flows around the company fine.

I want to use the smarthost for all mail that leaves the organisation but I also want mail to flow properly between my back-end servers. I think the solution might lie in routing groups and connectors but I'm not really sure what I'm doing with those.
0
Comment
Question by:tlcsupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 12

Expert Comment

by:aa230002
ID: 22762068
How many Routing groups you have and how these servers belong to these routing groups?
You dont need to give smart host on all servers our your organization. You just need to define routing groups and then create routing group connectors between them for mail flow.

On London1 server, i would recommend you to create a SMTP connector with Address Space * and then send all mails to 1 single IP of MessageLabs using this SMTP connector rather than giving the smart host on SMTP virtual server properties.
0
 
LVL 1

Author Comment

by:tlcsupport
ID: 22766235
All 4 servers are in a single routing group. Perhaps this is the problem.

If I create a connector with the address space of *, internal e-mail destined for the other servers attempts to go out via the connector.
0
 
LVL 1

Accepted Solution

by:
tlcsupport earned 0 total points
ID: 23485019
Having removed Sophos Puremessage, the problem resolved. Very strange behaviour. We've since replaced the offending Exchange server and installed Puremessage onto it and do not experience the same problems.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question