Solved

Prompted for workgroup security logon when creating new database

Posted on 2008-10-17
3
238 Views
Last Modified: 2010-04-21
I am trying to create a new database with no workgroup security. My problem is whenever I try to create the database, I am prompted to logon using workgroup security. If I click Cancel, the database is not created.
I tried re-booting and then trying to create the database, but that didnt work.
How can stop this from happening?
Thanks,
Todd
0
Comment
Question by:shambalad
  • 2
3 Comments
 
LVL 57

Accepted Solution

by:
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 22742437
<<How can stop this from happening?>>

Access workgroup security is always "on" and cannot be turned off. Normally you don't see a login because the default workgroup file has a user account called "admin" with a blank password. This is the first login that JET tries when opening a database and if it suceeds, you don't get a login. If it doesn't, it pops up the login dialog.

So it's either one of two things:

1. The password for the admin user is a non-blank.

2. Your joined to the wrong workgroup.

Have you recently worked with user level security or done anything that may have started this?

JimD.
0
 
LVL 7

Author Comment

by:shambalad
ID: 22743630
I work with numerous databases and numerous workgroups here. Basically, as you suggest, I need to be using a workgroup that has the admin profile set with its default permissions and a blank password. In my case, the default workgroup that Access first creates fit the bill.

e.g.: "C:\Documents and Settings\< My Profile >\Application Data\Microsoft\Access\System.mdw"

There are two solutions that I have found that work. One is to simply logon using the current default workgroup when prompted. Then after the database starts, joining the workgoup I really wanted to be part of when working with the database.

There is a second way to do this that bypasses having to log on to the current default workgroup, when creating a new database. This is done by going into the Registry and changing the value of the default workgroup that Access uses when it starts up.

Registry Key:
My Computer\HKEY_CURRENT USER\Microsoft\Office\11.0\Access\Jet\4.0\Engines\SystemDB
0
 
LVL 7

Author Closing Comment

by:shambalad
ID: 31507193
Sometimes I can't see the forest for the tree. Thanks for the help.
Todd
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you are entering numbers in a speadsheet, and don't remember what 6×7 is, you just type “=6*7" instead. It works in every cell! This is not so in Access. To enter the elusive 42 in a text box, you have to find a calculator, and then copy the re…
In a multiple monitor setup, if you don't want to use AutoCenter to position your popup forms, you have a problem: where will they appear?  Sometimes you may have an additional problem: where the devil did they go?  If you last had a popup form open…
Using Microsoft Access, learn some simple rules for how to construct tables in a relational database. Split up all multi-value fields into single values: Split up fields that belong to other things into separate tables: Make sure that all record…
In Microsoft Access, learn the trick to repeating sub-report headings at the top of each page. The problem with sub-reports and headings: Add a dummy group to the sub report using the expression =1: Set the “Repeat Section” property of the dummy…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question