?
Solved

Connecting to a pc behind a router with firewall

Posted on 2008-10-17
11
Medium Priority
?
435 Views
Last Modified: 2012-05-05
I have been trying to connect to several PC's on the office network behind a router with a firewall.  I have forwarded the ports to the computers but I am not able to connect.  I can ping the router but cannot connect to the PCs.  The forwarded ports look like this:

Name: ABC
Private IP:  123.456.78.90
Protocol Type: TCP
Private Port:  5620
Public Port:  5620

I put the router's ip address as the ip address to connect to in pcAnywhere's Quick connect and I have configured the Host communications tab to use; data port - 5620 and status port - 5620 but still cannot connect.  What have I missed?
0
Comment
Question by:swrightsr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 2

Expert Comment

by:XeroX1988
ID: 22742900
PCAnywhere uses UDP aswell, that might be your problem that it's only configured for TCP.

If you would like to check to see if the router's ports are open for using pcAnywhere to connect over the Internet to a host that is behind a router, you can use telnet command to do this. For example, type open xxx.xxx.xxx.xxx 5631, where the x's represent the IP address of the router.

If you see the message "Could not open connection" or you see a blank screen with a blinking cursor, then one of the following is true: 1) The ports are closed. 2) You are using the wrong router. 3) The host is not waiting for a connection. 4) You are connecting through a firewall that is blocking the pcAnywhere ports.

 If you see the error "Connection to host lost," then the ports are open but the host is refusing the connection for some other reason. Check for entries in the TCP/IP options that limit connections to specific addresses. To do this, open pcAnywhere>Tools>Options>Host Communications tab. Ensure that there are no addresses entered in the "Limit connections to the following names or IP addresses" field. If there are, either delete them or add the address or name of the remote computer you are trying to connect with.

If you see the message "Please press Enter," then the port is open.

Hope this gets you some answers why it aint working at the moment.
0
 
LVL 8

Expert Comment

by:DenverRick
ID: 22742914
Why did you change ports?

You need to have 5631 AND 5632 open for pcAnywhere.
0
 

Author Comment

by:swrightsr
ID: 22742972
thnx Xerox1988 for the reply.  I have also tried the both option for Protocol type.  How do I get to Telnet?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Assisted Solution

by:DenverRick
DenverRick earned 400 total points
ID: 22742987
just go to a command prompt and type

telnet x.x.x.x 9999  (port number)
0
 

Author Comment

by:swrightsr
ID: 22742995
This was already setup by the previous person because there is more than one PC that we connect to.
0
 

Author Comment

by:swrightsr
ID: 22743044
when I type "telnet xx.xxx.xx.xxx 9999" at the command prompt I get this message: "'telnet' is not recognized as an internal or external command, operable program or batch file."
0
 
LVL 2

Expert Comment

by:XeroX1988
ID: 22743078
You can also use a program called Putty to telnet, heres the download page:

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
0
 
LVL 2

Accepted Solution

by:
XeroX1988 earned 1520 total points
ID: 22743096
It might also have to do with the fact that you are using the same port for public / private, as the default ports are 2 different ones, if it's not that hard to configure and you have a spare port, could you try to use 2 ports instead of 1 for both?
0
 

Author Comment

by:swrightsr
ID: 22743291
have tried with two different public and private ports no luck.  I tried Putty and I received a message "Network Error: software caused connection abort"  Does this mean the port is not open?
0
 

Assisted Solution

by:kingramco
kingramco earned 80 total points
ID: 22743951
What is the router/firewall device?
0
 

Author Comment

by:swrightsr
ID: 22745103
Dlink DI-624. Thank you to everyone but i figured out my problem.  I did not set my quick connection ports(under Remotes-->Properties-->Details) to go to the ports that had been forwarded.  I appreciate everyones help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month10 days, 22 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question