access denied using rexec.exe

trying to run a remote command to a Windows 2008 server using rexec. (for testing).  Ultimately we will be running the command from an IBM i system 520 using runrmtcmd.  Right now when I enter the command rexec 10.3.9.39 -l remotecmd remotecmd (username and password are the same)
the response I get back from the server 10.3.9.39 is access denied.  Anyone have any ideas?
roomstoreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sk_raja_rajaCommented:
1.Install rshsvr on your server and start the service.
rshsvr can be found on ResKit CD, it contains a detailed installation doc too.
Don't forget to setup your .rhosts file before starting rshsvr.

2.have you tried the username format domain\username , and if a workgroup use the remote ws name as the domain?

3.Also, any firewalls on the other systems that could be blocking this traffic?

4.PsExec v1.72
http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/PsExec.mspx
Nothing needed to install on the other machine as well...
To open a dos shell on the remote machine.....
psexec.exe \\computername -u domain\userid -p password -i cmd.exe
The -i switch forces interaction with teh remote desktop
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
roomstoreAuthor Commented:
Sorry for the delay.

SK Raja,

I plan to work on this Monday. I will try your first suggestion, rshsvr .

We are in a domain, and I have tried d\u format, but the iseries errors out, says the username field can only be 10 characters -- My domain name only exceeds 10 characters. I plan to try this -- Physically logon to the server as the domain\ibm, then try to run the command using 'ibm' as the user. Maybe the connection will pass through, since both users have the same password. I have also created a local 'ibm' user on the 2008 server.

Disabled the firewall.

Psexec -- I believe I have seen this used to aid the installation of unix printers on windows.

Jason
0
roomstoreAuthor Commented:
Your solution is noteworthy, although, what I did to make it work was, started the iSeries for Windows Remote Command service. This is the listerner that accepted my remote command. Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.