Solved

Cancel CISCO telnet Session

Posted on 2008-10-17
17
4,541 Views
Last Modified: 2012-06-22
How do i cancel a telnet session in a cisco router? i try to telnet to a device that is really not online and I do not want to wait until it times out to cancel. Is there a combination of keys?
0
Comment
Question by:TAMSCODAN
  • 6
  • 4
  • 4
  • +2
17 Comments
 
LVL 15

Expert Comment

by:wingatesl
ID: 22745555
To break a session on a cisco router you would hold
ctrl and shift
then hit "6" and then "x"
0
 
LVL 3

Author Comment

by:TAMSCODAN
ID: 22745605
i tried that and it didn't work
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22745646
Are you pressing Ctl + Shift + 6 at the same time then releasing and then hitting "x"?
0
 
LVL 15

Expert Comment

by:wingatesl
ID: 22745657
you did release and wait a second before hitting x? I just tried it on two different routers and it worked.
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22746003
ctrl + shift 6 and x, is used to clear a telnet session when logged into a multiple cisco devices in serial, such as via reverse telnet or telnetted to another device from one device.

I'm not aware of a way to clear a session externally to the router, apart from ring the user and get them to log out cleanly.

You can enable multiple lines and adjust idle timeout periods.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22746071
Rexxus,

Good point. I was assuming that this was about a session FROM a Cisco router.

TAMSCODAN, please let us know the details. What are you telnetting from and what are you telnetting to?

0
 
LVL 3

Author Comment

by:TAMSCODAN
ID: 22746562
I am telneting from a CISCO 7604 to another device however the device does not seem to be available so the telnet keeps trying and I have to sit there and wait until it times out. I have tried the above but it only works for ping and trace routes, not for telnet.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22746574
To break a ping or traceroute all you need to do is issue the break sequence (ctl+shift+6). To suspend a telnet session you have to follow the break sequence with an "x".
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 23

Expert Comment

by:Mysidia
ID: 22746875
To break a command that hasn't succeeded yet, try typing just  
the  default break sequence
Control+Shift+6

Repeat several times in a row,  don't press 'x'  after each time.

The sequence

Ctrl+Shift+6,  then  x
is used to put a connected telnet session into the background, and give
you a router command prompt where you can then type 'disconnect'

If the session isn't established yet, you need to either cancel it or let it
time out.

0
 
LVL 23

Expert Comment

by:Mysidia
ID: 22746911
Break'ing  may not work to escape the telnet.
You can set a different escape character on the vty line, with
for example "escape-character 27"   for the ESCAPE key.

But IOS still ignores the escape sequence while it is waiting to establish
a telnet connection  (or at least in the versions of IOS I can check)


Another possibility is to change the telnet timeout to a shorter duration
For example:
ip tcp synwait-time 10


This way your router waits 10 seconds before timing out new TCP
connections it initiates to other hosts; instead of 30 seconds.

Which makes the wait less unpleasant.

0
 
LVL 3

Author Comment

by:TAMSCODAN
ID: 22761297
I still have not had any success. I tried several times
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22762272
Can you please post the config of the 7604.
0
 
LVL 3

Author Comment

by:TAMSCODAN
ID: 22762509
what do you need from the config?
0
 
LVL 23

Expert Comment

by:Mysidia
ID: 22763236
Please type  "show version"  on the 7604  and indicate what software version & hardware
0
 
LVL 3

Author Comment

by:TAMSCODAN
ID: 22767561
Cisco Internetwork Operating System Software
IOS (tm) s3223_rp Software (s3223_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF15, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Fri 29-Aug-08 19:09 by kellythw
Image text-base: 0x40101040, data-base: 0x42D700A0

ROM: System Bootstrap, Version 12.2(17r)SX3, RELEASE SOFTWARE (fc1)
BOOTLDR: s3223_rp Software (s3223_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF15, RELEASE SOFTWARE (fc1)

ROUTER1 uptime is 1 week, 10 hours, 11 minutes
Time since ONYXONTHEBAY.7604 switched to active is 1 week, 10 hours, 10 minutes
System returned to ROM by s/w reset (SP by power-on)
System restarted at 00:21:43 EST Tue Oct 14 2008
System image file is "sup-bootdisk:/s3223-advipservicesk9_wan-mz.122-18.SXF15.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco CISCO7604 (R7000) processor (revision 2.0) with 458752K/65536K bytes of memory.
Processor board ID FOX11200JTC
R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache
Last reset from power-on
SuperLAT software (copyright 1990 by Meridian Technology Corp).
X.25 software, Version 3.0.0.
Bridging software.
TN3270 Emulation software.
9 Virtual Ethernet/IEEE 802.3 interfaces
57 Gigabit Ethernet/IEEE 802.3 interfaces
1915K bytes of non-volatile configuration memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102
0
 
LVL 23

Accepted Solution

by:
Mysidia earned 500 total points
ID: 22775991
How are you logged into the 7604?
Via a console cable connection, or via telnet?

How are you connecting to the 7604?
E.g. Are you SSH or Telnet'ing  into the 7604  and then attempting to connect
out?

Or is your PC plugged into the 7604 console port with a serial cable?

Reason I ask, is..
I have tried testing  and noted:
Control+Shift+6  then x
_does_ work for me _perfectly_ while attempting to cancel telnet on a device running a 12.2  image, the telnet attempt cancels with a message  "Interrupted by user"

But there is one major caveat.
It only seems to work when consoled into the device telnet is being cancelled from.  (Using the serial cable  on a console port)
I essentially have a default line conf.

I can reproduce your description of it "not working"  if

I use a windows or Linux telnet program and connect to a device,
and from  that device  initiate the telnet command
Control+Shift+6 then x      
does not  seem to work  for cancelling the attempt; only for suspending
an established session.

While at the same time   Control+Shift+6     does the other things I expect it to do   (for example, no problems cancelling traceroutes or pings)


Possibly the device cares _how_ you are connecting to it.
I would suggest you try plugging in a serial port into the 7604 and verify
you can cancel telnet attempts initiated from the console  (if not already).


The only possible 'fix'  I can still suggest is:
conf t
ip tcp synwait-time 5
^Z

Which clearly must be done with care, if  the router is participating in any TCP-based protocols where a 5 second timeout would be undesirable.
0
 
LVL 3

Author Closing Comment

by:TAMSCODAN
ID: 31507304
I was unable to fix my problem
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now