Solved

SBS 2003 VPN

Posted on 2008-10-18
9
398 Views
Last Modified: 2012-05-05
My users are not able to access server drives when connected thru vpn. This has been working for years so it is not an installation issue. SBS is setup to be the RAS server. What I'm seeing is that the users are not getting DHCP during the session, they all have 169. addresses and no default gateway info. they do have dns defined pointing correctly at the server?
does anyone know where I find this setting, I've rebooted the Server, restarted the ip routing service, restarted DHCP service ?
0
Comment
Question by:ahounschell
9 Comments
 
LVL 9

Expert Comment

by:waynewilliams
Comment Utility
If you are running SBS 2003 just run the Remote Access wizard in Server Management (Server Management>Internet & Email>Configure Remote Access).

Also, check in the DHCP console and make sure under "address leases" that you see some that assigned to "RAS".  These are the ones reserved for VPN users.
0
 

Author Comment

by:ahounschell
Comment Utility
I did run the wizard, it completes with no errors, there are ras addresses available under DHCP
0
 
LVL 1

Expert Comment

by:abatemc
Comment Utility
are you using the Connect to Small Business Server connection on the clients? Or did you manually create VPN connections?
0
 

Author Comment

by:ahounschell
Comment Utility
The clients are All Windows XP, I manually created the clients on each computer
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Expert Comment

by:abatemc
Comment Utility
Is it a remote office your're connecting or are these users all over the place? If it's a remote office, make sure that it's on a different subnet. For testing purposes, see if assigning a static address to one or two of the users results in connectivity. Go into the Users snap in in Server Management and right click to properties on one of the users affected. Go to the dial-in tab and assign a static ip address. Try to connect and see if it works. Then we can narrow down the real issue.
0
 

Author Comment

by:ahounschell
Comment Utility
The users just connect to one office/server. I tried the static ip thru ADU&C, dialup , it didn't help.

Oddly this worked yesterday.. No updates or changes that I'm aware of ??? the proble was reported last night, users couldnt connect, after a reboot we can connect but can't access server , no dhcp being issued to the clients ?
0
 
LVL 1

Accepted Solution

by:
abatemc earned 500 total points
Comment Utility
So the users are connecting to SBS from the road, home or wherever right? You are NOT connecting from a remote office back to the SBS Server...?

Try this...From of the the computers trying to get in, go to your RWW site. Make sure you uncheck "I'm using a public or shared computer". Click "Download Connection Manager" on the right hand side and see what that does for you.
0
 
LVL 77

Expert Comment

by:Rob Williams
Comment Utility
>>"The clients are All Windows XP, I manually created the clients "
You should be creating the client using the "create remote access disk" wizard or downloading from the RWW work site. This assures they have correct name resolution. The 169.254.x.x addresses indicate the DHCP service is not properly being applied to VPN clients, though those IP's will work if routing is configured. Better to fix the problem though.

If you use the SBS wizard as waynewilliams suggested it should configure the DHCP relay service for you. Are you sue you are using the "configure remote access wizard" in server management and not the the wizard in the RRAS console?
If it still doesn't work your best bet is to configure a static address pool as per the 10th step in the following link (should not be necessary with SBS, however...):
http://www.lan-2-wan.com/vpns-RRAS-1nic.htm

Good outline of the SBS method to establish the VPN:
http://www.lan-2-wan.com/SBS-VPN-instr.htm

Are the drive mappings done by IP or by name? If by name try pinging or mapping by IP. If that doesn't work make sure the local subnet from which the client is connecting is different that the corporates site. They must be different as pointed out by abatemc.

0
 

Author Closing Comment

by:ahounschell
Comment Utility
Thanks for your help.. I ran the vpn wizard, rebooted the server, reboot the firewall and Recreated with the connection manager. All is working..
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now