php exec under IIS?

Hello,

When I try to run file 1.php with code

<?
  exec("lame.exe -m m -b 16 --resample 22.050 1.mp3 2.mp3");
?>

On my local machine (my machine use apache as web server) it works fine, and create second file.

When I try to run same code on server which running IIS 6 (on windows 2003 platform) it doesn't  work.

Does anyone know how to solve this problem?
dctengineerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
dctengineerConnect With a Mentor Author Commented:
Problem resolved by adding rights for appropriate usarname to cmd.exe
0
 
pr0t0c0l12Commented:
a couple of things.  Make sure that in the properties of IIS you have allowed 1.asp as a recognized page. Meaning that index.html, index.htm, default.php and some other ones are allowed.  

Please go to your web properties, and then add 1.asp to be allowed to run.  If this doesn't work for you...

Try allowind active server pages to run. It is a setting in the IIS menu:
To enable Active Server Pages you will do the following:

1. Go into Internet Information Services

2. Select Web Service Extensions

3. Select "allow" for Active Server Pages
0
 
pr0t0c0l12Commented:
There is a better tutorial to show you how to run active server pages here.

http://msdn.microsoft.com/en-us/library/ms972337.aspx
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
dctengineerAuthor Commented:
I have problem with executing .exe files from PHP, not ASP.
0
 
pr0t0c0l12Commented:
0
 
pr0t0c0l12Connect With a Mentor Commented:
dctengineer this might help you...

http://www.php.net/manual/en/ref.exec.php
0
All Courses

From novice to tech pro — start learning today.