Solved

2924 switch login problems

Posted on 2008-10-18
2
491 Views
Last Modified: 2008-10-19
Okay... Here is my issue.  
If i cli into my 2924 switch i have no problem but it asks me for a pssword.  If I try and log in via the web interface it wants a login name and password.  The thiing is this is only an issue when I try and log in via web interface.  It does not occur when I login via cli.  Strange

********************************config below

     ***** This is the network switch *****

C
**********************************************************************
*                                                                    *
*   PUBLIC EDUCATION NETWORK - NOT USED BY COMMERCIAL OR GOVERNMENT  *
*                                                                    *
**********************************************************************
*                                                                    *
*  The sole purpose of this network is to provide to the the public  *
*  access to a working Cisco router and switch network.              *
*                                                                    *
*  Use this to better learn networking and practice with Cisco name  *
*  brand devices.  This will assist wtih a basic CCNA or an advanced *
*  CCNP certification canidate.  It is also useful for those simply  *
*  wanting to know how to do things on general network devices.      *
*                                                                    *
**********************************************************************



User Access Verification

Password:
Password:
Cisco_2924>en
Password:
Cisco_2924#sh run
Building configuration...

Current configuration:
!
version 11.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Cisco_2924
!
enable secret 5 $1$X4wM$N7aXDzoDN60iJVIX3PQIO1
enable password 7 121811161C0F18
!
ip name-server 192.168.1.110
ip name-server 192.168.1.101
clock timezone EDT -5
clock summer-time EDT recurring
!
interface VLAN1
 ip address 192.168.1.111 255.255.255.0
 no ip route-cache
!
interface FastEthernet0/1
 description Router1720
 speed 100
 duplex full
 spantree portfast
!
interface FastEthernet0/2
 description Server-PDC
 speed 100
 duplex full
 no cdp enable
 spantree portfast
!
interface FastEthernet0/3
 description This is a Test
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/4
 description wood2k3
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/5
 description office_xp_192_168_1_213
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/6
 no cdp enable
!
interface FastEthernet0/7
 no cdp enable
!
interface FastEthernet0/8
 no cdp enable
!
interface FastEthernet0/9
 no cdp enable
!
interface FastEthernet0/10
 description kith_lap (Mallorys room)
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/11
 no cdp enable
!
interface FastEthernet0/12
 no cdp enable
!
interface FastEthernet0/13
 no cdp enable
!
interface FastEthernet0/14
 no cdp enable
!
interface FastEthernet0/15
 no cdp enable
!
interface FastEthernet0/16
 no cdp enable
!
interface FastEthernet0/17
 no cdp enable
!
interface FastEthernet0/18
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/19
 no cdp enable
!
interface FastEthernet0/20
 no cdp enable
!
interface FastEthernet0/21
 no cdp enable
!
interface FastEthernet0/22
 speed 100
 duplex full
 no cdp enable
!
interface FastEthernet0/23
 description BIT_TORRENT_192_168_1_212
 no cdp enable
!
interface FastEthernet0/24
 speed 100
 duplex full
 no cdp enable
!
ip default-gateway 192.168.1.1
logging file flash:log.txt 4096 3072 warnings
no logging console
logging trap debugging
logging facility syslog
logging 192.168.1.101
logging 192.168.1.110
snmp-server community ********** RW
snmp-server community BamBam972 RW
snmp-server trap-authentication
snmp-server location basement
snmp-server contact N.O.C. x-00000
snmp-server chassis-id Cisco_2924
snmp-server system-shutdown
snmp-server enable traps config
snmp-server host 192.168.1.110 cun tty config snmp
banner login ^CC
**********************************************************************
*                                                                    *
*   PUBLIC EDUCATION NETWORK - NOT USED BY COMMERCIAL OR GOVERNMENT  *
*                                                                    *
**********************************************************************
*                                                                    *
*  The sole purpose of this network is to provide to the the public  *
*  access to a working Cisco router and switch network.              *
*                                                                    *
*  Use this to better learn networking and practice with Cisco name  *
*  brand devices.  This will assist wtih a basic CCNA or an advanced *
*  CCNP certification canidate.  It is also useful for those simply  *
*  wanting to know how to do things on general network devices.      *
*                                                                    *
**********************************************************************

^C
banner motd ^CCC

     ***** This is the network switch *****

^C
!
line con 0
 password 7 000507070A5F1F
 login
 stopbits 1
line vty 0 4
 password 7 15131F0D0A2E3F
 login
!
scheduler interval 100
end
0
Comment
Question by:plates55
2 Comments
 
LVL 13

Expert Comment

by:Quori
ID: 22750883
CLI uses your enable password. It would use a username and password if the CLI line was set to login local.

You can use the 'username <blah>' directive at CLI to add a user.
0
 
LVL 2

Accepted Solution

by:
Salman4u_k earned 500 total points
ID: 22751308
Web Interface login need the encrypted password to login.
add the following commands
enable the privilege 15 level secret
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000

encrypted level 15 show like this from show run command:
username admin privilege 15 secret 5 $1$2zeu$djslo$PUklFo
i hope it will work
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now