• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1376
  • Last Modified:

idle timeout (no traffic 15ish min) How to stop it

I'm using UltraVNC 1.0.5
My server has a BLANK screen saver after 5 min.
I find that when remote viewing I get disconnected after 20 mins.
(I assume when the screen goes blank in 5 min. there is no traffic and UltraVNC has some kind of idle timeout default to 15 sec of no traffic?!?!)

***I have the default settings and my .ini file has idleTimeout set to 0***

I do not want UltraVNC to kill my connection at all, EVEN if there is a blank screen for 4 hours.. I still want to stay connected.

Question
How can I stop it from killing my connection? I can not use the reconnect as this turns the screensaver off during reconnection and my servers screen will be on for another 5 min until it turns off.

Thank-you in advance.
0
detroitdr
Asked:
detroitdr
  • 3
  • 3
1 Solution
 
kuknoCommented:
hm.. is there a firewall between your PC and the server? If so, the firewall could well drop your session due to lack of traffic.

Regards
Kurt
0
 
detroitdrAuthor Commented:
Only windows software firewall. But that wouldn't do it would it?
0
 
kuknoCommented:
>Only windows software firewall. But that wouldn't do it would it?

I don't think so. Any messages in the logs (eventlog, etc.) ?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
detroitdrAuthor Commented:
could you point me to where the eventlog would be? (and on server side or viewer side)
I don't even know which side is disconnecting

(I'm running a test now. and I've changed the screensaver (blank) to 20 min. and currently i have not been kicked off.. that's already 24 min. so it appears to be a blank screen.. no activity and UltraVNC kicks you off after 15 min....
0
 
detroitdrAuthor Commented:
If i change the screen saver on server to Stars, then I do not get cut off. So what would be cutting the connection?
0
 
kuknoCommented:
go to the "Admin properties" of the VNC server and enable debug logging. The log file will be WinVNC.log in the install directory. Try to reproduce the "effect" and then either look into the debug file or post it here.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now