Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

421.4.3.2 service not available

Posted on 2008-10-19
6
Medium Priority
?
14,426 Views
Last Modified: 2012-05-11
I have just set up the new small business server 2008
and I have a problem receiving e-mail from external clients
but internally we can send e-mail to each other fine and from a command line-also send e-mail to an internal e-mail box
I'm using the standard SMTP port 25
whenever anybody tries from externally they get 421.4.3.2 service not available
I have checked my firewall and port 25 is open
the IP address is 78.32.179.162 if you have the time to try it
any help would be much appreciated

please be patient as I do not have a e-mail server and I will have to keep looking back here for your reply

Thank you in advance
0
Comment
Question by:LetchfordP
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 18

Expert Comment

by:Andrej Pirman
ID: 22753792
Check all these:
- is port 25 forwarded in your ROUTER to your SBS server local IP?
- disable AntiVirus on SBS and try again. If Antivirus is guilty, dig into settings to let SMTP service to connect to internet and open port 25
- disable any AntiSpam filtering and see if it helps
- I don't know about SBS 2008, but it might include Mail Delaying or Greylisting mechanism, which delays each foreign message for few minutes, and responds with some code. Code should NOT be 421.4.3.2, but you should check if this is the case
0
 

Author Comment

by:LetchfordP
ID: 22753814
Labsy:
thank you for your reply:
hello thank you for your reply
port 25 is routed to small business server
have disabled all anti-virus has still not working
as for your last point about to e-mail delaying I do not see anything that relates to this?

Thank you for looking by
0
 
LVL 3

Expert Comment

by:Scripting_Guy
ID: 22754179
by default, exchange 2007 only accepts inbound smtp emails from trusted sources. in order to change that, open the management console. go to server management, hub transport. There are suppoed to be two default connectors there, i believe one is named client and one is named default. double click the default conector. check under network that it is listening in port 25 and so that we are editing the correct connector. then go to permission groups and check anonymous users.

with this modification, exchange will accept all inbound emails. however, pay attention that you do not become an open relay.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 5

Expert Comment

by:madhusk
ID: 22755473
421 4.3.2 represents "System not accepting network messages response."


1. Check the connection with the AD & mailbox role servers
2. Run the EXBPA and search for the problem.

Run the following script

Test-ServiceHealth
By using this methods you get a clear idea where the problem is exactly and also post the Error code in related to this to better understand the problem


Regards,
Madhu
0
 

Author Comment

by:LetchfordP
ID: 22755603
Scripting_Guy: Thanks but this is already done

madhusk:
1. Check the connection with the AD & mailbox role servers
In SBS AD and Exchange all on one box so no problem with the connection or am I missing something?
2. Run the EXBPA and search for the problem
I have run the EXBPA and no problem, but I will post for all to see.
0
 

Accepted Solution

by:
LetchfordP earned 0 total points
ID: 22769429
OK I have found out what it was:
open the management console. go to server management, hub transport. There are two default connectors there, ione is nanamed default. double click the default conector, network tab, and then and the address for remoute servers opened this up and now all is now working
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question