Solved

Excel does not display correctly when published at 24 bit color

Posted on 2008-10-20
7
1,176 Views
Last Modified: 2012-05-05
We have Citrix Presentation Server 4.5 running on Server 2003.
If I publish Excel 2007 with any display setting above 256 colors, it does not display correctly. Please see screen1.jpg. If I press alt+f, you can see the file menu, see screen2.jpg. Other applications are published at 24bit color without issues.

Can anyone advise why this may be happening please? Apologies for lack of information here. Please let me know what else would be helpful to know. I'm not a Citrix person...

Thanks.


screen1.JPG
screen2.jpg
0
Comment
Question by:BenBispham1
  • 4
  • 3
7 Comments
 
LVL 2

Expert Comment

by:Ron9909
ID: 22757512
Can you post some information about your client device please?  What OS, ICA client version, access method etc?  If you are using Citrix Program Neighborhood/XenApp client, is it client configured to connect to a seamless window, or have you set specific settings for window size/colour depth?

Have you tried running the published app using another type of client?  How about using the client installed locally on the presentation server itself?  
0
 

Author Comment

by:BenBispham1
ID: 22758843
I am using PNAgent 9.2 on Win XP. I just tried changing the depth on the client to 24bit and the res to 1024x768 from default and Excel loaded fine. I didn't realise those settings were there. Thank you.

Although this show's the problem, it doesn't solve it. I would have thought default meant it would take the setting that it is published at? I have no means of changing this setting on all of the clients... Any ideas? We have all different versions of the client in use all over the place. From the server, it works fine with the PNA set to default.

0
 
LVL 2

Accepted Solution

by:
Ron9909 earned 500 total points
ID: 22759578
You are correct in that the settings should be coming from the properties of the published app, however, it sounds like you have a client issue (perhaps only affecting XP with certain fixes, or something to do with your graphics adapter, or 100 other possibilities...), so upgrading the PN Agent client would be my first suggestion.

If that's not an option for some reason, you can make changes to the PNAgent configuration through the Web Interface.  When you configure a PN Agent Service Site (in the Access Suite Console), you are able to modify the 'Session Options', which includes the ability to set the colour depth for all apps.  

Any changes  you make here are added to the config.xml file that relates to that site - this file contains all PNA configuration information, so the next time PNA starts/refreshes, it will get the updated colour depth info you specify (part of the idea of PNA is so that you can centralise all configuration and avoid having to make changes on each client machine).

This might be a workaround if you aren't able to upgrade the client.  I would definitely suggest experimenting with a new version of the client first though if possible.  Perhaps you have a software deployment mechanism in your company you could use to roll out an updated client to the desktops??
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Author Comment

by:BenBispham1
ID: 22765554
Thank you for your advice, very helpful. I have discovered that it is the screen size that's causing the problem. If the 9.2 client is set to default, it doesn't display correctly. If I set it manually to 1024x768 it does work. I've tried the latest client and it doesn't seem to have the problem. Unfortunately we don't yet have any method of software delivery, so I was really hoping to find another solution. I find it strange that it's only Excel that has this problem. Looks like we'll have to ask users to change the setting manually. I'm not going to change the "Session Options" as all of the size options actually work in the client, just not when set to default.
0
 

Author Comment

by:BenBispham1
ID: 22765667
Now with the new client I'm having to enter my password everytime I launch an app, the old one was set to pass through but the option is grayed out in the latest XenApp :/
0
 

Author Comment

by:BenBispham1
ID: 22765863
I removed and reinstalled, solved the problem.

Thanks for your help, I think upgrading the client is the most sensible way to go.
0
 
LVL 2

Expert Comment

by:Ron9909
ID: 22766183
No problem.  Glad to help.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Several part series to implement Internet Explorer 11 Enterprise Mode
Citrix XenDesktop 7.6 Citrix Policies Graphics
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now