Date format in word 2007 mail merge

Hi experts,

I'm having a problem with the format of a date field when mail merging in Word 2007 with Excel data. It usually works fine, but in some cases the date shows up in Word as 39455 instead of "8 January 2008". In Word, I'm using this: {MERGEFIELD  Date_of_Inc \@ "d MMMM yyyy"}. In Excel, the dates come all from the same column and they are all formatted as dates (the first date type).

Any clues?

Thanks!
J
jiiins2Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
dlc110161Connect With a Mentor Commented:
Hi -

Try making Word prompt you for the type of Excel document you are using. You will want to be sure and use the Confirm file format conversion on open (Office Button / Word Options / Advanced - General group)

Then when you perform your merge, use the OLE DB Database file format, so that you can better control the format of your data coming from Excel.

Dawn Crosier-Bleuel
Word MVP
Confirm-File-Format.gif
Data-Source.gif
0
 
Calvin BrineCommented:
I've not tried to use 2007 for a mail merge as yet, but 2003 suffered from the same issue.  The way that I get around it is to encapsulate your results using the text formula.
=Text(A12,"mmm dd, yyyy")
This will force the value to text, so when word reads it, you get the correct results.  
I don't know about Word 2007, but the control codes in 2003 didn't work according to what the instructions stated.
 
HTH
Cal
0
All Courses

From novice to tech pro — start learning today.