RPC over HTTP wont work after reinstall of IIS and Exchange 2003

I have been running RPC over HTTP fine (without certificates) for the last two years on my standalone 2003 Server Standard w/Exchange 2003 Enterprise SP2. Last night my exchange server experienced some SMTP problems which required me to reinstall IIS and Exchange 2003. I restored the metabase files in IIS and followed microsoft's instructions to restore the server. Everyhthing works fine (OWA, ActiveSync) except for RPC/HTTP. I get a password prompt but cannot login in like I normally did with my domain/username and P/W when i am off and on the network.

To troubleshoot I uninstalled the HTTP/RPC service then reinstalled the component, configured the virtual directories security permission as advised, and configured the registry keys using the RPCNOFRONTEND utility. Also configure ESM with the appropriate settings - still no dice.

Been working on this for hours and am going nuts trying to figure out what i am missing...Any suggestion would be much appreciated! I got this working before..not sure what is blocking it from working again....

Thanks,
-Travis

twstreetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bhnmiCommented:
What happens on the remote client? Does it keep prompting for credentials when trying to connect?
0
twstreetAuthor Commented:
yes..its prompts repeatedly and it never accepts the credentials...on the LAN i can connect a client (that is not on the domain) to exchange but when i try to add the proxy server address it says it cant resolve the server...on the outside I use the same FQDN for both the server and the proxy (ctsindiana.dyndns.org) and it always worked..now when the prompt pops up it changes the domain to the NETBIOS NAME/USERNAME... weird....

I dont have any users on the LAN so I have been cocentrating on getting this work from the WAN side....does this help you out?
0
twstreetAuthor Commented:
Finally figured out what the problem was and got it working without using SSL :) It was a longshot but i tried this registry hack posted on technet
http://technet.microsoft.com/en-us/library/bb124604(EXCHG.65).aspx
 Wish i would have found this 10 hours ago! Basically I followed these directions and manually added a new key...hope this helps out anyone else with a similar issue.
-----------------------------------------------------------------------------------------------------------------------
To configure the RPC proxy server to allow for SSL offloading on a separate server
On the RPC proxy server, start Registry Editor (Regedit).

In the console tree, locate the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy

Create a DWORD value with the name AllowAnonymous.

Right-click the AllowAnonymous DWORD value, and select Modify.

In the Value data field, enter 1.

Important:
On the RPC virtual directory security settings in Internet Information Services (IIS), under Authentication methods, verify that the check box next to Enable anonymous access is cleared.

Restart the World Wide Web Publishing Service (W3SVC) in the services snap-in to Microsoft Management Console (MMC).

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.