• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2623
  • Last Modified:

Trying to install a sound card on a Hyper v server

I'm running Server 2008 datacenter edition with several Hyper v virtual servers. The host is a clean install with nothing running but hyper v. I have a virtual server running remote apps and have internet explorer as one of the remote apps. I am wanting to be able to have sound from the remote internet explorer and have installed a soundcard on the host. The card installed fine and the os found a driver and installed automatically. I'm not able to see the sound card on the virtual server. I tried shutting the virtual server using the add hardware in the settings, but the only hardware listed is scsi controller, network adapter, and legacy network adapter.
0
kenfitzgerald
Asked:
kenfitzgerald
  • 15
  • 13
  • 3
1 Solution
 
mdgillCommented:
0
 
kenfitzgeraldAuthor Commented:
do u know what he means by, you need to have Remote Desktop (Or full on Terminal Services installed).
0
 
kenfitzgeraldAuthor Commented:
I enabled the bring to computer option and started the windows audio service but I still get no active sound mixer device installed.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Darius GhassemCommented:
You need the Remote Desktop client installed an giving the ability to allow someone to remote control the Server. Full Terminal Services is installing Terminal Server and configur it to be in Adminitrsrative mode or Application to allow for remote connection. In the actual VM you won't be able to get sound if your at the Server 2008 Console but if you remote desktop into the VM like the above article is saying to then in theory you should be able to get sound.
0
 
kenfitzgeraldAuthor Commented:
yeah, that's what I thought it was. I have the latest rdc client installed and I have terminal services in application server mode installed and have been running remote apps for a couple of months. I still don't have an audio output device installed on my vm. I usually do, and have in this case, rdc straight to the vm, and still am not getting sound. what am I missing?
0
 
Darius GhassemCommented:
Did you follow the steps in the article above?
0
 
kenfitzgeraldAuthor Commented:
yes, actually most of them were already from when I tried to get sound in the past, I have everything set but when I get to this point in the article:
Once you've done that you can turn on the the volume control and you should see that a "pseudo" sound card is installed
I don't get any volume control or pseudo sound card, when I hover over the sound icon in the system tray I get no audio output device installed.
0
 
Darius GhassemCommented:
Have you started the Windows Audio Service?
0
 
Darius GhassemCommented:
Make sure the service above is running then remote desktop to the server then go to Control Panel then Find Sounds and Audio Devices then turn the volume up.
0
 
kenfitzgeraldAuthor Commented:
yes, and I set it to automatic
0
 
kenfitzgeraldAuthor Commented:
the service is started, but when I open sounds in controll panel it says no audio devices are installed.
0
 
Darius GhassemCommented:
But are you RDP into the server then going into the control panel?
0
 
kenfitzgeraldAuthor Commented:
yes
0
 
Darius GhassemCommented:
That should work. Do you have an Audio device on the computer you are RDP from? If  the service is running you can go to the Remote Desktop then connect to the server then go to control panel and change the sound.
0
 
kenfitzgeraldAuthor Commented:
I do have audio on the client pc, but this is still not working when I connect.
0
 
Darius GhassemCommented:
If you followed the steps above then I'm stumped. That should work.
0
 
kenfitzgeraldAuthor Commented:
yeah me too, is there a way to refer to another expert?
0
 
Darius GhassemCommented:
Yes, if you click the Request Attention link under your question. Do me one favor if can you take a print screen of what you are seeing when you RDP and go to the Sound Settings.
0
 
kenfitzgeraldAuthor Commented:
Here is a screenshot of the sound settings control panel applet and my services console on the remote server.
screenshot.doc
0
 
Darius GhassemCommented:
So, you got that screen shot by using Remote Desktop to the server then opening the Control Panel when you are logged into the Server throught Remote Desktop and openning the Sound Settings in the Control Panel?
0
 
kenfitzgeraldAuthor Commented:
Yes, I know it sounds crazy, I don't know why this isn't working. Both screenshots are from the terminal server through RDC.
0
 
kenfitzgeraldAuthor Commented:
Is there a group policy setting that would block this? I have a citrix server that uses the same policy and the sound works on it.
0
 
Darius GhassemCommented:
Is the hyper-v VM you are connecting to 2008?
0
 
kenfitzgeraldAuthor Commented:
yes
0
 
Darius GhassemCommented:
OK, then I have done this with a 2003 Hyper-V not 2008 when I tested the 2008 this doesn't work. Do me favor look in your RDP settings to see if you have Bring Sound to this Computer select. I do and it's still not working.
0
 
kenfitzgeraldAuthor Commented:
yes bring to this computer is selected.
0
 
Darius GhassemCommented:
I can't get it to work with the 2008 Server but can with any other OS. I would hit request attention to see if anyone else can help. I'm not positive if this will work on a 2008 Server.
0
 
mdgillCommented:
this lead me to the solution and i tested with my own datacenter 2008 server with hyper-v running 2008 standard guest.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Remote_Desktop-Terminal_Services/Q_23384292.html

on the terminal server run box, tsconfig.msc
right click RDP-TCP connection and click properties.
client settings tab.
remove the check from audio.
click ok and log off


my sound started working from both rdp into the terminal server and the vm server.
0
 
mdgillCommented:
note: "terminal server run box" i mean the host os
0
 
Darius GhassemCommented:
@mdgill

Great find! That did it for me.
0
 
kenfitzgeraldAuthor Commented:
That did it, thanks guys! Although in my case I had to do this on the host os and the virtual server to get it to work.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 15
  • 13
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now