Solved

Remote Desktop Protocol Error between XP pro PC and NT Server 4.0

Posted on 2008-10-20
3
930 Views
Last Modified: 2013-12-21
Hi all.

I just upgraded  windows XP professional to Service pack 3
After doing this users who use Remote Desktop to access a Windows NT 4.0 server are now having difficulty
they get a popup error stating
"Because of  a protocol error, this session will be disconnected. Please try connecting to the remote computer again"
Users who are still running XP Pro with service pack 2 are not getting this error'

So i am thinking it is related to an upgrade to a remote desktop protocol

I am about ready to pull my hair out

Any help would be greatly appreciated

0
Comment
Question by:cdubbcisco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 5

Accepted Solution

by:
micalkin earned 500 total points
ID: 22759518
according to the help on RDP:

To change authentication options, open Remote Desktop Connection, click Options, and then click the Advanced tab. If you're not sure which option to choose, ask your system administrator or the owner of the remote computer.

Remote computers that are running Windows Server 2003 with Service Pack 1 (SP1) or earlier operating systems cannot provide their identity for verification. If you know that the remote computer is running one of those operating systems, you can avoid authentication warnings by choosing Always connect, even if authentication fails, and then saving that change by clicking Save or Save As on the General tab.

The default option is "Always connect, even if authentication fails." To change it for future use, select the authentication level you want, and then, on the General tab, click Save or Save As to save your settings to an .rdp file. To connect to the same remote computer in the future, double-click the .rdp file.
0
 

Author Comment

by:cdubbcisco
ID: 22767147
i ended up just uninstalling service pack 3 and that fixed the error
0
 
LVL 28

Expert Comment

by:asavener
ID: 24186003
I realize this is an old thread, but :

Find an XP SP2 machine.

Copy MSTSC.exe and related DLL (mstsc??.dll, I forget the exact name) from c:\windows\system32\ to a network location.

Then run that executable from the XP SP3 machine when connecting to the NT 4 terminal server.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question