• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 596
  • Last Modified:

Outlook Web Access stopped working

Outlook Web access has stopped working. I hadn't noticed, just got a call from a user. I can't see anything untoward with it, all services running, nothing changed in the configuration, nothing in the event viewer.
tried to access \https:\servername\exchange, comes back with page not available, can't access it directly from the server and tried using ip address instead of name and that doesn't work. Any ideas where I should start checking? Thx
0
fatboyjimbob
Asked:
fatboyjimbob
  • 11
  • 11
1 Solution
 
DenverRickCommented:
Start in IIS.  Under the Default Web Site, what VD's do you have?  A picture would be sufficient.
0
 
fatboyjimbobAuthor Commented:
Exadmin
Exchange
Exchange-oma
ExchangeWeb
0
 
DenverRickCommented:
Oooh...not good, you're missing some.  What happens when you Right Click and Browse 'Exchange'?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
fatboyjimbobAuthor Commented:
I think there all there.
exchange.jpg
0
 
fatboyjimbobAuthor Commented:
virtual dirs
0
 
DenverRickCommented:
0
 
DenverRickCommented:
THAT don't look to bad, back to the Right Click / Browse question, what happens?
0
 
fatboyjimbobAuthor Commented:
Hi,

It tells me that I must view it over s secure channel and is secured with SSL
0
 
DenverRickCommented:
Ok.  Now on the Server, in a browser https://localhost/exchange???
0
 
fatboyjimbobAuthor Commented:
I get the page cannot be dislayed
0
 
DenverRickCommented:
Have you done an IISReset on the server since this problem started?
0
 
DenverRickCommented:
Also, where does your Certificate come from?  Doesn't appear to be self-signed, have you checked to see it is still valid?
0
 
DenverRickCommented:
If you get PCNBD on localhost...you will probably have to rebuild your OWA (previous link).  Assuming all the services are running.

Have you checked the Application Event Log?  Are there any errors that look suspect?
0
 
fatboyjimbobAuthor Commented:
I have restarted, got this message in my email

sRV2K3 has reported a Error.  Reported status is:
Queues - Unknown
Drives - Unknown
Services - Error
Memory - Unknown
CPU - Unknown

Always had the same certificate, which gives the message that it is from an untrusted site, but worked fine for the last two years with that cert.

0
 
fatboyjimbobAuthor Commented:
I just tried going to the OMA directory and that is working fine
0
 
DenverRickCommented:
Right Click Default Web Site, Properties, Directory Security tab, View Certificate.  Does it have valid dates?

Still want to see what's in the Application Event Log...
0
 
fatboyjimbobAuthor Commented:
clicking on view certificate does nothing, doesn't open up another window...not a thing. Anything in particular I should look for in the event log
0
 
DenverRickCommented:
Red ones!

If you can't view the Certificate, it is probably broken...your IIS does not show the typical VD's that would accompany this box being the Certificate Server, so where was the Cert issued from?
0
 
fatboyjimbobAuthor Commented:
always been using the srv2k3 cert
certs.jpg
0
 
DenverRickCommented:
Did you view this certificate?  Self-signed certs are usually only issued for two years.
0
 
fatboyjimbobAuthor Commented:
i can't view the certificate when I click on it, but the expiry date is 2010 from the previous pic (or is that misleading)  I restarted the server and the only issue in the event logs was MSExchangDSAccess Event Type:      Error
Event Source:      MSExchangeDSAccess
Event Category:      Topology
Event ID:      2114
Date:            20/10/2008
Time:            21:34:17
User:            N/A
Computer:      SRV2K3
Description:
Process INETINFO.EXE (PID=1608). Topology Discovery failed, error 0x80040a02.

For more information, click http://www.microsoft.com/contentredirect.asp.

this has not repeated again.
0
 
fatboyjimbobAuthor Commented:
Fixed this by replacing the current certificate with itself. All started working again. Just don't know why it stopped
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 11
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now