Solved

Cannot Get SIP Phones Working Behind Cisco 857 ADSL NAT Router

Posted on 2008-10-20
2
1,368 Views
Last Modified: 2012-05-05
Experts,

Have installed a cisco ADSL 857 router as per config below. I've little experience of getting SIP phones working and I can't do it with this router. I ahve swapped it out temporarily with the ISP's own router ( A horrible BT 2Wire ) and the SIP phones work fine, problem is, the SIP provider won't support their phones unless they go through a cisco router! Arghh...

The router logs on to the internet fine and NAT works ok - can browse the web / download files e.t.c.

Can anyone help?


version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 123456
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable password 7 ABC123
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2436944224
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2436944224
 revocation-check none
 rsakeypair TP-self-signed-2436944224
!
crypto pki certificate chain TP-self-signed-2436944224
 certificate self-signed 01 nvram:IOS-Self-Sig#4.cer
!
dot11 ssid XYZ1
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7 XYZ1
!
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.11.1
!
ip dhcp pool sdm-pool
   import all
   network 192.168.11.0 255.255.255.0
   default-router 192.168.11.1
   dns-server 192.168.11.1
   lease 3
!
!
ip cef
ip inspect name inout https
ip inspect name inout pptp
ip inspect name inout dns
ip inspect name inout telnet
ip inspect name inout sip
ip inspect name inout sip-tls
ip inspect name inout tcp
ip inspect name inout udp
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain lookup source-interface Dialer0
ip domain name customer.local
ip name-server 208.67.222.222
ip name-server 208.67.220.220
!
password encryption aes
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 description adsl$ES_WAN$
 no ip redirects
 no ip unreachables
 ip virtual-reassembly
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption mode ciphers tkip
 !
 ssid XYZ1
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 no ip address
 bridge-group 1
!
interface Dialer0
 mtu 1452
 ip address negotiated
 ip access-group 121 in
 ip inspect inout out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname 123456
 ppp chap password 7 123456
 ppp pap sent-username 123456 password 7 123456
!
interface BVI1
 ip address 192.168.11.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip dns server
ip nat inside source list 101 interface Dialer0 overload
!
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 101 permit ip 192.168.11.0 0.0.0.255 any
access-list 121 permit icmp any any echo-reply
access-list 121 permit tcp host 208.67.222.222 any eq domain
access-list 121 permit udp host 208.67.222.222 any eq domain
access-list 121 permit udp host 208.67.220.220 any eq domain
access-list 121 permit tcp host 208.67.220.220 any eq domain

no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
 password 7 ABC123
 login
 no modem enable
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 0
 password 7 ABC123
 login
 transport input telnet ssh
!
scheduler max-task-time 5000
end
0
Comment
Question by:prodriveit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 23

Accepted Solution

by:
debuggerau earned 500 total points
ID: 22763576
use the sip fixup commands..

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00801fc74a.shtml

fixup protocol sip 5060    
fixup protocol sip udp 5060
0
 
LVL 2

Author Comment

by:prodriveit
ID: 23837772
This, combined with a correction in access-lists sorted things.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Start Cisco VPN AnyConnect Client Before Windows Login 4 63
Tool to test the firewall  protection 9 88
Cisco Anyconnect on MS Surface 12 51
CISCO WIFI 6 73
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question