Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1807
  • Last Modified:

Can't create a public folder on Exchange 2007

Hello,
I am in a mixed Exchange 2000/2007 environment. I was attempting to create folder replicas and move all public folders from the E2K server to the E2K7 server. For this I have used the following cmdlet:

[PS] C:\>cd $exscripts
[PS] C:\Program Files\Microsoft\Exchange Server\Scripts>.\Moveallreplicas.ps1 server<sourceserver> -newserver<destinationserver>

Then EMS gave me the follwing error report:

Get-PublicFolder : There is no existing PublicFolder that matches the following
 Identity: '\'. Please make sure that you specified the correct PublicFolder Id
entity and that you have the necessary permissions to view PublicFolder.
At line:1 char:17
+ get-publicfolder  <<<< -identity \ -Recurse -resultsize unlimited
Get-PublicFolder : There is no existing PublicFolder that matches the following
 Identity: '\NON_IPM_SUBTREE'. Please make sure that you specified the correct
PublicFolder Identity and that you have the necessary permissions to view Publi
cFolder.
At line:1 char:17
+ get-publicfolder  <<<< -identity \NON_IPM_SUBTREE -Recurse -resultsize unlimi
ted

So in line of this error, I have attempted to create a new public folder manually, using the EMC Public folder in the Toolbox.

While I was attempting to do this, I was unable to manually create a public folder. Nothing worked at all.

Here is the error I am getting while attempting to create a new public folder on the E2K7 server:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00

Error:
There is no existing PublicFolder that matches the following Identity: '\'. Please make sure that you specified the correct PublicFolder Identity and that you have the necessary permissions to view PublicFolder.

MapiExceptionUnknownUser: Unable to make connection to the server. (hr=0x80004005, ec=1003)
Diagnostic context:
   
Lid: 23065   EcDoConnectEx called [length=148]
Lid: 17913   EcDoConnectEx returned [ec=0x3EB][length=56][latency=15]
Lid: 19778  
Lid: 27970   StoreEc: 0x3EB    
Lid: 17730  
Lid: 25922   StoreEc: 0x3EB    

Exchange Management Shell command attempted:
New-PublicFolder -Name 'testpublicfolder' -Path '\' -Server 'computername.domain.com'

Elapsed Time: 00:00:00

I am sure my installation of Exchange went well, used the /PrepareAD and /PrepareLegacyExchangepermissions in the setup. Did not used the /PrepareSchema. My domain controller is a Win2K8 server acting as a GC and DNS.

Any help appreciated, thank you all.
0
beaumier
Asked:
beaumier
  • 4
  • 3
1 Solution
 
beaumierAuthor Commented:
Hi florin,
Thanks for your input, however I already looked at those links you provided, but with no help.

However, I beleive I can trace down the problem to 1 major issue I forgot to include during the setup preparation and perhaps you can confirm this:
On the schema master here are the options I have selected:
-setup.com /PrepareLegacyExchangePermissions -> done
-setup.com /PrepareAD -> done

then installed Excchange 2007. Even the ExBPA (best practices analyzer) found no issues with the Exchange setup

I have forgotten this one:
-setup.com /PrepareSchema
-setup.com /PrepareAllDomains (not required since I have only 1 forest and 1 domain name)

I am currently in the process of rebuilding the whole lab and restart another attempt, this time with all the options to prepare the Active Directory
0
 
florin_sCommented:
Hi,

 - yes you should run the /PrepareSchema command.

  - it does not need to be run on the domain that you run /PrepareAD in, but any additional domains will need this command run. You have three command line options with this command.

    Setup.com /PrepareDomain  Prepares the current domain

    Setup.com /PrepareDomain:FQDN of target domain to be prepped

    Setup.com /PrepareAllDomains  Prepares all domains in the forest.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
beaumierAuthor Commented:
I have re-created my lab to test out Exchange, reinstalled everything but I am still getting the same errors. This time with all the commands (/PrepareLegacy..., /PrepareSchema, /PrepareAD, /PrepareAllDomains)

Also I am getting Event #3113 Source: MSExchangeIS Public Store

Description        There was a problem retrieving the list of public MDBs associated with the TLH with GUID "<guid>". The entry "<object>" was not found in the directory. The item may have been deleted. This problem may resolve itself after directory replication and regular directory maintenence completes.

And to top it off, I am unable to perfom a "move mailbox" between the 2 servers. I am geting errors as well.

In my lab environment those are the VM I have (those VM are identical snapshots taken from my real production servers)
-Windows 2008 domain controller, Global catalog & DNS server
-Exchange 2000 SP3
-Exchange 2007 SP1

Should I include my Windows 2000 domain controller as well in the lab environment?

Thanks.
0
 
beaumierAuthor Commented:
Looks like I have found my problem. It was a permission issue.
Somehow, in Active Directory Users & Computers, in the Users container, there is a group called "Exchange Domain Servers``. The group contained the E2K server, but not the E2K7 server, so I added the server manually into that group and rebooted the E2K7 server.

I am now able to perform a move mailbox operation between the 2 servers and create a new public folder on the E2K7 server.

As for moving public folders from the E2K to the E2K7 folder I will have to investigate some more. There is a script that seems to be working (moveallreplicas.ps1) but needs further testing.

Thanks for your inputs.
0
 
beaumierAuthor Commented:
After reading a few posts from experts regarding public folder replication from Exchange 2000 to Exchange 2007, I finally found solutions from replicating issues between the 2 servers:
-Removed the smart host under SMTP virtual server, the smart host was blocking replication traffic. Also looked for an antivirus software that would block SMTP replication. Restarted the SMTP service afterwards. Used Message Tracking to see replication traffic from the Exchange 2000 box.

-Also created a second Routing group on the Exchange 2000 server identical to the one created by the E2K7 wizard, for some reasons after creating this second routing group, all of the sudden replication began almost instantly between the 2 servers.

-Used moveallreplicas.ps1 script on the EMS (E2K7 server) and cmdlet Get-PublicFolderStatistics, verified item count on both the Management Shell and ESM on the E2K server.

All is well.
Thanks for all your inputs
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now