Solved

Disable Auto DNS Register Server 2008

Posted on 2008-10-20
4
1,863 Views
Last Modified: 2012-05-05
Short version of the issue, I changed my SSL certificate and that has made a disaster with Exchange 2007.  I keep getting the Name on the security certificate is invalid or does not match the name of the site. error on my clients.  The commands everyone posts to correct this in the Exchange Console are NOT working!!  I get an error when I try to run Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://server.mydomain.com/autodiscover/autodiscover.xml  or Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://server.mydomain.lcl/autodiscover/autodiscover.xml 

I know when I delete my secondary IP address from DNS I no longer get the error message on the client and everything runs smoothly.  However even with the Register this connections Address with DNS unchecked on the second network adapter it STILL registers it.  The quick fix that everyone has written really long repairs to is to simply bind a second IP address to another card or to the same interface as long as it doesn't end up in DNS.  how in the world do I get Windows Server 2008 to STOP registering in DNS...I can static enter the IP addresses I need.

What a CLUSTER F*** Windows 2008 Server and Exchange 2007 are!!!
0
Comment
Question by:acasgar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 9

Expert Comment

by:abdulzis
ID: 22764678
http://thebackroomtech.com/2008/03/24/marks-windows-2008-dns-server-command-line-cheat-sheet/

Enable or disable dynamic DNS on a zone
 dnscmd /config zonename /allowupdate 1|0
 1 enables, 0 disables, 0 is default
 
0
 
LVL 31

Accepted Solution

by:
Henrik Johansson earned 500 total points
ID: 22770558
Edit the following in registry
HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Interface name>
\DisableDynamicUpdate=1 (default=0)

KB-reference for 2000/2003
http://support.microsoft.com/kb/246804
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
In-place Upgrading Dirsync to Azure AD Connect
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question