Solved

Cursor in Word 2007 doesn't stay static when typing.

Posted on 2008-10-20
19
3,102 Views
Last Modified: 2012-05-05
I recently bought 4 new dell's for our firm with XP Pro on them.  

These came with Office 2007 for the first time.  All of our other PCs have Office 2003.  One of my employees just called me about an annoyance to her.  I haven't really noticed it, but I don't do much work in Word, but she does.

Anyways, in Word 2007 as you type the cursor disappears and shows up every couple of letters.  Unlike any other app including excel 2007 on the same pc where the cursor/line stays black as you type and only starts to blink when you aren't typing.

I've googled and searched here and found no answers for it.  I found a few asking about it, not many though.  I know my user is being picky on this, but to her is appears as if the text is lagging when she types.

Any ideas?
0
Comment
Question by:jpilet
  • 8
  • 5
  • 4
  • +2
19 Comments
 

Expert Comment

by:TTCLIVE
ID: 22762017
Try this:

Start > control panel > Mouse properties > Pointer options >
Uncheck   "hide mouse pointer while typing"
0
 

Author Comment

by:jpilet
ID: 22762111
No difference.  I changed this options and rebooted just to make sure.

This only happens in Word 2007.  If I go to any other program and say hold down one letter, you'll see the black bar where the text is move along staticly leading the letters.  If I do this in Word 2007, the cursor bar only blinks every 10 letters or so.
0
 

Expert Comment

by:TTCLIVE
ID: 22762224
I've seen a few posts out there that say to delete the normal.dot file and then if that doesn't work use the repair feature of word. Here is Microsoft's take on how to do these things.

http://support.microsoft.com/kb/822005
0
 

Author Comment

by:jpilet
ID: 22762334
This is on a brand new machine I just unboxed though.

This seems to be what it's doing straight from the factory, on all the machines.

Is this not happening on your Word 07?  I have no one to confirm or not if this is normal behavior with Word 07.  

0
 

Expert Comment

by:TTCLIVE
ID: 22762389
I reverted back to Office 2003 after trying 2007 for a while - I just didn't like it. So I don't have an installed copy to check against. I would like to point out however that it is a Microsoft product, so it's possible that it just doesn't work right even with it being a new install!!

It's also possible that it was not installed correctly by the manufacturer. It's kind of hard to believe though that MS would take the cursor away!
0
 

Author Comment

by:jpilet
ID: 22762555
I called my friend many states away and asked him to try this on his vista machine with word 2007, and he said his is doing it also.  

So Unless someone can verify that their word 07 doesn't do it, I guess it's just how it is now, although it's dumb they would change this only in word.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 22762557
I suppose anything is possible. I installed my own purchased copy of Office 2007 Pro on my Vista laptop and the cursor in Word works just fine. I might see it go away for a split second while typing a character, but by and large, the cursor is always there. .... T
0
 

Author Comment

by:jpilet
ID: 22762591
Well that's what I mean.  It goes away and shows every other letter or so.  

If you actually notice this in any other program, it never blinks at all.  It stays a solid black vertical line for every letter you type.

So of course I work for attorneys, and one notices stuff like this as she's saying it hurts her eyes because looks at the screen and reads what she types, and it definitely gives a different feel/look.

I notice that, although I can't say it really bothers me.
0
 

Expert Comment

by:TTCLIVE
ID: 22762603
Maybe it has something to do with the OS? That's pretty much all I've got, sorry I could not help more.  I will keep my ears open and see if I hear anything about anyone else having a solution for this, hopefully someone else might have a solution on here.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 90

Expert Comment

by:John Hurst
ID: 22762695
I guess I cannot see the problem. When I open an empty document, the cursor is blinking, the same as it does in Word 2003. I am not seeing anything beyond that, any problem, or any loss of functionality. With respect to cursor activity, my Word 2007 looks pretty much like my Word 2003.
.... T
0
 

Expert Comment

by:TTCLIVE
ID: 22762776
This is actually from a VmWare post, but maybe give it a try and see what happens?

right click desktop
select settings tab
click advanced

select troubleshoot tab
drag hardware acceleration slider one click to the left (disable cursor accelerations)
click OK

Full post is here: http://communities.vmware.com/thread/106227
0
 

Author Comment

by:jpilet
ID: 22767571
thinkpads user:  Yes, the cursor blinks just like 2003, but when you start TYPING the cursor line goes away.  Just look at the cursor as your type in this browser.  It stays solid for every letter you type.  This happens in EVERY program in windows...except Word 07 from what I can see.

TTCLIVE:  Good idea, tried it and no difference.  I don't think it's something wrong with my systems.  I think it's a word issue with it's interface unfortunately.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 22767864
jpilet - It looks like you or your users may have to get used to this. I pulled up Word 2002 in a Virtual Machine just now. I can just barely see what you are trying to say. So far, Word 2007 is not bothering me in any way.

Take a look in the Word 2007 Options -> Advanced. There is an option called Smart Cursoring there. It is entirely possible that the cursor is doing a lot of work, and possibly the blinking is related to that. You might try testing these various advanced options to see if they help you. I tried a few, and could not perceive any difference. At this point, I am satisfied with the way Word 2007 works for and I am not going to try to change it in any way.

Cheers, ..... T
0
 

Author Comment

by:jpilet
ID: 22767950
But you do see what I'm talking about right?

You do see it is different, and although it may not bother you, it has changed, correct?
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 125 total points
ID: 22769186
I see what you are talking about - that is correct. What I am saying additionally is that it is a non-issue for me. The cursor doesn't stall or go away on my Word 2007, it merely blinks while typing, and until you brought it to my attention, I never even noticed.  
Cheers, .... T
0
 

Author Comment

by:jpilet
ID: 22769718
Correct, that is what I'm talking about.  It's the normal behavior from what I can now tell of Word 07.  The question is, can this be changed so it doesn't blink during typing.

A non-issue for you, but a change to attorneys working on long documents 10 hours a day that is tough on the eyes.
0
 

Author Closing Comment

by:jpilet
ID: 31516955
Closing this as there seems to be no answer to change the way the cursor blinks in the new Word 07...to my dismay :).
0
 

Expert Comment

by:Prekeges
ID: 25584039
Try going to HKCU\Control Panel\Desktop and change the cursorblinkrate to 0.
Note that doing this in Control Panel--Keyboard--Speed--cursor blink rate doesn't work because moving the slider to None changes the registry value to -1.  The regisry value seems to need to be at 0 and then the insertion point seems to stay visible when typing and especially when being moved with the arrows.
0
 

Expert Comment

by:ianto39
ID: 26517517
Using HKCU\Control Panel\Desktop to set cursorblinkrate to 0 doesn't fix the underlying problem. It has the same effect as moving the slider to None, ie make the cursor/I-beam/Insertion Point marker, when inactive, not flash (which is not what you want anyway as it's this flashing that makes it easier to find the cursor in the first place).  The new behavior in O2k7 (and also in O2k10) is to hide the cursor when typing, or flash erratically while typing. This bugs the heck out of me and those who notice it. If you're reading this and you don't mind this new behavior, we don't really need to know that. We would like to know a way to fix it, or maybe one of MS's Ribbon team (presumably) could comment here or on any of the myriad MS forums that raise the issue, confirming that yes they have done this and not included a switch for it. Also, no need to suggest people delete their normal.dot file, or upgrade their video driver, or change their mouse pointer settings etc.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Introduction This tutorial provides instructions on how to properly format your Word document using the inbuilt tools provided. The benefits of using these tools means your documents are more accessible and easily portable to other applications an…
This article descibes how to create a connection between Excel and SAP and how to move data from Excel to SAP or the other way around.
This video shows where to find the word count, how to display it, and what it breaks down to in Microsoft Word.
Learn how to make your own table of contents in Microsoft Word using paragraph styles and the automatic table of contents tool. We'll be using the paragraph styles in Word’s Home toolbar to help you create a table of contents. Type out your initial …

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now