Solved

Pop3 works but SMTP doesn't

Posted on 2008-10-20
22
364 Views
Last Modified: 2013-11-30
I'm aware they're both different.

Where do i begin to check what the smtp settings are for the exchange server in my building?
I should add all incoming emails are scanned for viruses/spam by a third party before being released to our server.
0
Comment
Question by:Antonio King
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 10
  • +1
22 Comments
 
LVL 4

Expert Comment

by:Dizzybro
ID: 22762611
Whos your ISP?
0
 

Author Comment

by:Antonio King
ID: 22762626
Company called Vodat provide our leased line.
0
 
LVL 32

Expert Comment

by:aleghart
ID: 22762650
Are you talking about SMTP outbound or SMTP inbound to you?
Also, are you the mail server admin, or the end user?
What, exactly, is not working?
0
Major Incident Management Communications

Major incidents and IT service outages cost companies millions. Often the solution to minimizing damage is automated communication. Find out more in our Major Incident Management Communications infographic.

 

Author Comment

by:Antonio King
ID: 22762679
Sorry I havn't really provided much information.

I am the mail server administrator, although not highly experienced.
I'm trying to setup access for people to connect to our exchange server from outside the office.

I.e from their home pc's.

Although i've successfully got webmail working, i'd like to add the option of a "permanent" connection using Outlook Express and the like by connecting to pop3 and smtp.

pop3 (incoming emails) works, but smtp just won't connect, and to start off with, i'm not sure what the smtp address to use would be?
0
 

Author Comment

by:Antonio King
ID: 22762699
I've tried the same address for the pop3 section in the smtp section of Windows Mail.

I receive this message when doing send and receive
The connection to the server has failed. Subject 'Read: Maintenance Call Update', Account: *************, Server: 'mail.************', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E

I've also tried smtp.************ with the same response as above.
0
 
LVL 1

Accepted Solution

by:
JamesonJendreas earned 500 total points
ID: 22762712
One issue I have found is that often times an ISP will block traffic on port 25 - the port that SMTP uses to send emails.  This is done to reduce the chance of a user pushing spam through an ISP's system.  We solved this issue by deploying a quick PPTP VPN  (I use RAS on a Win 2k3 server) for outside users to connect to when sending emails.
0
 

Author Comment

by:Antonio King
ID: 22762733
Please note the exchange server is in our building, we provide our own email system. I might be completely way off the mark here, but our emails have nothing to do with our ISP.
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762737
PS - I am referring to the ISP of the HOME user - we ALWAYS have this issue with the AT&T networks (bellsouth, att, yahoo etc) among others.  If you do use SSL, it will not use port 25, but the ISP may also block the ssl port (587 I think is the SSL or maybe that's TLS)
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762768
"Please note the exchange server is in our building, we provide our own email system. I might be completely way off the mark here, but our emails have nothing to do with our ISP."

As mentioned above, it would be the HOME users ISP that would block an SMTP send, if they connect via a VPN to your office before sending an email, then the email will first go through the VPN to your office ISP, which I assume does not block SMTP.

From Wikipedia:

"Port 25 blocking

Firewalls and routers can be programmed to not allow SMTP traffic (TCP port 25) from machines that are not supposed to run Mail Transfer Agents or send e-mail.[4] This practice is somewhat controversial when ISPs block home users, especially if the ISPs do not allow the blocking to be turned off upon request. E-mail can still be sent from these computers to designated smart hosts via port 25 and to other smart hosts via the e-mail submission port 587."
0
 

Author Comment

by:Antonio King
ID: 22762778
Ah I see!

Ok I've successfully connected my home pc via a vpn to my work network.

I've setup windows mail to point to the exchange server.
This is the error I received, once again receiving emails are fine but sending is not.

The message could not be sent. The authentication setting might not be correct for your outgoing e-mail [SMTP] server. For help solving this problem, go to Help, search for "Troubleshoot Windows Mail", and read the "I'm having problems sending e-mail" section. If you need help determining the proper server settings, please contact your e-mail service provider.

The rejected e-mail address was '*********@****.***'. Subject 'Read: Maintenance Call Update', Account: '************' Server: '***.***.***.***', Protocol: SMTP, Server Response: '550 5.7.1 Unable to relay for '*********@****.***', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC79
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762797
Make sure you have "My SMTP server requires authentication" and tell it to use the POP login creds.  
0
 

Author Comment

by:Antonio King
ID: 22762808
ok, that message above popped up because of an email sitting in the outbox. I deleted this and tried sending a test email to myself.

It appears to have sent but i havn't received it yet.
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762846
also, if you continue to get the 550 5.7.1 error, this is regarding a relay issue

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20799097.html 

0
 

Author Comment

by:Antonio King
ID: 22762947
You've been very helpful JamesonJendreas.

Looks like connecting the machine through a vpn solves the problem, I've checked with my isp and port 25 is blocked.

Theroetically I could change the SMTP port on the exchange server and what I have setup here.

What implications would there be to this? Is it advisable?

Only reason I would like to do this is to make it easier for my colleagues to setup their emails, without having to create a vpn connection.
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762968
This is something that I have though about myself, as the VPN is an extra step - In general there isn't any reason I can think of to not change the port - other than 25 is always selected by default, and that if you do choose another port, you'll have to make sure it is not used by any other service.
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22762983
and an MS KB on the issue

http://support.microsoft.com/kb/274842 
0
 

Author Comment

by:Antonio King
ID: 22763253
Ok, thanks for your help!

I've tried changing the port to numerous different types but it's still not connecting.
Even after changing the port on the exchange server, leaving windows mail on my home pc as 25 and trying to connect using the vpn actually works. Which to me says i'm not changing the right setting.

However I followed the KB article you suggested.
Any suggestions?
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22763271
Do you have just one exchange server?  What version are you using?
0
 

Author Comment

by:Antonio King
ID: 22763297
Oh now that is something I should've probably disclosed!

We have 3 exchange servers, all Exchange 2003.
0
 
LVL 1

Expert Comment

by:JamesonJendreas
ID: 22763366
All three will need to be pointing to whatever port you choose.  Like I said I haven't actually tried to run SMTP on another port, so I'm not too sure.  On each server, I believe you'll need to do the following (although you may have already tried this)

Open System Manager
Go to "administrative groups"-->first administrative group-->servers--> 'servername'-->protocols-->SMTP-->Defualt Virtual SMTP server.  Right click on the Virtual SMTP server and click "properties".  Hit the "delivery" tab, then the "outgoing connections button.  Change the TCP port.  Repeat this for all servers in all admin groups.

Next in Outlook you'll need to specify the port for SMTP to use.

Hopefully that'll help, but if you tried that then there may need to be some more research to be done.
0
 

Author Comment

by:Antonio King
ID: 22763474
Yea I had already tried that.

My other thoughts are either firewalls either end or outgoing emails are going out some other way.
As even with all the exchange servers smtp ports changed connecting via vpn and leaving the smtp setting as the default I can still send emails fine!

I've accepted your solution to my original question, Thanks for your help on that JamesonJandreas!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The most common mistakes I hear or read about email usually begin with people talking about POP3 and IMAP, so let's clear those off the table: POP3 and IMAP have absolutely nothing to do with sending or receiving email, so get that notion out of you…
There was an incident about the POP3 issue for the double read receipts and delivery receipts in Exchange 2013.  There was huge research been done and found solution for the duplicate mails. Especially when the user gets  duplicate mails.
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question