Solved

PIX VPN not allowing multiple connections from one site

Posted on 2008-10-20
11
699 Views
Last Modified: 2012-05-05
I'm testing a VPN config from home on my laptop and desktop. Both systems connect fine but it seems only one can access the LAN at a time from my home connection. I thought it might have been an issue with Vista on one system but noticed it worked after I shut off the other connection and reconnected.

I've searched the answered questions and found a possible solution "iskamp nat-traversal 20" referencing connections from behind NAT devices. However when I entered this line it did not seem to make a difference. The whole config I built via the PDM. What am I missing or need to remove?

(I also have two previous vpn config Idle-time entries I can't seem to remove "VPN" "MYVPM")

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ORwbFgCygXFCTltA encrypted
passwd ORwbFgCygXFCTltA encrypted
hostname pix
domain-name domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit tcp any interface outside eq smtp
access-list 100 permit tcp any interface outside eq www
access-list 100 permit tcp any interface outside eq https
access-list 100 permit tcp host 24.45.xx.xx interface outside eq 3389
access-list 100 permit tcp host 63.127.xx.xx interface outside eq 3389
access-list JAMVPN_splitTunnelAcl permit ip host 192.168.20.10 any
access-list inside_outbound_nat0_acl permit ip host 192.168.20.10 192.168.20.0 255.255.255.0
access-list outside_cryptomap_dyn_100 permit ip any 192.168.20.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 38.96.xx.xx 255.255.255.248
ip address inside 192.168.20.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool MYVPN 192.168.20.51-192.168.20.100
pdm location 24.45.xx.xx 255.255.255.255 outside
pdm location 63.127.xx.xx 255.255.255.255 outside
pdm location 192.168.20.0 255.255.255.0 inside
pdm location 192.168.20.10 255.255.255.255 inside
pdm location 192.168.20.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.20.10 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.20.10 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.20.10 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.20.10 3389 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 38.96.xx.xx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 100 match address outside_cryptomap_dyn_100
crypto dynamic-map outside_dyn_map 100 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp nat-traversal 20
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPN idle-time 1800
vpngroup MYVPM idle-time 1800
vpngroup MYVPN address-pool MYVPN
vpngroup MYVPN dns-server 192.168.20.10 66.28.0.45
vpngroup MYVPN wins-server 192.168.20.10
vpngroup MYVPN default-domain jam.local
vpngroup MYVPN split-tunnel MYVPN_splitTunnelAcl
vpngroup MYVPN idle-time 1800
vpngroup MYVPN password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.20.31-192.168.20.50 inside
dhcpd dns 192.168.20.10 66.28.0.45
dhcpd wins 192.168.20.10
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:2fecd9b1503deed9baa8004637105b18
: end
[OK]
 
0
Comment
Question by:Eros18
  • 6
  • 5
11 Comments
 
LVL 22

Expert Comment

by:rickhobbs
ID: 22764879
MYVPN is your vpn pool of addresses,  It is required. It appears the vpn you are trying to configure is JAMVPN,  None of the supporting commands for it are there,   I would recommend you go to the VPN tab and remove everything and start the wizard over.
0
 

Author Comment

by:Eros18
ID: 22768851
JAMVPN = MYVPN. I renamed to hide private information. Looks like I missed one. Any other ideas?
0
 

Author Comment

by:Eros18
ID: 22768908
Just to clarify, the VPN connection works. However if I connect from 2 PC's behind the SAME router only one connection works.
0
 

Author Comment

by:Eros18
ID: 23231494
Any ideas? I have reviewed this config and tested many times. I am still unable to connect from 2 or more systems from the same IP address.
0
 
LVL 22

Expert Comment

by:rickhobbs
ID: 23241012
What is the VPM license on this firewall?  How many connections?
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 

Author Comment

by:Eros18
ID: 23242599
PIX 506e with 25 vpn licenses. No hardware based vpn connections at this time and only using Cisco VPN Client to connect.
0
 
LVL 22

Expert Comment

by:rickhobbs
ID: 23244226
I see a couple things.  First of all it is not good that your vpn tunnel is the same network as your internal network.  I would use 20 internal and 21 for the VPN and add a route for it..   Secondly, there seems to be  problems with the crypto mapping.  You must get rid of the JAMVPN.  If you have, can you post an updated config?  Is the closck set on the PIX?  If yes, set the timezone and DST.
example:
clock timezone EST -5
clock summer-time EDT recurring
0
 
LVL 22

Expert Comment

by:rickhobbs
ID: 23244233
Also, can you open a log window on the second VPN client trying to connect and post the output?
0
 
LVL 22

Accepted Solution

by:
rickhobbs earned 500 total points
ID: 23244245
0
 

Author Comment

by:Eros18
ID: 24942223
The issue turned out to be the Transparent Tunneling option in the VPN 5.0 client. Apparently on one system it was turned on causing a conflict with the Transparent Tunneling config on the PIX. Disabled it and tested again, works great. rickhobbs I assign you the points for following up on this post. Thanks!
0
 
LVL 22

Expert Comment

by:rickhobbs
ID: 24961087
For future reference, if you go under c:\Program Files\Cisco Systems\VPN Client\Profiles and copy the .prf file desired after you have installed the client on an other machines, you won't have to worry about getting something wrong in the configuration.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
This video discusses moving either the default database or any database to a new volume.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now