Solved

Where can I find the PHP5 RPM for RHEL 5?

Posted on 2008-10-21
13
5,750 Views
Last Modified: 2013-12-16
Hello experts,

Can anyone plz tell me from where i can download php5 for rhel 5? I went to http://www.php.net/downloads.php and download the source code from there but i couldnt unzip it. I searched then the red hat site for a php download and couldnt find anything either. Can anyone be kind enough to give me a link to download it and instructions if necessary?

Thanx in advance.
0
Comment
Question by:stavrama
13 Comments
 
LVL 17

Assisted Solution

by:owensleftfoot
owensleftfoot earned 100 total points
ID: 22765057
0
 
LVL 3

Assisted Solution

by:Ricardo Elena
Ricardo Elena earned 100 total points
ID: 22768415
You can download PHP 5 SRPM from official redhat site or centos site
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/
rpm --rebuild filename.src.rpm
cd /usr/src/redhat/RPM/

rpm -iv filename.rpm
0
 
LVL 2

Author Comment

by:stavrama
ID: 22810725
I downloaded the rpm for php but when i try to install it, it says  that i miss specific packages. Those are:

1) httpd
2) httpd-mmn
3) libgmp.so.3
4) php-cli
5) php-common

I havent managed to find httpd-mmn and libgmp. However whenever i try to install the other 3 packages then it says that some other packages are missing. For example when i try to install httpd then i get this error message:

warning: httpd-2.2.3-6.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
        libapr-1.so.0 is needed by httpd-2.2.3-6.el5.i386
        libaprutil-1.so.0 is needed by httpd-2.2.3-6.el5.i386

Can anyone help and tell me what i need to do in order to solve this and install php? Do i need to go and download one by one every package that ask me to do? I have seen this happening one more time when i tried to install oracle but i found a solution there when i installed 1 single package and all the dependencies were gone.
0
 
LVL 2

Author Comment

by:stavrama
ID: 22848617
I still fail to find libgmp and httpd-mmn packages. Can anyone  send me a link with those 2 plz. I remind that i need it for rhel 5
0
 
LVL 2

Author Comment

by:stavrama
ID: 22919638
So far i have installed httpd,  libgmp, php common and php cli. I only miss httpd-mmn in order to install the php package. However i can run now a php script. How is this possible since i haven't installed yet the php rpm? And what is happening with httpd-mmn? I thought that after the installation of httpd, that dependency would have been sorted out.
If i install now the php rpm with --nodeps will it be ok?
0
 
LVL 16

Expert Comment

by:GUEEN
ID: 22923511
What about just using yum to install it via console?

yum install php
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 2

Author Comment

by:stavrama
ID: 22929589
I have done this already but i get the same error:

"Error: Missing Dependency: httpd-mmn = 20051115 is needed by package php"
0
 
LVL 16

Expert Comment

by:GUEEN
ID: 22930122
How about

yum update

yum install httpd


0
 
LVL 16

Expert Comment

by:GUEEN
ID: 22930131
Hold on - first find out if it is installed

 yum list installed httpd
0
 
LVL 2

Author Comment

by:stavrama
ID: 22938408
For the last command you posted i get the following results:

[root@localhost tmp]# yum list installed httpd
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
[root@localhost tmp]#
.
0
 
LVL 16

Accepted Solution

by:
GUEEN earned 300 total points
ID: 22938924
Perhaps you need this update?
http://rhn.redhat.com/errata/RHBA-2008-0360.html
0
 
LVL 2

Author Closing Comment

by:stavrama
ID: 31508171
It appears that i can do my job with the packages php-common and php-cli since i dont need the html version of php. Thanx a lot for your help :)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
AWS RDS 3 64
bad ownership or modes for chroot directory 6 63
File and print server with Ubuntu? 7 23
How code a 301 redirect for folder files -> 1 file 2 11
This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now