Solved

SBS Server stopped accepting RDP connections

Posted on 2008-10-21
16
586 Views
Last Modified: 2012-05-05
I use RDP to administer my SBS 2003 server. For a couple of years up until today it was fine. Today it is not accepting RDP connections. We also have a 2003 Terminal Server on this network. It is still working normally. When I switched on the SBS Server Console today, there was a balloon at the bottom right stating that an update had been installed which required a reboot. Maybe something happened because of this update.

I have rebooted the SBS Server and re-rerun the CEICW without any success.

What should I do next to try and fix this?

Ian
0
Comment
Question by:ipendlebury
  • 10
  • 6
16 Comments
 
LVL 1

Expert Comment

by:robclarke41
ID: 22765683
Perhaps you are no longer accepting remote connections?

Try:
windows key + pause/break
Go to the remote tab
Make sure enable remote desktop on this computer is checked
0
 

Author Comment

by:ipendlebury
ID: 22765710
Thanks for the reply. I just checked that. Remote Connections are still enabled on that screen
0
 
LVL 1

Expert Comment

by:robclarke41
ID: 22765745
Any antivirus software or firewalls modified/installed on the server? You need port 3389 open to RDP
0
 

Author Comment

by:ipendlebury
ID: 22765789
Nothing has been modified since it last worked. But I mentioned in my opening message about the update.

This Server has ISA Server installed. When I ran the CEICW I have checked the box to enable TS in the Firewall. I just ran it again without success
0
 
LVL 1

Expert Comment

by:robclarke41
ID: 22765812
Try this:

1. Click Start, click Run, type cmd, and then press ENTER.

2. At the command prompt, type the following commands. Press ENTER after each command.

cd /d %programfiles%\microsoft isa server

regsvr32 wspadmin.dll


3. When you receive the DllRegisterServer in wspadmin.dll succeeded message, click OK.

4. At the command prompt, type the following commands. Press ENTER after each command.

md VPN\Netsh


net start fwsrv

0
 

Author Comment

by:ipendlebury
ID: 22765835
Ok I did all that.....

The Regsvr32 command succeeded.

It said that the VPN\Netsh folder already existed.

It said that the fwsrv service is already started.
0
 

Author Comment

by:ipendlebury
ID: 22765841
The server is not accepting RDP connections from the internal or external networks
0
 
LVL 1

Expert Comment

by:robclarke41
ID: 22765860
Have you tried editing the system policy and adding your machine/ip address to the remote management computers group?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Author Comment

by:ipendlebury
ID: 22765893
I shouldn't have to do that. I've always been able to RDP in from anywhere in the outside world. Ie from any machine and any IP address. Currently I am in the office and therefore trying to connect on the internal network. If I added my computer to that System Policy, it would not alter external access.
0
 
LVL 1

Accepted Solution

by:
robclarke41 earned 500 total points
ID: 22765898
Also in the terminal server config, RDP-TCP settings under the network adapter tab make sure only your internal adapter is selected
0
 

Author Comment

by:ipendlebury
ID: 22766054
Ok we have a partial success now. In the RDP TCP Settings, it was configured for all adapters. I changed it to just the internal adapter. Now I can connect from the internal network only. But this is what I would expect from disabling the externla adapter,

So how do I make them both work?
0
 

Author Comment

by:ipendlebury
ID: 22766195
I just checked the RDP TCP Settings on another SBS Server that I adminster at another company. This server is working normally and accepting both internal and external RDP connections. The RDP TCP is configured for all adapters. So presumably my server should be able to function similarly?

Obviously we have fixed something by changining this setting. But i need it to work on both adapters.
0
 
LVL 1

Expert Comment

by:robclarke41
ID: 22767433
I'm afraid I'm out of ideas then, I'll have a look on some of my virtual machines and see if I can replicate your problem.
0
 

Author Comment

by:ipendlebury
ID: 22767555
Thinking that I might have flushed out a gremlin, I put the RDP TCP settings back to 'All adapters', but RDP stopped working internally again. Thanks for our efforts so far,

Ian
0
 

Author Comment

by:ipendlebury
ID: 22768074
That should read: 'Thanks for your efforts so far'
0
 

Author Comment

by:ipendlebury
ID: 22784606
Later that day, I tried again to RDP into the server and it worked. So I don't know if it freed itself up, or something eventually happened as a result of me changing the RDP TCP setting. But i'll award the points and thank you for your efforts.

Ian
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Many functions in Excel can make decisions. The most simple of these is the IF function: it returns a value depending on whether a condition you describe is true or false. Once you get the hang of using the IF function, you will find it easier to us…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now