Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

EthX don't become up during startup

In my envirnment with RedHat Linux the eth0 and arh1 are configured in bonding in bond0.

here the configuration:
# cat ifcfg-bond0
DEVICE=bond0
ONBOOT=yes
BOOTPROTO=static
IPADDR=10.130.15.22
NETMASK=255.255.255.192
GATEWAY=10.130.15.1
# cat ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
MASTER=bond0
SLAVE=yes
ETHTOOL_OPTS="autoneg off speed 100 duplex full"
# cat ifcfg-eth1
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=static
MASTER=bond0
SLAVE=yes
ETHTOOL_OPTS="autoneg off speed 100 duplex full"


When the operating system startup the eth0 and eth1 don't come up and I need to give the command:
ifconfig eth0 up
ifconfig eth1 up
to make it working.

in boot.log i see:
Oct 20 12:14:14 t1nlas2a sysctl: net.ipv4.ip_forward = 0
Oct 20 12:14:14 t1nlas2a sysctl: net.ipv4.conf.default.rp_filter = 1
Oct 20 12:14:14 t1nlas2a sysctl: kernel.sysrq = 0
Oct 20 12:14:14 t1nlas2a sysctl: kernel.core_uses_pid = 1
Oct 20 12:14:14 t1nlas2a network: Setting network parameters:  succeeded
Oct 20 12:14:14 t1nlas2a network: Bringing up loopback interface:  succeeded
Oct 20 12:14:17 t1nlas2a ifup: Enslaving eth0 to bond0
Oct 20 12:14:17 t1nlas2a ifup: Enslaving eth0 to bond0
Oct 20 12:14:17 t1nlas2a ifup: Enslaving eth1 to bond0
Oct 20 12:14:18 t1nlas2a ifup: Enslaving eth1 to bond0
Oct 20 12:14:18 t1nlas2a network: Bringing up interface bond0:  succeeded
Oct 20 12:14:18 t1nlas2a tune_vm: Setting the VM Inactive Clean Percent value to 100
Oct 20 12:14:18 t1nlas2a rc: Starting tune_vm:  succeeded
Oct 20 12:17:39 t1nlas2a ntpd:  failed
Oct 20 12:17:40 t1nlas2a ntpd: ntpd startup succeeded

in
messages:
Oct 20 12:16:25 t1nlas2a kernel: ip_tables: (C) 2000-2002 Netfilter core team
Oct 20 12:16:25 t1nlas2a kernel: Ethernet Channel Bonding Driver: v2.6.0 (January 14, 2004)
Oct 20 12:16:25 t1nlas2a kernel: bonding: MII link monitoring set to 100 ms
Oct 20 12:16:25 t1nlas2a kernel: ip_tables: (C) 2000-2002 Netfilter core team
Oct 20 12:16:25 t1nlas2a kernel: tg3.c:v3.52RH (Mar 06, 2006)
Oct 20 12:16:25 t1nlas2a kernel: eth0: Tigon3 [partno(349321-001) rev 2100 PHY(5704)] (PCIX:66MHz:64-bit) 10/100/1000BaseT Ethernet 00:17:a4:a9:d5:f0
Oct 20 12:16:25 t1nlas2a kernel: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] Split[0] WireSpeed[1] TSOcap[0]
Oct 20 12:16:25 t1nlas2a kernel: eth0: dma_rwctrl[769f0000]
Oct 20 12:16:25 t1nlas2a kernel: eth1: Tigon3 [partno(349321-001) rev 2100 PHY(5704)] (PCIX:66MHz:64-bit) 10/100/1000BaseT Ethernet 00:17:a4:a9:d5:ef
Oct 20 12:16:25 t1nlas2a kernel: eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] TSOcap[0]
Oct 20 12:16:25 t1nlas2a kernel: eth1: dma_rwctrl[769f0000]
Oct 20 12:16:25 t1nlas2a kernel: bonding: bond0: enslaving eth0 as a backup interface with a down link.
Oct 20 12:16:25 t1nlas2a kernel: bonding: bond0: enslaving eth1 as a backup interface with a down link.


How could I solve the problem?
Thanks
0
nokiamobile
Asked:
nokiamobile
1 Solution
 
Ricardo ElenaManager, US OperationsCommented:
An easy way is to write:
ifconfig eth0 up
ifconfig eth1 up

in the file /etc/rc.local and restart
0
 
jgiordanoCommented:
did you put the bond parameters in the modprobe.conf?

also I like to put the mac addresses in
ifcfg-eth0
ifcfg-eth1
0
 
nokiamobileAuthor Commented:
The correct solution was to delete al
ifcfg-eth0*
ifcfg-eth1*
files
there was some ifcfg-ethX.orig in the directory.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now