Solved

How to share my Verizon broadband card's internet connection with another computer wirelessly

Posted on 2008-10-21
20
1,193 Views
Last Modified: 2010-05-18
At home, my husband and I each have a notebook computer running Windows XP and we access each other's files and printers and the internet wirelessly. We have Verizon FiOS internet, a D-Link router, and a Linksys wireless access point.

Now - when we go on the road: I have a Verizon broadband card (pcmcia) that we physically share. Only one of us at a time can be on the internet.

I know that Windows XP supports Internet Connection Sharing, but I'm confused about how to set this up. I've gone as far as specifying that my Verizon BB connection is to be shared with other computers on my network. But what I'm confused about is how do I setup the local area network wirelessly? Right now, neither one of us sees the other's computer in "Network Connections". And can I do this without destroying all the settings that we use at home? That is, I want to go home and have everything still work as it usually does there without having to reconfigure anything.
0
Comment
Question by:alicia1234
  • 16
  • 4
20 Comments
 
LVL 44

Accepted Solution

by:
Darr247 earned 500 total points
Comment Utility
Well, when you choose to share it via ICS, it should ask you which interface you want to share. i.e. Unless the wireless card is the only network adapter (besides the 3G card) there should be a picklist and it will urge you to choose one. I presume you have already chosen the wireless card (if it's the only other network adapter it's selected automatically). That means ICS should set the wireless card to a static IP of 192.168.0.1... to check that, right-click the wireless card's icon in the tray and choose Open Network Connections, double-click the wireless adapter, in the dialog that opens scroll to the bottom and choose Internet Protocol (TCP/IP) then click Properties. This should be the only setting you'll need to change back and forth to switch between sharing and home. i.e. when you're home you'll switch that back to 'Obtain IP automatically', and when you want to share change that back to 192.168.0.1 / mask 255.255.255.0.  You MUST use that address when sharing the connection for the ICS DHCP server to work properly.

Step 2.
To connect the laptops, create a new wireless ad-hoc network. Following the same directions (above) as getting to the TCP/IP screen, click the Wireless Networks tab instead of scrolling down to TCP/IP on the General tab.
On the Wireless Networks tab, click Advanced. Check the box next to Any available network (access point preferred), and UNcheck Automatically connect to non-preferred networks if it's checked (SP3 for XP should have unchecked it, but in case you haven't updated). Then click Close.
Back on Wireless Networks, click Add. For Network name (SSID) I suggest 3G-Share. At the bottom of that window check the ''This is a computer-to-computer (ad hoc) network ...'' box. That will probably eliminate other encryption/authentication choices beside WEP and Open. Enter a 10-digit key. e.g. A phone number without the dashes works good. That's only 64-bit RC-4 encryption, but it means less overhead. Repeat in the Confirm field.
On the Connection tab uncheck the Connect when this network is in range box. OK back to the Wireless Networks tab.
You should now have a new network listed named 3G-Share (On Demand).

On your husband's computer, just do Step 2 above. Remember the SSID is case sensitive (so 3G-Share doesn't match 3G-share nor 3G-SHARE), and remember to enter the same 10-digit WEP code.

When that's done, look in View Available Wireless Networks on your husband's computer and the new network should appear with a little wireless card icon (if I recall correctly) next to it instead of an antenna tower icon as Infrastructure/access point networks get. Select that icon and click Connect. If it connects without clicking the Connect button first, go back to the Connection tab in the Properties of 3G-Share in Preferred networks and UNcheck the Connect when this network is in range box (this is really a serious security setting that should't be hidden away like that... it's to ensure your computers don't offer your WEP password to other ad-hoc networks you happen to encounter along the way who have also named their network ''3G-Share'', which, while unlikely, is not totally unfathomable).

If you watch the connection occurring in Network Connections you should see in the lower left corner of that window when it receives its IP address (probably 192.168.0.2).

At that point if you open a command prompt window on the computer with the 3G card, and run
route print
you can see exactly how ICS alters the routing table to send the wireless card traffic through the 3G adapter interface.

Another way to share them is adding a 3G router, such as the Cradlepoint CTR-350, Kyocera KR-1, D-Link DIR-450, Linksys WRT54G3G-VN, or others.  You plug your card in the router, turn the power on, it dials out (probably #777 or *98) and connects just as if it were plugged into your computer, then you can connect wirelessly or via cat5 to the router just like you do at home.  If you think you might want to check that out, I'd be happy to post some links for you.
Price range is $100 to $200 new... I've seen used-to-unopened KR-1's on the auction sites for $60-$75 lately...  since they've been replaced by the KR-2, which is a much larger unit... the KR-1 or one of the even-smaller Cradlepoint units should work fine for travel, though...  most even come with 12V 'lighter plug' type adapters to use them in your car/RV etc.
0
 

Author Comment

by:alicia1234
Comment Utility
OK, thanks. First step:

I enabled connection sharing by opening Network Connections, going to properties for the"National Access-Broadband Access" connection, advanced tab, then checking the box to share the connection. As soon as I do that, I get a warning that "The user name and password for this connection were not saved for use by all users. As a result, Internet Connection Sharing" can only dial this connection when you are logged on. To enable automatic dialing, save your usern name and password for all users in the Connect dialog". I clicked OK.

Then for the "Home networking connection", I selected "Wireless Network Connection" (the only other choice is Local Area Connection 6). I unchecked the boxes for  establishing a dial-up connection whenever another computer on the network accesses the internet, and for allowing other users to control or disable internet connection sharing. Then I get a warning "Since this connection is currently active, some settings will not take effect until the next time you dial it." So I disconnected and connect again.

Then I go into network connections, right-click on the "National Access - Broadband Access" and select properties. On the "networking" tab, when I view the properties TCP/IP, it still says "Obtain an address automatically". It's not getting set to the static IP of 192.168.0.1
0
 

Author Comment

by:alicia1234
Comment Utility
oops! I realized I should have been checking the wireless card for that IP address. Yes, it's there. So hold on while I try the rest of the stuff.
Thanks!
0
 

Author Comment

by:alicia1234
Comment Utility
OK. Went through all the steps. Double-checked that everything was done as you said, and that my results matched what you said I should get. On my husband's PC, 3G-Share does show up in the wireless networks list. I highlight it and click "Connect". It takes a while (maybe a minute?), then on that same "Choose a wireless network" screen, under 3G-Share, it says "Not connected" over on the right, but underneath the "Security-enabled computer-to-computer network" it says "You are currently connected to this network. To disconnect from this network, click Disconnect". And there is a disconnect button.
If I try to access the internet on my husbands pc, I get a "Dial-up connection" window where I can select from "3G Connection" (I have no idea what this is) or "National Access-Broadband Access". I select "National Access-Broadband Access". It has my Verizon broadband username already entered in (my card's phone number plus @vzw3g.com". I enter in the password (I know it's correct) and click "Connect". It gives an error that there is no dial tone (which, of course, there isn't because the card is not in that computer).
Any ideas?
0
 

Author Comment

by:alicia1234
Comment Utility
oh - but wait! When I closed out of that error window, the page I had tried to access on the internet is there. So I do have internet access on my husband's computer. Yay! BUT - why do I get that dial-up window?
0
 

Author Comment

by:alicia1234
Comment Utility
oh man - sorry - it's giving me the page "offline". I'm NOT able to access the internet.
0
 

Author Comment

by:alicia1234
Comment Utility
OK, on a hunch I though maybe I needed to connect to the 3G-Share network on MY pc first. So I did that. Got the same statuses as described above ("Not connected" on the right, but the "you are currently connected..." message at the bottom.
Meanwhile, on my husband's pc, I tried to connect again. As soon as I hit the "connect" button, MY pc said "Connected" at the top right corner of the window now instead of "Not connected". My husband's pc connected to the network, then after several seconds of "Acquiring network address", it said it was "Connected".
BUT when I try to access the internet on my husband's pc, it says the page I'm looking for is not available offline etc. I click "Connect" and and now I get the dial-up connection window again.
0
 

Author Comment

by:alicia1234
Comment Utility
If I do an ipconfig on my husband's pc, the ip address and default gateway are 169.254.63.226.
On my pc, IP for the wireless card is 192.168.0.1 with no default gateway.
For the PPP adapter (National Access-BroadbandAccess) IP and gateway are 75.221.84.176.
0
 

Author Comment

by:alicia1234
Comment Utility
I rebooted my husband's pc. The "Dial-up connection" window comes up automatically! I cancel out of it, it came up again, I cancelled out. Three times. Connected again to 3G-Share. Same IP address (it says it's autoconfiguration IP address). Is that the problem? Also I notice now that 3G-Share is "manual", not "on demand".
0
 

Author Comment

by:alicia1234
Comment Utility
On a hunch, I edited the wireless connection properties on my husband's computer and set the IP to a static address of 192.168.0.2. Now I can access the shared files on his pc from my pc.
However, he still cannot get out to the internet. Whenever I try to access the internet from his pc, I get the "Dial-up connection" box.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:alicia1234
Comment Utility
I have determined that it is the Windows Firewall on my pc that is causing the problem. I disabled the firewall. On my husband's pc, I set the tcp/ip properties for the wireless connection back to "obtain an IP address automatically".
Now the connection to 3G-Share works and I can access the internet on his computer.
I do have to connect my pc to the 3G-Share network first. Without that, my husband's pc won't connect.
0
 

Author Comment

by:alicia1234
Comment Utility
So now I've tried to figure out how to configure the firewall to do whatever it is that I need to make the Internet connection work but I can't figure it out. There's nowhere that I can say, basically, let this IP address have free range. I need help with that. Windows XP SP3.
I've upped points to 500 so I can get this question resolved.
Thanks.
0
 
LVL 44

Assisted Solution

by:Darr247
Darr247 earned 500 total points
Comment Utility
> If I try to access the internet on my husbands pc, I get a "Dial-up connection" window
> where I can select from "3G Connection"

What causes that is, in Control Panel->Internet Options, Connections tab. It's most-likely set to  'Always dial my default connection' - change it to 'Dial whenever...' and it should only try to dial when there is no network connection detected; or 'Never dial a connection'  and then he'll just have to remember to dial manually before he wants to access the internet.

You may want to set both of them up to share it, then no matter which one has the card in it the other one can share it.


> I have determined that it is the Windows Firewall on my pc that is causing the problem.

If you have the windows firewall enabled when you enable ICS, the ICS setup should open the ports/services that need to be open (that's why it takes so long after you check the box and click OK for it to finish... it's not just setting the wireless card's IP address). So the best way may be to UNshare it (uncheck the box in the Internet Connection Sharing section) and OK back out and close all windows. Then get back to the Advanced tab in the 3G adapter's Properties, check that the firewall is running, then re-check the box in the ICS section, select the wireless card from the picklist and let the 'hidden wizard' make all the settings again. See if that opens up the firewall properly.


Sorry I wasn't here to get and respond to your messages right away. I don't monitor this 24/7, that's just part of my username. :-)
If we keep chipping away at this, it should eventually work just the way you want it to. I have setup sharing a 3G connection exactly like this using wireless card to wireless card, NIC to NIC (with a crossover cable), NIC to router to multiple computers, NIC to access point to multiple wireless computers, and wireless card to wireless router to multiple NICs.  So please don't get too frustrated, and we'll get it eventually.
0
 

Author Comment

by:alicia1234
Comment Utility
Thanks ... will have to resume this in the morning. ;-)
0
 

Author Comment

by:alicia1234
Comment Utility
Ta Da!! It worked! I "unshared" the internet connection. Turned on the firewall. Shut down and restarted both computers. Then on my pc, I shared the internet connection again. Then on both computers, I connected to the 3G-Share network. Both computers do what they should.

Question: does it make sense that I have to connect my pc to the 3G-Share network too? If so, could you explain why?
0
 

Author Comment

by:alicia1234
Comment Utility
Here's my summary of what had to be done, just to have it all in one place, in case someone else wants to know:
On the PC that has the Verizon card in it ("host"):
 

Enable internet connection sharing (do this ONCE):

1.	Do not connect to the Verizon card yet.

2.	CP > Network Connections > Properties for the"National Access-Broadband Access" connection, Advanced tab; check the box to share the connection.

3.	Ignore the warning about the username and password not being saved.

4.	For the "Home networking connection", select "Wireless Network Connection"

5.	Uncheck the boxes for establishing a dial-up connection whenever another computer on the network accesses the internet, and for allowing other users to control or disable internet connection sharing.

6.	Now connect to the Verizon card through VZAccess (in the usual manner)
 

Check that the IP address is now correct:

1.	CP > Network Connections > Properties for "Wireless Network Connection"; General tab; select TCP/IP connection and click "Properties" button.  IP address should be static at 192.168.0.1 with a mask of 255.255.255.0 and no default gateway.
 

Create a new wireless adhoc network (do this ONCE):

1.	CP > Network Connections > Properties for "Wireless Network Connection", "Wireless Networks" tab, click "Advanced" button. Make sure that the radio button for "Any available network (access point preferred)" is selected, and that the box for "Automatically connect to non-preferred networks" is NOT checked. (These settings were already that way.) Click "Close".

2.	Back on the "Wireless Networks" tab, click the "Add" button:

"	For SSID: 3G-Share (case-sensitive; can be anything you want but be consistent)

"	At the bottom of that window check the ''This is a computer-to-computer (ad hoc) network ...'' box

"	Uncheck the box for "The key is provided to me automatically"

"	Enter a 10-digit key (for 64-Bit RC-4 encryption; less overhead than 128-bit). I used my home phone number without dashes.

3.	On the "Connection" tab, make sure that the box for "Connect when this network is in range" is NOT checked. Click "OK".

4.	Back on the "Wireless Networks" tab, there is now a new network listed as "3G-Share (On Demand)". The icon is a little broadband card, not an antenna.
 
 

On the second PC ("client": the one that will be sharing the internet connection):
 

Create a new wireless adhoc network (do this ONCE):

1.	Follow the above steps exactly, same as for setting it up on the host PC
 
 

Now, whenever you want to share the connection:

1.	On the host pc, establish the internet connection through the broadband card.

2.	On the host pc, connect to the 3G-Share wireless network.

"	It may say "not connected" at the top right, but say that it is connected in the area just below the security setting; when another pc connects, it will change to "connected" at the top right

3.	On the client pc, connect to the 3G-Share wireless network.
 
 

To switch between "normal home use" and sharing the Verizon card, on the host pc, set the IP for the "Wireless Network" connection:

"	Control Panel > Network Connections; right-click "Wireless Network" and select "Properties"; on "General" tab, highlight "Internet Protocol (TCP/IP)" and click "Properties" button:

"	For normal home use (using home's wireless network with router and AP point, etc): "Acquire address automatically"

"	For sharing Verizon card: 192.168.0.1 with mask 255.255.255.0

Open in new window

0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
> Question: does it make sense that I have to connect my pc to the 3G-Share network too?

Not really... I don't recall having to do that.  I don't usually use ad-hoc networks though (my S720 card is usually plugged into a KR-1 router), so maybe microsoft changed something since the last time I tried it.  I'll revisit that this afternoon (will be gone for a couple hours first) and see if it works that way here, too and I'm just mis-remembering.
0
 

Author Comment

by:alicia1234
Comment Utility
Well, it was working great most of the day. We were happily sharing the broadband internet connection, here in a little cottage by a river. Sigh. Then I noticed that my wireless icon in the system try had that balloon saying "Wireless network is now connected". It seems that it reset itself. Also, my Verizon broadband connection had to be re-established.

My husband could no longer access the internet. I disconnected him from 3G-Share and reconnected. No good. Shut down, restarted. No good. Tried the unshare/share fix on my pc. No good. The only way I could get him out to the internet again was to disable the firewall on the internet connection.

I'm totally confused. ;-(
0
 

Author Comment

by:alicia1234
Comment Utility
No new posts in a while so I will close this out. The basic technique that was given was correct, except that I still have this firewall issue. Oh well.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
I'm not sure what's going on with that. I have not had any problems like that whether using windows firewall or norton internet security's firewall.  Is he using other ports besides '80' (HTTP)?

If you want to see what ports are being used at any moment, you could use TCPView, which is made by SysInternals. They make some good utilities, and microsoft was so impressed with them they bought the company.

TCPView is on this page - http://technet.microsoft.com/en-us/sysinternals/677683af-3f5e-42ea-8116-9c92acd2c271.aspx

It shows open sockets... a socket is the IP address + port number, usually expressed like 192.168.0.2:80, and TCP will show the socket addresses open on the local AND the remote systems you're connected to.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Resolve DNS query failed errors for Exchange
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now