Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


freeze with _ char at start up = 82Q33 Express Integrated Graphics Controller + Linux

Posted on 2008-10-21
Medium Priority
Last Modified: 2013-12-15

The question is complicated and i am out of solution...

I installed linux pardus 2008 with Windows XP SP3 dual...(Windows is not a case in this question...)

The problem with Linux Pardus is:

When i start the machine, while the services are loading, it may come up with an error when i decrease init level...So, the error is the black screen freezes with _ char and cannot load KDE...

But, THIS OCCURS RANDOMLY...Sometimes, the black is passed perfectly and the KDE is loaded...Another thing is resolution is 1440x900...It's a weird solution for Intel i guess...

I think the problem is with the Intel 82Q33 Express Integrated Graphics Controller...

You may say: Check the repository for XORG-Server...I did...No use...
You may say: Change XORG.conf under /etc/X11, give some values to it...
You may say: Change the kernel parameter from:
root=LABEL=PARDUS_ROOT vga=791 splash=silent quiet resume=/dev/sda7

to xorg=safe...Please follow my steps that i am executing:

1) xorg=prob->error chains->_ char
2) xorg=safe->error chains->ok (I can see GUI but resolution is 800x600, I need 1440x900'ü, at the bottom there is error log)
3) xorg=off->error chains->startx->no init 5->fails
4) I installed  intel updates from test repository:
->error chains->_ (no safe or no off or no probe set)
5) xorg.conf-> Option "FramebufferCompression" "false"->error chains->_ char
6) step 4 + step5.+xorg=off->error chains->startx->fails
 In each machine there is the _ error randomly...After restart or close, then start operations, the problem still exists...

Step 2 the error log i got:
eth0: Mac 5, PHY: 6, PBA No: 1042ff-0ff
agpgart: Detected an Intel Q33 Chipset.
agpgart: AGP architecture is 256M @ 0xe0000000
rtc_coms 00:03: rtc core: registered rtc_cmos as rtc0
ACPI Exception (video-1613): AE_NOT_FOUND, Evaluating _DOD [20070126]
input: Video Bus as
ACPI: Video Device [GFX0] (multi-head: no rom: yes post: no)
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) ->IRQ 21
PCI: Setting latency timer of device 0000:00:1b.0 to 64

Now, after that i try to use 915resolution and this time i got this:

Intel chipset detected.  However, 915resolution was unable to determine the chipset type.
Chipset Id: 29d08086

Now, please help me...I got appr. 100 machines to execute your solution...Pardus distro is a unique distro but i have 100 machines...So, i can try your ubuntu/debian any distro solution...

I got plenty of machines here...Damn...And this question is far worthed 500 points definitely...

Best regards...

I am now attaching the original xorg.conf
Question by:jazzIIIlove
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
LVL 12

Author Comment

ID: 22770145
ok...let me tell behavior of machines:

For example: I opened today 6 machines to probe 1/6 fail...
A month ago when i try for 8 machines 4/8 fail...

When a machine fails to open Linux, he has a tendency of failing again...For that one machine, for 5 try, 3 fail...So, if he has a tendency to fail once, he fail again definitely...I am now sending a XORG.conf of 3/5 failing machine as snippet:

As you see for screen section, in the snippet, there is no resolution set...I had set that before to 1440x900 but again fails...

So, another i am now probing is:
<<Try commenting out this "BusId   "PCI:0:2:0"" from your /etc/X11/xorg.conf file, or play <<around with different values. like PCI:0:0:1 etc.

But i am hopeless...By the way, i asked this question before, but i had thought i have taken the image of master machine in a false way, that affected grub and graphic card driver...

I had that question deleted because of my busy job environment and to clarify the problem...

Again best regards...And i know this question is though...Thank you in advance...

Section "Module"
    SubSection "extmod"
        Option  "omit xfree86-dga" "true"
Section "dri"
    Mode    0666
Section "Files"
    RgbPath "/usr/lib/X11/rgb"
    FontPath    "/usr/share/fonts/misc/"
    FontPath    "/usr/share/fonts/dejavu/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath    "/usr/share/fonts/freefont/"
    FontPath    "/usr/share/fonts/TrueType/"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/Speedo/"
    FontPath    "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/75dpi/"
    FontPath    "/usr/share/fonts/encodings/"
Section "ServerFlags"
    Option  "SuspendTime" "0"
    Option  "OffTime" "0"
    Option  "BlankTime" "0"
    Option  "AllowMouseOpenFail" "true"
    Option  "StandbyTime" "0"
Section "InputDevice"
    Identifier  "Keyboard"
    Driver  "kbd"
    Option  "XkbLayout" "tr"
    Option  "XkbModel" "pc105"
    Option  "XkbVariant" "basic"
    Option  "CoreKeyboard" "true"
Section "InputDevice"
    Identifier  "Mouse"
    Driver  "mouse"
    Option  "CorePointer" "true"
Section "Device"
    Identifier  "VideoCard"
    Driver  "intel"
    VendorName  "Intel Corporation"
    BoardName   "82Q33 Express Integrated Graphics Controller"
    BusId   "PCI:0:2:0"
    Option  "Monitor-VGA" "Monitor[VGA]"
Section "Screen"
    Identifier  "Screen"
    Device  "VideoCard"
    Monitor "Monitor[VGA]"
    DefaultDepth    24
    SubSection "Display"
        Depth   24
Section "ServerLayout"
    Identifier  "Layout"
    Screen  "Screen"
Section "Monitor"
    Identifier  "Monitor[VGA]"
    Option  "Enable" "true"

Open in new window

LVL 12

Author Comment

ID: 22770411
<<Try commenting out this "BusId   "PCI:0:2:0"" from your /etc/X11/xorg.conf file, or play <<around with different values. like PCI:0:0:1 etc.

I deleted the line with busid but again in 3 machines, it failed and _ char is seen...

The interesting thing before i am changing the line, i select the machines that failed for the first time...After i edit, they worked well for couple startups...But interesting thing is they failed at the same try...

LVL 12

Author Comment

ID: 22770419
I caught t the error with my own eyes that every line is ACPI stg error...

Best regards...
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

LVL 12

Author Comment

ID: 22770475
I have an idea:

what is i set the xorg=safe, then in xorg.conf, append the line:

       Option         "ForceBIOS" "1024x768=1440x900"

LVL 12

Author Comment

ID: 22770501
 Option         "ForceBIOS" "640x480=1440x900"
LVL 12

Author Comment

ID: 22775683
I tried ACPI=off

no use...
LVL 12

Author Comment

ID: 22776338
i tried several combination noapic nolapic acpi=off pci=noacpi under grub.conf...

Each time a machine, random machine fails...out of 3 machines...

I am getting insane...

The error starts with acpi id 1 already in use...
LVL 12

Author Comment

ID: 22776447
Here i am now sending the log under /var/log as attachment:

And XORG.conf of the original installation that has failed once...
LVL 12

Author Comment

ID: 22777299
Ok...I am sending other files for you to check...I updated XORG help...

Please somebody help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
LVL 12

Author Comment

ID: 22777931
BIOS bug IO#ACPI 0 id 1 is already used.
Fixing upto 2.

What does that mean?
LVL 12

Author Comment

ID: 22778094
This is getting insane!

a small white dot in the right part of the screen, only one's the weirdest thing i have ever seen in my life!!
LVL 12

Author Comment

ID: 22780202
pci=bios kills 4 machines...96 left...
acpi=off noapic -> no use

I am using
LVL 12

Accepted Solution

jazzIIIlove earned 0 total points
ID: 22807850
ok...i solved the problem:

1) adding xorg=safe as kernel param...This will add some lines to xorg.conf...Reboot..
2) Removing xorg=safe and adding the 1440x900 resolution to xorg.conf...Reboot...This will cause the display card to have only one resolution as 1440x900 that will suffice my problem so the students cannot change the resolution to absurd values...



Featured Post

Certified OpenStack Administrator Course

We just refreshed our COA course based on the Newton exam.  With 14 labs, this course goes over the different OpenStack services that are part of the certification: Dashboard, Identity Service, Image Service, Networking, Compute, Object Storage, Block Storage, and Orchestration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question