• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 736
  • Last Modified:

freeze with _ char at start up = 82Q33 Express Integrated Graphics Controller + Linux

Hello...

The question is complicated and i am out of solution...

I installed linux pardus 2008 with Windows XP SP3 dual...(Windows is not a case in this question...)

The problem with Linux Pardus is:

When i start the machine, while the services are loading, it may come up with an error when i decrease init level...So, the error is the black screen freezes with _ char and cannot load KDE...

But, THIS OCCURS RANDOMLY...Sometimes, the black is passed perfectly and the KDE is loaded...Another thing is resolution is 1440x900...It's a weird solution for Intel i guess...

I think the problem is with the Intel 82Q33 Express Integrated Graphics Controller...

You may say: Check the repository for XORG-Server...I did...No use...
You may say: Change XORG.conf under /etc/X11, give some values to it...
You may say: Change the kernel parameter from:
root=LABEL=PARDUS_ROOT vga=791 splash=silent quiet resume=/dev/sda7

to xorg=safe...Please follow my steps that i am executing:

1) xorg=prob->error chains->_ char
2) xorg=safe->error chains->ok (I can see GUI but resolution is 800x600, I need 1440x900'ü, at the bottom there is error log)
3) xorg=off->error chains->startx->no init 5->fails
4) I installed  intel updates from test repository:
http://paketler.pardus.org.tr/pardus-2008-test/xorg-video-7.3-52-15.pisi
http://paketler.pardus.org.tr/pardus-2008-test/xorg-server-7.3-46-13.pisi
->error chains->_ (no safe or no off or no probe set)
5) xorg.conf-> Option "FramebufferCompression" "false"->error chains->_ char
6) step 4 + step5.+xorg=off->error chains->startx->fails
 In each machine there is the _ error randomly...After restart or close, then start operations, the problem still exists...

Step 2 the error log i got:
eth0: Mac 5, PHY: 6, PBA No: 1042ff-0ff
agpgart: Detected an Intel Q33 Chipset.
agpgart: AGP architecture is 256M @ 0xe0000000
rtc_coms 00:03: rtc core: registered rtc_cmos as rtc0
ACPI Exception (video-1613): AE_NOT_FOUND, Evaluating _DOD [20070126]
input: Video Bus as
/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:1e/input/input5
ACPI: Video Device [GFX0] (multi-head: no rom: yes post: no)
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) ->IRQ 21
PCI: Setting latency timer of device 0000:00:1b.0 to 64

Now, after that i try to use 915resolution and this time i got this:

Intel chipset detected.  However, 915resolution was unable to determine the chipset type.
Chipset Id: 29d08086

Now, please help me...I got appr. 100 machines to execute your solution...Pardus distro is a unique distro but i have 100 machines...So, i can try your ubuntu/debian any distro solution...

I got plenty of machines here...Damn...And this question is far worthed 500 points definitely...

Best regards...

I am now attaching the original xorg.conf
0
jazzIIIlove
Asked:
jazzIIIlove
  • 13
1 Solution
 
jazzIIIloveAuthor Commented:
ok...let me tell behavior of machines:

For example: I opened today 6 machines to probe 1/6 fail...
A month ago when i try for 8 machines 4/8 fail...

When a machine fails to open Linux, he has a tendency of failing again...For that one machine, for 5 try, 3 fail...So, if he has a tendency to fail once, he fail again definitely...I am now sending a XORG.conf of 3/5 failing machine as snippet:

As you see for screen section, in the snippet, there is no resolution set...I had set that before to 1440x900 but again fails...

So, another i am now probing is:
rindi:
<<Try commenting out this "BusId   "PCI:0:2:0"" from your /etc/X11/xorg.conf file, or play <<around with different values. like PCI:0:0:1 etc.

But i am hopeless...By the way, i asked this question before, but i had thought i have taken the image of master machine in a false way, that affected grub and graphic card driver...

I had that question deleted because of my busy job environment and to clarify the problem...

Again best regards...And i know this question is though...Thank you in advance...

Section "Module"
    SubSection "extmod"
        Option  "omit xfree86-dga" "true"
    EndSubSection
EndSection
 
Section "dri"
    Mode    0666
EndSection
 
Section "Files"
    RgbPath "/usr/lib/X11/rgb"
    FontPath    "/usr/share/fonts/misc/"
    FontPath    "/usr/share/fonts/dejavu/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath    "/usr/share/fonts/freefont/"
    FontPath    "/usr/share/fonts/TrueType/"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/Speedo/"
    FontPath    "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/75dpi/"
    FontPath    "/usr/share/fonts/encodings/"
EndSection
 
Section "ServerFlags"
    Option  "SuspendTime" "0"
    Option  "OffTime" "0"
    Option  "BlankTime" "0"
    Option  "AllowMouseOpenFail" "true"
    Option  "StandbyTime" "0"
EndSection
 
Section "InputDevice"
    Identifier  "Keyboard"
    Driver  "kbd"
    Option  "XkbLayout" "tr"
    Option  "XkbModel" "pc105"
    Option  "XkbVariant" "basic"
    Option  "CoreKeyboard" "true"
EndSection
 
Section "InputDevice"
    Identifier  "Mouse"
    Driver  "mouse"
    Option  "CorePointer" "true"
EndSection
 
Section "Device"
    Identifier  "VideoCard"
    Driver  "intel"
    VendorName  "Intel Corporation"
    BoardName   "82Q33 Express Integrated Graphics Controller"
    BusId   "PCI:0:2:0"
    Option  "Monitor-VGA" "Monitor[VGA]"
EndSection
 
Section "Screen"
    Identifier  "Screen"
    Device  "VideoCard"
    Monitor "Monitor[VGA]"
    DefaultDepth    24
    SubSection "Display"
        Depth   24
    EndSubSection
EndSection
 
Section "ServerLayout"
    Identifier  "Layout"
    Screen  "Screen"
EndSection
 
Section "Monitor"
    Identifier  "Monitor[VGA]"
    Option  "Enable" "true"
EndSection

Open in new window

0
 
jazzIIIloveAuthor Commented:
<<Try commenting out this "BusId   "PCI:0:2:0"" from your /etc/X11/xorg.conf file, or play <<around with different values. like PCI:0:0:1 etc.

I deleted the line with busid but again in 3 machines, it failed and _ char is seen...

The interesting thing before i am changing the line, i select the machines that failed for the first time...After i edit, they worked well for couple startups...But interesting thing is they failed at the same try...

Weird...
0
 
jazzIIIloveAuthor Commented:
I caught t the error with my own eyes that every line is ACPI stg error...

Best regards...
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
jazzIIIloveAuthor Commented:
I have an idea:

what is i set the xorg=safe, then in xorg.conf, append the line:

       Option         "ForceBIOS" "1024x768=1440x900"

??
0
 
jazzIIIloveAuthor Commented:
edit:
 Option         "ForceBIOS" "640x480=1440x900"
0
 
jazzIIIloveAuthor Commented:
I tried ACPI=off

no use...
0
 
jazzIIIloveAuthor Commented:
i tried several combination noapic nolapic acpi=off pci=noacpi under grub.conf...

Each time a machine, random machine fails...out of 3 machines...

I am getting insane...

The error starts with acpi id 1 already in use...
0
 
jazzIIIloveAuthor Commented:
Here i am now sending the log under /var/log as attachment:

And XORG.conf of the original installation that has failed once...
messages.txt
xorg.conf.txt
0
 
jazzIIIloveAuthor Commented:
Ok...I am sending other files for you to check...I updated XORG server...no help...

Please somebody help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
syslog.txt
Xorg.0.log.txt
Xorg.0.log.old.txt
0
 
jazzIIIloveAuthor Commented:
BIOS bug IO#ACPI 0 id 1 is already used.
Fixing upto 2.

What does that mean?
0
 
jazzIIIloveAuthor Commented:
This is getting insane!
pci=bios

a small white dot in the right part of the screen, only one dot...it's the weirdest thing i have ever seen in my life!!
0
 
jazzIIIloveAuthor Commented:
pci=bios kills 4 machines...96 left...
acpi=off noapic -> no use

I am using http://lxr.linux.no/linux+v2.6.24.7/Documentation/kernel-parameters.txt#L1194
0
 
jazzIIIloveAuthor Commented:
ok...i solved the problem:

1) adding xorg=safe as kernel param...This will add some lines to xorg.conf...Reboot..
2) Removing xorg=safe and adding the 1440x900 resolution to xorg.conf...Reboot...This will cause the display card to have only one resolution as 1440x900 that will suffice my problem so the students cannot change the resolution to absurd values...

Voila!

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 13
Tackle projects and never again get stuck behind a technical roadblock.
Join Now